aboutsummaryrefslogtreecommitdiff
path: root/lang/twelf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/twelf/Makefile')
-rw-r--r--lang/twelf/Makefile66
1 files changed, 42 insertions, 24 deletions
diff --git a/lang/twelf/Makefile b/lang/twelf/Makefile
index 78fd521463e7..cb6b20cd0587 100644
--- a/lang/twelf/Makefile
+++ b/lang/twelf/Makefile
@@ -2,41 +2,59 @@
# $FreeBSD$
PORTNAME= twelf
-PORTVERSION= 1.5R1
-PORTREVISION= 5
-CATEGORIES= lang
-MASTER_SITES= http://www-2.cs.cmu.edu/~twelf/dist/ http://www.cs.cmu.edu/~twelf/dist/
-DISTNAME= twelf-1-5R1
+PORTVERSION= 1.7.1
+CATEGORIES= lang math
+MASTER_SITES= http://twelf.plparty.org/releases/ \
+ http://www-2.cs.cmu.edu/~twelf/dist/ http://www.cs.cmu.edu/~twelf/dist/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= beyert@cs.ucr.edu
COMMENT= Meta-logical framework for deductive systems
-.if defined(WITH_MLTON)
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
RUN_DEPENDS= mlton:${PORTSDIR}/lang/mlton
BUILD_DEPENDS= mlton:${PORTSDIR}/lang/mlton
-.elif defined(WITH_SML_NJ_DEVEL)
-RUN_DEPENDS= sml:${PORTSDIR}/lang/sml-nj-devel
-BUILD_DEPENDS= sml:${PORTSDIR}/lang/sml-nj-devel
-.else
-RUN_DEPENDS= sml:${PORTSDIR}/lang/sml-nj
-BUILD_DEPENDS= sml:${PORTSDIR}/lang/sml-nj
-.endif
+USES= gmake
+ALL_TARGET= mlton
+PLIST_FILES= bin/${PORTNAME}-server
+PORTDATA= emacs examples examples-clp examples-delphin tex vim README
+PORTDOCS= dvi html info pdf ps
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
USE_TEX= tex:build
+BUILD_DEPENDS+= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
+BUILD_DEPENDS+= ${LOCALBASE}/bin/dvips:${PORTSDIR}/print/dvipsk-tetex
+.endif
-.if defined(WITH_MLTON)
-MAKEFILE= mlton/Makefile
-.elif defined(WITH_SML_NJ_DEVEL)
-MAKEFILE= smlnj/Makefile
+post-patch:
+.if ${PORT_OPTIONS:MDOCS}
+ @${REINPLACE_CMD} 's|-number|-number-sections|g' \
+ ${WRKSRC}/doc/guide/Makefile
+ @${REINPLACE_CMD} 's|twelf_\*.html|twelf/\*.html|g' \
+ ${WRKSRC}/doc/guide/Makefile
.endif
-WRKSRC= ${WRKDIR}/twelf
-INFO= twelf
+post-build:
+.if ${PORT_OPTIONS:MDOCS}
+ cd ${WRKSRC}/doc/guide && ${MAKE} all ${INSTALL_TARGET}
+.endif
-RESTRICTED= License is currently indeterminate (expected to be GPL)
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME}-server \
+ ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${STAGEDIR}${DATADIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR}
+.endif
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/Makefile
+WRKSRC= ${WRKDIR}/twelf
+INFO= twelf
.include <bsd.port.mk>