aboutsummaryrefslogtreecommitdiff
path: root/lang/yarv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/yarv/Makefile')
-rw-r--r--lang/yarv/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/lang/yarv/Makefile b/lang/yarv/Makefile
index d60ef4f8395f..b3b9da62af33 100644
--- a/lang/yarv/Makefile
+++ b/lang/yarv/Makefile
@@ -22,6 +22,7 @@ USE_RUBY= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} --program-suffix=20 \
--enable-shared --with-openssl-include=${OPENSSLINC}
+CONFIGURE_ARGS+=--enable-ipv6
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LIBS="${PTHREAD_LIBS}"
OPTIONS= DEBUG "Enable debugging information" off \
@@ -37,13 +38,6 @@ BROKEN= does not build
BROKEN= Does not build on 5.x
.endif
-.if ${OSVERSION} >= 400014
-CONFIGURE_ARGS+=--enable-ipv6
-.if ${OSVERSION} < 500000
-CONFIGURE_ARGS+=--enable-wide-getaddrinfo
-.endif
-.endif
-
.if defined(NOPORTDOCS)
INSTALL_TARGET= install-nodoc
PLIST_SUB+= PORTSDOCS="@comment "