aboutsummaryrefslogtreecommitdiff
path: root/lang/yorick
diff options
context:
space:
mode:
Diffstat (limited to 'lang/yorick')
-rw-r--r--lang/yorick/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/yorick/Makefile b/lang/yorick/Makefile
index 02ef9e708903..213e38d22229 100644
--- a/lang/yorick/Makefile
+++ b/lang/yorick/Makefile
@@ -56,4 +56,10 @@ post-install:
${INSTALL_DATA} $$f ${PREFIX}/${INFO_PATH}; \
done
+# Hidden by default: this requires an X terminal to run all checks
+.ifdef MAINTAINER_MODE
+regression-test: build
+ (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} check)
+.endif
+
.include <bsd.port.mk>