aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/dmd2/Makefile15
-rw-r--r--lang/dmd2/distinfo4
-rw-r--r--lang/dmd2/pkg-plist171
3 files changed, 88 insertions, 102 deletions
diff --git a/lang/dmd2/Makefile b/lang/dmd2/Makefile
index a4f6397456fa..fcd891f2f663 100644
--- a/lang/dmd2/Makefile
+++ b/lang/dmd2/Makefile
@@ -7,8 +7,7 @@
PORTNAME= dmd
PKGNAMESUFFIX= 2
-PORTVERSION= 2.059
-PORTREVISION= 1
+PORTVERSION= 2.060
CATEGORIES= lang
MASTER_SITES= http://ftp.digitalmars.com/
DISTNAME= dmd.${PORTVERSION}
@@ -26,10 +25,7 @@ DOCSDIR= ${PREFIX}/share/doc/dmd2
PORTDOCS= *.txt druntime/ html/ phobos/
WRKSRC= ${WRKDIR}/dmd2/src/${PORTNAME}
LICENSE_COMB= multi
-LICENSE= ART10 ZLIB DMD BSL
-LICENSE_NAME_ZLIB= zlib license
-LICENSE_PERMS_ZLIB= ${_LICENSE_PERMS_DEFAULT}
-LICENSE_FILE_ZLIB= ${WRKSRC}/../phobos/phoboslicense.txt
+LICENSE= ART10 DMD BSL
LICENSE_NAME_DMD= Digital Mars license
LICENSE_FILE_DMD= ${WRKSRC}/backendlicense.txt
LICENSE_PERMS_DMD= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell auto-accept
@@ -63,8 +59,6 @@ BUILD= release
MODULEDIR= ${PREFIX}/include/d/phobos2
post-patch:
- @${REINPLACE_CMD} -e "s|gcc|${CC}|" ${WRKSRC}/posix.mak \
- ${WRKSRC}/../phobos/etc/c/zlib/freebsd.mak
@${REINPLACE_CMD} -e "s|g++|${CXX}|" ${WRKSRC}/posix.mak
@${REINPLACE_CMD} -e "s|cc|${CC}|" ${WRKSRC}/../phobos/posix.mak
@${REINPLACE_CMD} -e "s|/etc|${PREFIX}/etc|" \
@@ -112,11 +106,10 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
cd ${WRKDIR}/dmd2 && ${COPYTREE_SHARE} html ${DOCSDIR}
${MKDIR} ${DOCSDIR}/druntime
- ${INSTALL_DATA} ${WRKSRC}/../druntime/LICENSE_1_0.txt ${DOCSDIR}/druntime
- ${INSTALL_DATA} ${WRKSRC}/../druntime/README.txt ${DOCSDIR}/druntime
+ ${INSTALL_DATA} ${WRKSRC}/../druntime/LICENSE ${DOCSDIR}/druntime
+ ${INSTALL_DATA} ${WRKSRC}/../druntime/README ${DOCSDIR}/druntime
cd ${WRKSRC}/../druntime && ${COPYTREE_SHARE} doc ${DOCSDIR}/druntime
${MKDIR} ${DOCSDIR}/phobos
- ${INSTALL_DATA} ${WRKSRC}/../phobos/phoboslicense.txt ${DOCSDIR}/phobos
${INSTALL_DATA} ${WRKSRC}/../phobos/std.ddoc ${DOCSDIR}/phobos
.endif
diff --git a/lang/dmd2/distinfo b/lang/dmd2/distinfo
index 30bde6da74da..3d45e2e0acb6 100644
--- a/lang/dmd2/distinfo
+++ b/lang/dmd2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dmd.2.059.zip) = 47c712f9c47e0ac156362dfbd5e90f6ed63eb6ffbd0cc96c7db3f9d48ccd9a50
-SIZE (dmd.2.059.zip) = 26217241
+SHA256 (dmd.2.060.zip) = 8da5b46e34e476c29155eff8507aa7a6a82545b1e236f27bad2b6613d2165498
+SIZE (dmd.2.060.zip) = 26819944
diff --git a/lang/dmd2/pkg-plist b/lang/dmd2/pkg-plist
index e895e9f6ad25..79776ace1d36 100644
--- a/lang/dmd2/pkg-plist
+++ b/lang/dmd2/pkg-plist
@@ -28,92 +28,92 @@ lib/libphobos2.a
%%EXAMPLESDIR%%/samples/d/wc2.d
%%EXAMPLESDIR%%/samples/d/winsamp.d
%%EXAMPLESDIR%%/samples/d/winsamp.def
-include/d/druntime/import/core/atomic.di
-include/d/druntime/import/core/bitop.di
-include/d/druntime/import/core/cpuid.di
-include/d/druntime/import/core/demangle.di
-include/d/druntime/import/core/exception.di
-include/d/druntime/import/core/math.di
-include/d/druntime/import/core/memory.di
-include/d/druntime/import/core/runtime.di
-include/d/druntime/import/core/simd.di
-include/d/druntime/import/core/stdc/complex.di
-include/d/druntime/import/core/stdc/config.di
-include/d/druntime/import/core/stdc/ctype.di
-include/d/druntime/import/core/stdc/errno.di
-include/d/druntime/import/core/stdc/fenv.di
-include/d/druntime/import/core/stdc/float_.di
-include/d/druntime/import/core/stdc/inttypes.di
-include/d/druntime/import/core/stdc/limits.di
-include/d/druntime/import/core/stdc/locale.di
-include/d/druntime/import/core/stdc/math.di
-include/d/druntime/import/core/stdc/signal.di
-include/d/druntime/import/core/stdc/stdarg.di
-include/d/druntime/import/core/stdc/stddef.di
-include/d/druntime/import/core/stdc/stdint.di
-include/d/druntime/import/core/stdc/stdio.di
-include/d/druntime/import/core/stdc/stdlib.di
-include/d/druntime/import/core/stdc/string.di
-include/d/druntime/import/core/stdc/tgmath.di
-include/d/druntime/import/core/stdc/time.di
-include/d/druntime/import/core/stdc/wchar_.di
-include/d/druntime/import/core/stdc/wctype.di
+include/d/druntime/import/core/atomic.d
+include/d/druntime/import/core/bitop.d
+include/d/druntime/import/core/cpuid.d
+include/d/druntime/import/core/demangle.d
+include/d/druntime/import/core/exception.d
+include/d/druntime/import/core/math.d
+include/d/druntime/import/core/memory.d
+include/d/druntime/import/core/runtime.d
+include/d/druntime/import/core/simd.d
+include/d/druntime/import/core/stdc/complex.d
+include/d/druntime/import/core/stdc/config.d
+include/d/druntime/import/core/stdc/ctype.d
+include/d/druntime/import/core/stdc/errno.d
+include/d/druntime/import/core/stdc/fenv.d
+include/d/druntime/import/core/stdc/float_.d
+include/d/druntime/import/core/stdc/inttypes.d
+include/d/druntime/import/core/stdc/limits.d
+include/d/druntime/import/core/stdc/locale.d
+include/d/druntime/import/core/stdc/math.d
+include/d/druntime/import/core/stdc/signal.d
+include/d/druntime/import/core/stdc/stdarg.d
+include/d/druntime/import/core/stdc/stddef.d
+include/d/druntime/import/core/stdc/stdint.d
+include/d/druntime/import/core/stdc/stdio.d
+include/d/druntime/import/core/stdc/stdlib.d
+include/d/druntime/import/core/stdc/string.d
+include/d/druntime/import/core/stdc/tgmath.d
+include/d/druntime/import/core/stdc/time.d
+include/d/druntime/import/core/stdc/wchar_.d
+include/d/druntime/import/core/stdc/wctype.d
include/d/druntime/import/core/sync/barrier.di
-include/d/druntime/import/core/sync/condition.di
+include/d/druntime/import/core/sync/rwmutex.di
include/d/druntime/import/core/sync/config.di
-include/d/druntime/import/core/sync/exception.di
include/d/druntime/import/core/sync/mutex.di
-include/d/druntime/import/core/sync/rwmutex.di
+include/d/druntime/import/core/sync/exception.di
include/d/druntime/import/core/sync/semaphore.di
-include/d/druntime/import/core/sys/freebsd/sys/event.di
-include/d/druntime/import/core/sys/osx/mach/kern_return.di
-include/d/druntime/import/core/sys/osx/mach/port.di
-include/d/druntime/import/core/sys/osx/mach/semaphore.di
-include/d/druntime/import/core/sys/osx/mach/thread_act.di
-include/d/druntime/import/core/sys/posix/arpa/inet.di
-include/d/druntime/import/core/sys/posix/config.di
-include/d/druntime/import/core/sys/posix/dirent.di
-include/d/druntime/import/core/sys/posix/dlfcn.di
-include/d/druntime/import/core/sys/posix/fcntl.di
-include/d/druntime/import/core/sys/posix/inttypes.di
-include/d/druntime/import/core/sys/posix/net/if_.di
-include/d/druntime/import/core/sys/posix/netinet/in_.di
-include/d/druntime/import/core/sys/posix/netinet/tcp.di
-include/d/druntime/import/core/sys/posix/netdb.di
-include/d/druntime/import/core/sys/posix/poll.di
-include/d/druntime/import/core/sys/posix/pthread.di
-include/d/druntime/import/core/sys/posix/pwd.di
-include/d/druntime/import/core/sys/posix/sched.di
-include/d/druntime/import/core/sys/posix/semaphore.di
-include/d/druntime/import/core/sys/posix/setjmp.di
-include/d/druntime/import/core/sys/posix/signal.di
-include/d/druntime/import/core/sys/posix/stdio.di
-include/d/druntime/import/core/sys/posix/stdlib.di
-include/d/druntime/import/core/sys/posix/sys/ipc.di
-include/d/druntime/import/core/sys/posix/sys/mman.di
-include/d/druntime/import/core/sys/posix/sys/select.di
-include/d/druntime/import/core/sys/posix/sys/shm.di
-include/d/druntime/import/core/sys/posix/sys/socket.di
-include/d/druntime/import/core/sys/posix/sys/stat.di
-include/d/druntime/import/core/sys/posix/sys/time.di
-include/d/druntime/import/core/sys/posix/sys/types.di
-include/d/druntime/import/core/sys/posix/sys/uio.di
-include/d/druntime/import/core/sys/posix/sys/un.di
-include/d/druntime/import/core/sys/posix/sys/utsname.di
-include/d/druntime/import/core/sys/posix/sys/wait.di
-include/d/druntime/import/core/sys/posix/termios.di
-include/d/druntime/import/core/sys/posix/time.di
-include/d/druntime/import/core/sys/posix/ucontext.di
-include/d/druntime/import/core/sys/posix/unistd.di
-include/d/druntime/import/core/sys/posix/utime.di
-include/d/druntime/import/core/sys/windows/dbghelp.di
-include/d/druntime/import/core/sys/windows/dll.di
-include/d/druntime/import/core/sys/windows/stacktrace.di
-include/d/druntime/import/core/sys/windows/threadaux.di
-include/d/druntime/import/core/sys/windows/windows.di
+include/d/druntime/import/core/sync/condition.di
include/d/druntime/import/core/thread.di
-include/d/druntime/import/core/time.di
-include/d/druntime/import/core/vararg.di
+include/d/druntime/import/core/sys/freebsd/sys/event.d
+include/d/druntime/import/core/sys/osx/mach/kern_return.d
+include/d/druntime/import/core/sys/osx/mach/port.d
+include/d/druntime/import/core/sys/osx/mach/semaphore.d
+include/d/druntime/import/core/sys/osx/mach/thread_act.d
+include/d/druntime/import/core/sys/posix/arpa/inet.d
+include/d/druntime/import/core/sys/posix/config.d
+include/d/druntime/import/core/sys/posix/dirent.d
+include/d/druntime/import/core/sys/posix/dlfcn.d
+include/d/druntime/import/core/sys/posix/fcntl.d
+include/d/druntime/import/core/sys/posix/inttypes.d
+include/d/druntime/import/core/sys/posix/net/if_.d
+include/d/druntime/import/core/sys/posix/netinet/in_.d
+include/d/druntime/import/core/sys/posix/netinet/tcp.d
+include/d/druntime/import/core/sys/posix/netdb.d
+include/d/druntime/import/core/sys/posix/poll.d
+include/d/druntime/import/core/sys/posix/pthread.d
+include/d/druntime/import/core/sys/posix/pwd.d
+include/d/druntime/import/core/sys/posix/sched.d
+include/d/druntime/import/core/sys/posix/semaphore.d
+include/d/druntime/import/core/sys/posix/setjmp.d
+include/d/druntime/import/core/sys/posix/signal.d
+include/d/druntime/import/core/sys/posix/stdio.d
+include/d/druntime/import/core/sys/posix/stdlib.d
+include/d/druntime/import/core/sys/posix/sys/ipc.d
+include/d/druntime/import/core/sys/posix/sys/mman.d
+include/d/druntime/import/core/sys/posix/sys/select.d
+include/d/druntime/import/core/sys/posix/sys/shm.d
+include/d/druntime/import/core/sys/posix/sys/socket.d
+include/d/druntime/import/core/sys/posix/sys/stat.d
+include/d/druntime/import/core/sys/posix/sys/time.d
+include/d/druntime/import/core/sys/posix/sys/types.d
+include/d/druntime/import/core/sys/posix/sys/uio.d
+include/d/druntime/import/core/sys/posix/sys/un.d
+include/d/druntime/import/core/sys/posix/sys/utsname.d
+include/d/druntime/import/core/sys/posix/sys/wait.d
+include/d/druntime/import/core/sys/posix/termios.d
+include/d/druntime/import/core/sys/posix/time.d
+include/d/druntime/import/core/sys/posix/ucontext.d
+include/d/druntime/import/core/sys/posix/unistd.d
+include/d/druntime/import/core/sys/posix/utime.d
+include/d/druntime/import/core/sys/windows/dbghelp.d
+include/d/druntime/import/core/sys/windows/dll.d
+include/d/druntime/import/core/sys/windows/stacktrace.d
+include/d/druntime/import/core/sys/windows/threadaux.d
+include/d/druntime/import/core/sys/windows/windows.d
+include/d/druntime/import/core/time.d
+include/d/druntime/import/core/vararg.d
include/d/druntime/import/object.di
include/d/phobos2/crc32.d
include/d/phobos2/etc/c/zlib.d
@@ -123,7 +123,6 @@ include/d/phobos2/std/array.d
include/d/phobos2/std/ascii.d
include/d/phobos2/std/base64.d
include/d/phobos2/std/bigint.d
-include/d/phobos2/std/bind.d
include/d/phobos2/std/bitmanip.d
include/d/phobos2/std/c/fenv.d
include/d/phobos2/std/c/freebsd/socket.d
@@ -151,15 +150,11 @@ include/d/phobos2/std/compiler.d
include/d/phobos2/std/complex.d
include/d/phobos2/std/concurrency.d
include/d/phobos2/std/container.d
-include/d/phobos2/std/contracts.d
include/d/phobos2/std/conv.d
include/d/phobos2/std/cpuid.d
include/d/phobos2/std/cstream.d
include/d/phobos2/std/csv.d
include/d/phobos2/std/ctype.d
-include/d/phobos2/std/date.d
-include/d/phobos2/std/datebase.d
-include/d/phobos2/std/dateparse.d
include/d/phobos2/std/datetime.d
include/d/phobos2/std/demangle.d
include/d/phobos2/std/encoding.d
@@ -168,7 +163,6 @@ include/d/phobos2/std/file.d
include/d/phobos2/std/format.d
include/d/phobos2/std/functional.d
include/d/phobos2/std/getopt.d
-include/d/phobos2/std/gregorian.d
include/d/phobos2/std/internal/math/biguintcore.d
include/d/phobos2/std/internal/math/biguintnoasm.d
include/d/phobos2/std/internal/math/biguintx86.d
@@ -179,7 +173,6 @@ include/d/phobos2/std/internal/uni_tab.d
include/d/phobos2/std/internal/processinit.d
include/d/phobos2/std/internal/windows/advapi32.d
include/d/phobos2/std/json.d
-include/d/phobos2/std/loader.d
include/d/phobos2/std/math.d
include/d/phobos2/std/mathspecial.d
include/d/phobos2/std/md5.d
@@ -200,7 +193,6 @@ include/d/phobos2/std/regexp.d
include/d/phobos2/std/signals.d
include/d/phobos2/std/socket.d
include/d/phobos2/std/socketstream.d
-include/d/phobos2/std/stdarg.d
include/d/phobos2/std/stdint.d
include/d/phobos2/std/stdio.d
include/d/phobos2/std/stdiobase.d
@@ -214,6 +206,7 @@ include/d/phobos2/std/typetuple.d
include/d/phobos2/std/uni.d
include/d/phobos2/std/uri.d
include/d/phobos2/std/utf.d
+include/d/phobos2/std/uuid.d
include/d/phobos2/std/variant.d
include/d/phobos2/std/windows/charset.d
include/d/phobos2/std/windows/iunknown.d