aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/php53-extensions/Makefile164
-rw-r--r--lang/php53/Makefile53
-rw-r--r--lang/php53/Makefile.ext103
3 files changed, 174 insertions, 146 deletions
diff --git a/lang/php53-extensions/Makefile b/lang/php53-extensions/Makefile
index 0d5c03ce69a1..4e78206c19d8 100644
--- a/lang/php53-extensions/Makefile
+++ b/lang/php53-extensions/Makefile
@@ -24,86 +24,7 @@ NO_BUILD= yes
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-WITH_CTYPE= yes
-WITH_DOM= yes
-WITH_FILTER= yes
-WITH_HASH= yes
-WITH_ICONV= yes
-WITH_JSON= yes
-WITH_PDO= yes
-WITH_PDO_SQLITE=yes
-WITH_PHAR= yes
-WITH_POSIX= yes
-WITH_SESSION= yes
-WITH_SIMPLEXML= yes
-WITH_SQLITE= yes
-WITH_SQLITE3= yes
-WITH_TOKENIZER= yes
-WITH_XML= yes
-WITH_XMLREADER= yes
-WITH_XMLWRITER= yes
-
-OPTIONS= BCMATH "bc style precision math functions" off \
- BZ2 "bzip2 library support" off \
- CALENDAR "calendar conversion support" off \
- CTYPE "ctype functions" on \
- CURL "CURL support" off \
- DBA "dba support" off \
- DOM "DOM support" on \
- EXIF "EXIF support" off \
- FILEINFO "fileinfo support" off \
- FILTER "input filter support" on \
- FTP "FTP support" off \
- GD "GD library support" off \
- GETTEXT "gettext library support" off \
- GMP "GNU MP support" off \
- HASH "HASH Message Digest Framework" on \
- ICONV "iconv support" on \
- IMAP "IMAP support" off \
- INTERBASE "Interbase 6 database support (Firebird)" off \
- JSON "JavaScript Object Serialization support" on \
- LDAP "OpenLDAP support" off \
- MBSTRING "multibyte string support" off \
- MCRYPT "Encryption support" off \
- MSSQL "MS-SQL database support" off \
- MYSQL "MySQL database support" off \
- MYSQLI "MySQLi database support" off \
- ODBC "ODBC support" off \
- OPENSSL "OpenSSL support" off \
- PCNTL "pcntl support (CLI only)" off \
- PDF "PDFlib support (implies GD)" off \
- PDO "PHP Data Objects Interface (PDO)" on \
- PDO_SQLITE "PDO sqlite driver" on \
- PGSQL "PostgreSQL database support" off \
- PHAR "phar support" on \
- POSIX "POSIX-like functions" on \
- PSPELL "pspell support" off \
- READLINE "readline support (CLI only)" off \
- RECODE "recode support" off \
- SESSION "session support" on \
- SHMOP "shmop support" off \
- SIMPLEXML "simplexml support" on \
- SNMP "SNMP support" off \
- SOAP "SOAP support" off \
- SOCKETS "sockets support" off \
- SQLITE "sqlite support" on \
- SQLITE3 "sqlite3 support" on \
- SYBASE_CT "Sybase database support" off \
- SYSVMSG "System V message support" off \
- SYSVSEM "System V semaphore support" off \
- SYSVSHM "System V shared memory support" off \
- TIDY "TIDY support" off \
- TOKENIZER "tokenizer support" on \
- WDDX "WDDX support (implies XML)" off \
- XML "XML support" on \
- XMLREADER "XMLReader support" on \
- XMLRPC "XMLRPC-EPI support" off \
- XMLWRITER "XMLWriter support" on \
- XSL "XSL support (Implies DOM)" off \
- ZIP "ZIP support" off \
- ZLIB "ZLIB support" off
-
-ALL_OPTIONS= BCMATH BZ2 CALENDAR CTYPE CURL DBA \
+OPTIONS_DEFINE= BCMATH BZ2 CALENDAR CTYPE CURL DBA \
DOM EXIF FILEINFO FILTER FTP GD GETTEXT \
GMP HASH ICONV IMAP INTERBASE JSON LDAP MBSTRING MCRYPT \
MSSQL MYSQL MYSQLI \
@@ -113,10 +34,89 @@ ALL_OPTIONS= BCMATH BZ2 CALENDAR CTYPE CURL DBA \
TIDY TOKENIZER WDDX XML XMLREADER XMLRPC XMLWRITER XSL \
ZIP ZLIB
+OPTIONS_DEFAULT= CTYPE \
+ DOM \
+ FILTER \
+ HASH \
+ ICONV \
+ JSON \
+ PDO \
+ PDO_SQLITE \
+ PHAR \
+ POSIX \
+ SESSION \
+ SIMPLEXML \
+ SQLITE \
+ SQLITE3 \
+ TOKENIZER \
+ XML \
+ XMLREADER \
+ XMLWRITER
+
+BCMATH_DESC= bc style precision math functions
+BZ2_DESC= bzip2 library support
+CALENDAR_DESC= calendar conversion support
+CTYPE_DESC= ctype functions
+CURL_DESC= CURL support
+DBA_DESC= dba support
+DOM_DESC= DOM support
+EXIF_DESC= EXIF support
+FILEINFO_DESC= fileinfo support
+FILTER_DESC= input filter support
+FTP_DESC= FTP support
+GD_DESC= GD library support
+GETTEXT_DESC= gettext library support
+GMP_DESC= GNU MP support
+HASH_DESC= HASH Message Digest Framework
+ICONV_DESC= iconv support
+IMAP_DESC= IMAP support
+INTERBASE_DESC= Interbase 6 database support (Firebird)
+JSON_DESC= JavaScript Object Serialization support
+LDAP_DESC= OpenLDAP support
+MBSTRING_DESC= multibyte string support
+MCRYPT_DESC= Encryption support
+MSSQL_DESC= MS-SQL database support
+MYSQL_DESC= MySQL database support
+MYSQLI_DESC= MySQLi database support
+ODBC_DESC= ODBC support
+OPENSSL_DESC= OpenSSL support
+PCNTL_DESC= pcntl support (CLI only)
+PDF_DESC= PDFlib support (implies GD)
+PDO_DESC= PHP Data Objects Interface (PDO)
+PDO_SQLITE_DESC= PDO sqlite driver
+PGSQL_DESC= PostgreSQL database support
+PHAR_DESC= phar support
+POSIX_DESC= POSIX-like functions
+PSPELL_DESC= pspell support
+READLINE_DESC= readline support (CLI only)
+RECODE_DESC= recode support
+SESSION_DESC= session support
+SHMOP_DESC= shmop support
+SIMPLEXML_DESC= simplexml support
+SNMP_DESC= SNMP support
+SOAP_DESC= SOAP support
+SOCKETS_DESC= sockets support
+SQLITE_DESC= sqlite support
+SQLITE3_DESC= sqlite3 support
+SYBASE_CT_DESC= Sybase database support
+SYSVMSG_DESC= System V message support
+SYSVSEM_DESC= System V semaphore support
+SYSVSHM_DESC= System V shared memory support
+TIDY_DESC= TIDY support
+TOKENIZER_DESC= tokenizer support
+WDDX_DESC= WDDX support (implies XML)
+XML_DESC= XML support
+XMLREADER_DESC= XMLReader support
+XMLRPC_DESC= XMLRPC-EPI support
+XMLWRITER_DESC= XMLWriter support
+XSL_DESC= XSL support (Implies DOM)
+ZIP_DESC= ZIP support
+ZLIB_DESC= ZLIB support
+
.include <bsd.port.options.mk>
-.for opt in ${ALL_OPTIONS}
-. if defined(WITH_${opt}) && !defined(WITHOUT_${opt})
+.for opt in ${OPTIONS_DEFINE}
+. if ${PORT_OPTIONS:M${opt}}
USE_PHP+= ${opt:L}
. endif
.endfor
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 769c47e5e4ec..6606e1670558 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -39,17 +39,20 @@ CONFIGURE_ARGS= \
USE_GNOME= libxml2
-OPTIONS= CLI "Build CLI version" on \
- CGI "Build CGI version" on \
- FPM "Build FPM version (experimental)" off \
- APACHE "Build Apache module" off \
- AP2FILTER " Use Apache 2.x filter interface (experimental)" off \
- DEBUG "Enable debug" off \
- SUHOSIN "Enable Suhosin protection system" on \
- MULTIBYTE "Enable zend multibyte support" off \
- IPV6 "Enable ipv6 support" on \
- MAILHEAD "Enable mail header patch" off \
- LINKTHR "Link thread lib (for threaded extensions)" off
+OPTIONS_DEFINE= CLI CGI FPM APACHE AP2FILTER DEBUG SUHOSIN MULTIBYTE IPV6 \
+ MAILHEAD LINKTHR
+
+OPTIONS_DEFAULT= CLI CGI SUHOSIN IPV6
+
+CLI_DESC= Build CLI version
+CGI_DESC= Build CGI version
+FPM_DESC= Build FPM version (experimental)
+APACHE_DESC= Build Apache module
+AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)
+SUHOSIN_DESC= Suhosin protection system
+MULTIBYTE_DESC= zend multibyte support
+MAILHEAD_DESC= mail header patch
+LINKTHR_DESC= Link thread lib (for threaded extensions)
CONFLICTS= php52-5* php5-5*
@@ -62,7 +65,7 @@ PATCH_DIST_STRIP= -p1
PATCH_SITES+= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= ale
-.if !defined(WITHOUT_SUHOSIN)
+.if ${PORT_OPTIONS:MSUHOSIN_DESC}
PATCHFILES+= suhosin-patch-5.3.x-0.9.10.patch.gz
PATCH_SITES+= http://download.suhosin.org/:suhosin
PLIST_SUB+= SUHOSIN=""
@@ -70,12 +73,12 @@ PLIST_SUB+= SUHOSIN=""
PLIST_SUB+= SUHOSIN="@comment "
.endif
-.if defined(WITH_MAILHEAD)
+.if ${PORT_OPTIONS:MMAILHEAD}
PATCHFILES+= php-5.3.x-mail-header.patch:mail
PATCH_SITES+= http://choon.net/opensource/php/:mail
.endif
-.if !defined(WITHOUT_CLI)
+.if ${PORT_OPTIONS:MCLI}
PHP_SAPI+= cli
PLIST_SUB+= CLI=""
MAN1+= php.1
@@ -84,7 +87,7 @@ PLIST_SUB+= CLI="@comment "
CONFIGURE_ARGS+=--disable-cli
.endif
-.if !defined(WITHOUT_CGI)
+.if ${PORT_OPTIONS:MCGI}
PHP_SAPI+= cgi
PLIST_SUB+= CGI=""
.else
@@ -92,7 +95,7 @@ PLIST_SUB+= CGI="@comment "
CONFIGURE_ARGS+=--disable-cgi
.endif
-.if defined(WITH_FPM)
+.if ${PORT_OPTIONS:MFPM}
PHP_SAPI+= fpm
MAN8+= php-fpm.8
USE_RC_SUBR+= php-fpm
@@ -104,11 +107,11 @@ PLIST_SUB+= FPM=""
PLIST_SUB+= FPM="@comment "
.endif
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
PHP_SAPI+= mod
USE_APACHE= 20+
.include "${PORTSDIR}/Mk/bsd.apache.mk"
-.if defined(WITH_AP2FILTER)
+.if ${PORT_OPTIONS:MAP2FILTER}
CONFIGURE_ARGS+=--with-apxs2filter=${APXS}
.else
CONFIGURE_ARGS+=--with-apxs2=${APXS}
@@ -140,26 +143,26 @@ CONFIGURE_ENV+= ac_cv_pthreads_lib="" \
pthreads_working="yes" \
lt_cv_path_SED="sed"
-.if defined(WITH_LINKTHR)
+.if ${PORT_OPTIONS:MLINKTHR}
CONFIGURE_ENV+= LIBS="${LIBS} ${PTHREAD_LIBS}"
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.endif
-.if defined(WITH_MULTIBYTE)
+.if ${PORT_OPTIONS:MMULTIBYTE}
CONFIGURE_ARGS+=--enable-zend-multibyte
.endif
-.if defined(WITHOUT_IPV6)
+.if empty(PORT_OPTIONS:MIPV6)
CONFIGURE_ARGS+=--disable-ipv6
.endif
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
-.if defined(WITH_FPM)
+.if ${PORT_OPTIONS:MFPM}
@${REINPLACE_CMD} -e "s|^;\(pid\)|\1|;s|^;\(pm\.[a-z_]*_servers\)|\1|" \
${WRKSRC}/sapi/fpm/php-fpm.conf.in
.endif
@@ -185,10 +188,10 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/php.ini-production ${PREFIX}/etc
@${INSTALL_DATA} ${WRKDIR}/php.conf ${PREFIX}/etc
@${TOUCH} ${PREFIX}/include/php/ext/php_config.h
-.if defined(WITH_FPM)
+.if ${PORT_OPTIONS:MFPM}
@${CP} -n ${PREFIX}/etc/php-fpm.conf.default ${PREFIX}/etc/php-fpm.conf
.endif
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
@${CAT} ${PKGMESSAGE}
.endif
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index e4097e116eb9..3f5488163b0a 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -40,12 +40,15 @@ CONFIGURE_ARGS+=--with-curl=${LOCALBASE}
.if ${PHP_MODNAME} == "dba"
CONFIGURE_ARGS+=--enable-dba
-OPTIONS= CDB "cdb database support" on \
- DB4 "Berkeley DB4 support" off \
- GDBM "GDBM database support" off \
- QDBM "QDBM database support" off \
- INIFILE "INI file support" on \
- FLATFILE "flatfile support" on
+OPTIONS_DEFINE= CDB DB4 GDBM QDBM INIFILE FLATFILE
+OPTIONS_DEFAULT= CDB INIFILE FLATFILE
+
+CDB_DESC= cdb database support
+DB4_DESC= Berkeley DB4 support
+GDBM_DESC= GDBM database support
+QDBM_DESC= QDBM database support
+INIFILE_DESC= INI file support
+FLATFILE_DESC= flatfile support
PHP_HEADER_DIRS= libcdb libflatfile libinifile
.endif
@@ -85,7 +88,7 @@ USE_OPENSSL= yes
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg
-. if !defined(WITHOUT_X11)
+. if !empty(PORT_OPTIONS:MX11)
USE_XORG= xpm
. endif
@@ -94,13 +97,17 @@ CONFIGURE_ARGS+=--with-gd \
--with-jpeg-dir=${LOCALBASE} \
--with-png-dir=${LOCALBASE} \
--with-zlib-dir=/usr
-. if !defined(WITHOUT_X11)
+. if !empty(PORT_OPTIONS:MX11)
CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
. endif
-OPTIONS= T1LIB "Include T1lib support" on \
- TRUETYPE "Enable TrueType string function" on \
- JIS "Enable JIS-mapped Japanese font support" off
+OPTIONS_DEFINE= T1LIB TRUETYPE JIS
+OPTIONS_DEFAULT= T1LIB TRUETYPE
+
+T1LIB_DESC= Include T1lib support
+TRUETYPE_DESC= TrueType string function
+JIS_DESC= JIS-mapped Japanese font support
+
PHP_HEADER_DIRS=libgd
.endif
@@ -133,7 +140,7 @@ LIB_DEPENDS+= c-client4.9:${PORTSDIR}/mail/cclient
CONFIGURE_ARGS+=--with-imap=${LOCALBASE} \
--with-pcre-dir=${LOCALBASE}
-.if !defined(WITHOUT_SSL)
+.if !empty(PORT_OPTIONS:MSSL)
CONFIGURE_ARGS+=--with-imap-ssl=${OPENSSLBASE}
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
@@ -166,7 +173,10 @@ CONFIGURE_ARGS+=--with-ldap-sasl
CONFIGURE_ARGS+=--enable-mbstring \
--with-pcre-dir=${LOCALBASE}
-OPTIONS= REGEX "Enable multibyte regex support" on
+OPTIONS_DEFINE= REGEX
+OPTIONS_DEFAULT= REGEX
+
+REGEX_DESC= multibyte regex support
PHP_HEADER_DIRS=libmbfl libmbfl/filters libmbfl/mbfl libmbfl/nls
.endif
@@ -186,17 +196,23 @@ CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mysql"
-OPTIONS= MYSQLND "Use MySQL Native Driver" on
+OPTIONS_DEFINE= MYSQLND
+OPTIONS_DEFAULT= MYSQLND
+
+MYSQLND_DESC= Use MySQL Native Driver"
.endif
.if ${PHP_MODNAME} == "mysqli"
-OPTIONS= MYSQLND "Use MySQL Native Driver" on
+OPTIONS_DEFINE= MYSQLND
+OPTIONS_DEFAULT= MYSQLND
+
+MYSQLND_DESC= Use MySQL Native Driver"
.endif
.if ${PHP_MODNAME} == "odbc"
CONFIGURE_ARGS+=--enable-odbc
-OPTIONS= IODBC "Use the iODBC driver instead of unixODBC" off
+OPTIONS_DEFINE= IODBC
.endif
.if ${PHP_MODNAME} == "openssl"
@@ -220,7 +236,9 @@ CONFIGURE_ARGS+=--with-pdo-dblib=${LOCALBASE}
USE_PHP= pdo
USE_PHP_BUILD= yes
-OPTIONS= MSSQL "Enable Microsoft SQL Server support" off
+OPTIONS_DEFINE= MSSQL
+
+MSSQL_DESC= Microsoft SQL Server support
.endif
.if ${PHP_MODNAME} == "pdo_firebird"
@@ -233,14 +251,19 @@ USE_FIREBIRD= yes
.endif
.if ${PHP_MODNAME} == "pdo_mysql"
-OPTIONS= MYSQLND "Use MySQL Native Driver" on
+OPTIONS_DEFINE= MYSQLND
+OPTIONS_DEFAULT= MYSQLND
+
+MYSQLND_DESC= Use MySQL Native Driver
USE_PHP= pdo
USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
-OPTIONS= IODBC "Use the iODBC driver instead of unixODBC" off
+OPTIONS_DEFINE= IODBC
+
+IODBC_DESC= Use the iODBC driver instead of unixODBC
USE_PHP= pdo
USE_PHP_BUILD= yes
@@ -347,7 +370,9 @@ USE_PHP= session
USE_PHP_BUILD= yes
PHP_HEADER_DIRS=libsqlite/src
-OPTIONS= UTF8 "Enable UTF-8 support" off
+OPTIONS_DEFINE= UTF8
+
+UTF8_DESC= UTF-8 support
.endif
.if ${PHP_MODNAME} == "sqlite3"
@@ -452,58 +477,58 @@ CONFIGURE_ARGS+=--with-zlib=/usr
.include <bsd.port.pre.mk>
.if ${PHP_MODNAME} == "dba"
-. if defined(WITHOUT_CDB)
+. if empty(PORT_OPTIONS:MCDB)
CONFIGURE_ARGS+=--without-cdb
. endif
-. if defined(WITH_DB4)
+. if ${PORT_OPTIONS:MDB4}
CONFIGURE_ARGS+=--with-db4=${LOCALBASE}
USE_BDB= 40+
WITH_BDB_HIGHEST= yes
. endif
-. if defined(WITH_GDBM)
+. if ${PORT_OPTIONS:MGDBM}
LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+=--with-gdbm=${LOCALBASE}
. endif
-. if defined(WITH_QDBM)
+. if ${PORT_OPTIONS:MQDBM}
LIB_DEPENDS+= qdbm.14:${PORTSDIR}/databases/qdbm
CONFIGURE_ARGS+=--with-qdbm=${LOCALBASE}
. endif
-. if defined(WITHOUT_INIFILE)
+. if empty(PORT_OPTIONS:MINIFILE)
CONFIGURE_ARGS+=--disable-inifile
. endif
-. if defined(WITHOUT_FLATFILE)
+. if empty(PORT_OPTIONS:MFLATFILE)
CONFIGURE_ARGS+=--disable-flatfile
. endif
.endif
.if ${PHP_MODNAME} == "gd"
-. if !defined(WITHOUT_T1LIB)
+. if ${PORT_OPTIONS:MT1LIB}
LIB_DEPENDS+= t1.5:${PORTSDIR}/devel/t1lib
CONFIGURE_ARGS+=--with-t1lib=${LOCALBASE}
. endif
-. if !defined(WITHOUT_TRUETYPE)
+. if ${PORT_OPTIONS:MTRUETYPE}
CONFIGURE_ARGS+=--enable-gd-native-ttf
. endif
-. if defined(WITH_JIS)
+. if ${PORT_OPTIONS:MJIS}
CONFIGURE_ARGS+=--enable-gd-jis-conv
. endif
.endif
.if ${PHP_MODNAME} == "mbstring"
-. if defined(WITHOUT_REGEX)
-CONFIGURE_ARGS+=--disable-mbregex
-. else
+. if ${PORT_OPTIONS:MREGEX}
LIB_DEPENDS+= onig.1:${PORTSDIR}/devel/oniguruma4
CONFIGURE_ARGS+=--with-onig=${LOCALBASE}
+. else
+CONFIGURE_ARGS+=--disable-mbregex
. endif
.endif
.if ${PHP_MODNAME} == "mysql"
-. if defined(WITH_MYSQLND)
+. if ${PORT_OPTIONS:MMYSQLND}
CONFIGURE_ARGS+=--with-mysql=mysqlnd
. else
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
@@ -514,7 +539,7 @@ USE_MYSQL= yes
.endif
.if ${PHP_MODNAME} == "mysqli"
-. if defined(WITH_MYSQLND)
+. if ${PORT_OPTIONS:MMYSQLND}
CONFIGURE_ARGS+=--with-mysqli=mysqlnd
. else
CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
@@ -529,7 +554,7 @@ post-extract:
.endif
.if ${PHP_MODNAME} == "odbc"
-.if defined(WITH_IODBC)
+.if ${PORT_OPTIONS:MIODBC}
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-iodbc=${LOCALBASE}
@@ -541,7 +566,7 @@ CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "pdo_dblib"
-.if defined(WITH_MSSQL)
+.if ${PORT_OPTIONS:MMSSQL}
LIB_DEPENDS+= sybdb.5:${PORTSDIR}/databases/freetds-msdblib
.else
LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
@@ -549,7 +574,7 @@ LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
-.if defined(WITH_IODBC)
+.if ${PORT_OPTIONS:MIODBC}
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-pdo-odbc=iODBC,${LOCALBASE}
@@ -561,7 +586,7 @@ CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "pdo_mysql"
-. if defined(WITH_MYSQLND)
+. if ${PORT_OPTIONS:MYSQLND}
CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
USE_PHP+= mysql
@@ -574,7 +599,7 @@ USE_MYSQL= yes
.endif
.if ${PHP_MODNAME} == "sqlite"
-. if defined(WITH_UTF8)
+. if ${PORT_OPTIONS:MUTF8}
CONFIGURE_ARGS+=--enable-sqlite-utf8
. endif
.endif