aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/php5-extensions/Makefile1
-rw-r--r--lang/php5/Makefile22
-rw-r--r--lang/php5/Makefile.ext50
-rw-r--r--lang/php5/distinfo4
-rw-r--r--lang/php5/pkg-plist3
5 files changed, 36 insertions, 44 deletions
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index 21562daf4632..59c864ba99c6 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -18,6 +18,7 @@ IGNORE_WITH_PHP=52 53
USE_PHP_BUILD= yes
NO_BUILD= yes
+NO_MTREE= yes
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 6ced2a4b10f5..aee65e0a1e8b 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= php5
-PORTVERSION= 5.4.20
+PORTVERSION= 5.4.21
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
@@ -21,7 +21,7 @@ NO_OPTIONS_SORT=yes
.if !defined(PKGNAMESUFFIX)
USE_AUTOTOOLS= autoconf
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS= \
--with-layout=GNU \
@@ -55,9 +55,8 @@ ZTS_DESC= Force Zend Thread Safety (ZTS) build
CONFLICTS= php52-5* php53-5* php55-5*
-MAN1= php-config.1 phpize.1
+DESTDIRNAME= INSTALL_ROOT
-NO_STAGE= yes
.include <bsd.port.pre.mk>
PATCH_DIST_STRIP= -p1
@@ -73,7 +72,6 @@ PATCH_SITES+= http://choon.net/opensource/php/:mail
.if ${PORT_OPTIONS:MCLI}
PHP_SAPI+= cli
PLIST_SUB+= CLI=""
-MAN1+= php.1
.else
PLIST_SUB+= CLI="@comment "
CONFIGURE_ARGS+=--disable-cli
@@ -82,7 +80,6 @@ CONFIGURE_ARGS+=--disable-cli
.if ${PORT_OPTIONS:MCGI}
PHP_SAPI+= cgi
PLIST_SUB+= CGI=""
-MAN1+= php-cgi.1
.else
PLIST_SUB+= CGI="@comment "
CONFIGURE_ARGS+=--disable-cgi
@@ -90,7 +87,6 @@ CONFIGURE_ARGS+=--disable-cgi
.if ${PORT_OPTIONS:MFPM}
PHP_SAPI+= fpm
-MAN8+= php-fpm.8
USE_RC_SUBR+= php-fpm
CONFIGURE_ARGS+=--enable-fpm \
--with-fpm-user=${WWWOWN} \
@@ -196,16 +192,8 @@ test: build
@(cd ${WRKSRC} && ${MAKE} test)
post-install:
- @${INSTALL_DATA} ${WRKSRC}/php.ini-development ${PREFIX}/etc
- @${INSTALL_DATA} ${WRKSRC}/php.ini-production ${PREFIX}/etc
- @${INSTALL_DATA} ${WRKDIR}/php.conf ${PREFIX}/etc
- @${TOUCH} ${PREFIX}/include/php/ext/php_config.h
-.if ${PORT_OPTIONS:MFPM}
- @${CP} -n ${PREFIX}/etc/php-fpm.conf.default ${PREFIX}/etc/php-fpm.conf || ${TRUE}
-.endif
-.if ${PORT_OPTIONS:MAPACHE}
- @${CAT} ${PKGMESSAGE}
-.endif
+ @${INSTALL_DATA} ${WRKSRC}/php.ini-development ${WRKSRC}/php.ini-production \
+ ${WRKDIR}/php.conf ${STAGEDIR}/${PREFIX}/etc
.else
.include "${MASTERDIR}/Makefile.ext"
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 81cdd263114c..ccd55d551b79 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--enable-ctype
.endif
.if ${PHP_MODNAME} == "curl"
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+=--with-curl=${LOCALBASE}
.endif
@@ -86,9 +86,9 @@ USE_OPENSSL= yes
.endif
.if ${PHP_MODNAME} == "gd"
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
- png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
CONFIGURE_ARGS+=--with-gd \
--with-freetype-dir=${LOCALBASE} \
@@ -115,7 +115,7 @@ USES+= gettext
.endif
.if ${PHP_MODNAME} == "gmp"
-LIB_DEPENDS+= gmp:${PORTSDIR}/math/gmp
+LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
.endif
@@ -132,7 +132,7 @@ USES+= iconv
.endif
.if ${PHP_MODNAME} == "imap"
-LIB_DEPENDS+= c-client4:${PORTSDIR}/mail/cclient
+LIB_DEPENDS+= libc-client4.so:${PORTSDIR}/mail/cclient
CONFIGURE_ARGS+=--with-imap=${LOCALBASE} \
--with-pcre-dir=${LOCALBASE}
@@ -178,7 +178,7 @@ PHP_HEADER_DIRS=libmbfl libmbfl/filters libmbfl/mbfl libmbfl/nls
.endif
.if ${PHP_MODNAME} == "mcrypt"
-LIB_DEPENDS+= mcrypt:${PORTSDIR}/security/libmcrypt
+LIB_DEPENDS+= libmcrypt.so:${PORTSDIR}/security/libmcrypt
CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
@@ -186,7 +186,7 @@ USE_AUTOTOOLS= libltdl
.endif
.if ${PHP_MODNAME} == "mssql"
-LIB_DEPENDS+= sybdb:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
@@ -303,7 +303,7 @@ CONFIGURE_ARGS+=--enable-posix
.endif
.if ${PHP_MODNAME} == "pspell"
-LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= libaspell.so:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
@@ -317,7 +317,7 @@ CONFIGURE_ARGS+=--with-readline=/usr
.endif
.if ${PHP_MODNAME} == "recode"
-LIB_DEPENDS+= recode:${PORTSDIR}/converters/recode
+LIB_DEPENDS+= librecode.so:${PORTSDIR}/converters/recode
CONFIGURE_ARGS+=--with-recode=${LOCALBASE}
.endif
@@ -345,7 +345,7 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
CONFIGURE_ENV+= ac_cv_buggy_snprint_value="no"
-LIB_DEPENDS+= netsnmp:${PORTSDIR}/net-mgmt/net-snmp
+LIB_DEPENDS+= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -370,7 +370,7 @@ CONFIGURE_ARGS+=--with-sqlite3=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "sybase_ct"
-LIB_DEPENDS+= ct:${PORTSDIR}/databases/freetds
+LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-sybase-ct=${LOCALBASE}
.endif
@@ -390,7 +390,7 @@ CONFIGURE_ARGS+=--enable-sysvshm
.if ${PHP_MODNAME} == "tidy"
CONFIGURE_ARGS+=--with-tidy=${LOCALBASE}
-LIB_DEPENDS+= tidy-0.99:${PORTSDIR}/www/tidy-lib
+LIB_DEPENDS+= libtidy-0.99.so:${PORTSDIR}/www/tidy-lib
.endif
.if ${PHP_MODNAME} == "tokenizer"
@@ -475,17 +475,17 @@ USE_BDB= 40+
WITH_BDB_HIGHEST= yes
. endif
. if ${PORT_OPTIONS:MGDBM}
-LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+=--with-gdbm=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MQDBM}
-LIB_DEPENDS+= qdbm:${PORTSDIR}/databases/qdbm
+LIB_DEPENDS+= libqdbm.so:${PORTSDIR}/databases/qdbm
CONFIGURE_ARGS+=--with-qdbm=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MTOKYO}
-LIB_DEPENDS+= tokyocabinet:${PORTSDIR}/databases/tokyocabinet
+LIB_DEPENDS+= libtokyocabinet.so:${PORTSDIR}/databases/tokyocabinet
CONFIGURE_ARGS+=--with-tcadb=${LOCALBASE}
. endif
@@ -499,7 +499,7 @@ CONFIGURE_ARGS+=--disable-flatfile
.if ${PHP_MODNAME} == "gd"
. if ${PORT_OPTIONS:MT1LIB}
-LIB_DEPENDS+= t1:${PORTSDIR}/devel/t1lib
+LIB_DEPENDS+= libt1.so:${PORTSDIR}/devel/t1lib
CONFIGURE_ARGS+=--with-t1lib=${LOCALBASE}
. endif
@@ -515,7 +515,7 @@ USE_XORG= xpm
CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MVPX}
-LIB_DEPENDS+= vpx:${PORTSDIR}/multimedia/libvpx
+LIB_DEPENDS+= libvpx.so:${PORTSDIR}/multimedia/libvpx
CONFIGURE_ARGS+=--with-vpx-dir=${LOCALBASE}
. endif
@@ -523,7 +523,7 @@ CONFIGURE_ARGS+=--with-vpx-dir=${LOCALBASE}
.if ${PHP_MODNAME} == "mbstring"
. if ${PORT_OPTIONS:MREGEX}
-LIB_DEPENDS+= onig:${PORTSDIR}/devel/oniguruma4
+LIB_DEPENDS+= libonig.so:${PORTSDIR}/devel/oniguruma4
CONFIGURE_ARGS+=--with-onig=${LOCALBASE}
. else
CONFIGURE_ARGS+=--disable-mbregex
@@ -558,11 +558,11 @@ post-extract:
.if ${PHP_MODNAME} == "odbc"
. if ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= iodbc:${PORTSDIR}/databases/libiodbc
+LIB_DEPENDS+= libiodbc.so:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-iodbc=${LOCALBASE}
. else
-LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
. endif
@@ -570,19 +570,19 @@ CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
.if ${PHP_MODNAME} == "pdo_dblib"
. if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= sybdb:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
. else
-LIB_DEPENDS+= ct:${PORTSDIR}/databases/freetds
+LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
. endif
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
. if ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= iodbc:${PORTSDIR}/databases/libiodbc
+LIB_DEPENDS+= libiodbc.so:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-pdo-odbc=iODBC,${LOCALBASE}
. else
-LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
. endif
diff --git a/lang/php5/distinfo b/lang/php5/distinfo
index 17852ceb1954..a17c97c8a480 100644
--- a/lang/php5/distinfo
+++ b/lang/php5/distinfo
@@ -1,4 +1,4 @@
-SHA256 (php-5.4.20.tar.bz2) = cd0e42cf8b01b2fe23d5acbb30e04d64e8df21b0b4093e28aef36743646759e1
-SIZE (php-5.4.20.tar.bz2) = 11700446
+SHA256 (php-5.4.21.tar.bz2) = ea8f7cee1adcc6f3c850f17334563c4a229f8792c18ca215517253b0dec656ec
+SIZE (php-5.4.21.tar.bz2) = 11703043
SHA256 (php-5.4.x-mail-header.patch) = 005ae1cd8ed17c72d7b09dee9c4466e8b16d4ecba7fe11276731ed6ff9fbb344
SIZE (php-5.4.x-mail-header.patch) = 3379
diff --git a/lang/php5/pkg-plist b/lang/php5/pkg-plist
index a0764077cfec..b7a68bbede7c 100644
--- a/lang/php5/pkg-plist
+++ b/lang/php5/pkg-plist
@@ -238,6 +238,9 @@ lib/php/build/shtool
%%APACHE%%%%APACHEMODDIR%%/%%AP_MODULE%%
%%APACHE%%@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %f
%%APACHE%%@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %f
+%%CGI%%man/man1/php-cgi.1.gz
+%%CLI%%man/man1/php.1.gz
+%%FPM%%man/man8/php-fpm.8.gz
%%FPM%%share/php/fpm/status.html
@dirrm include/php/TSRM
@dirrm include/php/Zend