aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/asn1c/Makefile2
-rw-r--r--lang/cyclone/Makefile8
-rw-r--r--lang/elk/Makefile2
-rw-r--r--lang/ferite/Makefile4
-rw-r--r--lang/gforth/Makefile4
-rw-r--r--lang/gprolog/Makefile2
-rw-r--r--lang/hugs/Makefile2
-rw-r--r--lang/libutils/Makefile2
-rw-r--r--lang/lua/Makefile2
-rw-r--r--lang/lua4/Makefile2
-rw-r--r--lang/lua50/Makefile2
-rw-r--r--lang/nickle/Makefile2
-rw-r--r--lang/onyx/Makefile2
-rw-r--r--lang/open-cobol-devel/Makefile2
-rw-r--r--lang/open-cobol/Makefile2
-rw-r--r--lang/python-devel/Makefile2
-rw-r--r--lang/python/Makefile2
-rw-r--r--lang/python23/Makefile2
-rw-r--r--lang/python24/Makefile2
-rw-r--r--lang/python25/Makefile2
-rw-r--r--lang/python26/Makefile2
-rw-r--r--lang/python27/Makefile2
-rw-r--r--lang/python30/Makefile2
-rw-r--r--lang/python31/Makefile2
-rw-r--r--lang/python32/Makefile2
-rw-r--r--lang/rscheme/Makefile2
-rw-r--r--lang/smalltalk/Makefile2
-rw-r--r--lang/swi-pl/Makefile2
-rw-r--r--lang/tensile/Makefile2
-rw-r--r--lang/xsb/Makefile2
-rw-r--r--lang/yabasic/Makefile2
-rw-r--r--lang/yap/Makefile2
32 files changed, 39 insertions, 35 deletions
diff --git a/lang/asn1c/Makefile b/lang/asn1c/Makefile
index d084903381c6..263e27ea644a 100644
--- a/lang/asn1c/Makefile
+++ b/lang/asn1c/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= vlm@lionet.info
COMMENT= Modern ASN.1 to C compiler
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_PERL5= yes
MAN1= asn1c.1 enber.1 unber.1
diff --git a/lang/cyclone/Makefile b/lang/cyclone/Makefile
index 9f4534a79cb8..a5b8080725c3 100644
--- a/lang/cyclone/Makefile
+++ b/lang/cyclone/Makefile
@@ -22,9 +22,9 @@ ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PLIST_SUB+= DOCSDIR=${DOCSDIR:S/^${PREFIX}\///} \
- PORTBLD=${ARCH}-portbld-freebsd${OSREL}
+ PORTBLD=${MACHINE_ARCH}-portbld-freebsd${OSREL}
ALL_TARGET= all gprof aprof
CYCBINDIR= ${PREFIX}/bin
CYCINCDIR= ${PREFIX}/include/cyclone
@@ -32,6 +32,10 @@ CYCLIBDIR= ${PREFIX}/lib/cyclone
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500000
+BROKEN= "Cannot convert header files on -CURRENT!"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR} ${DOCSDIR}/online-manual
diff --git a/lang/elk/Makefile b/lang/elk/Makefile
index 861d52d2bab0..07f2f2a605ad 100644
--- a/lang/elk/Makefile
+++ b/lang/elk/Makefile
@@ -21,7 +21,7 @@ USE_BZIP2= yes
USE_MOTIF= yes
USE_LIBTOOL_VER=13
LIBTOOLFLAGS= # none
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/lang/ferite/Makefile b/lang/ferite/Makefile
index 568161afacdb..c0f7ab668f96 100644
--- a/lang/ferite/Makefile
+++ b/lang/ferite/Makefile
@@ -20,11 +20,11 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes
-PLIST_SUB= ARCH=${ARCH}
+PLIST_SUB= MACHINE_ARCH=${MACHINE_ARCH}
MAN1= builder.1 ferite.1
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index 40ef3228c6f1..cf9b8f62726c 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -41,13 +41,13 @@ MAN1= gforth.1
# Local variables
#
-.if ${ARCH} == i386
+.if ${MACHINE_ARCH} == i386
WORDSIZE=32
.else
WORDSIZE=64
.endif
-.if ${ARCH} == sparc64
+.if ${MACHINE_ARCH} == sparc64
BYTEORDER=b
.else
BYTEORDER=l
diff --git a/lang/gprolog/Makefile b/lang/gprolog/Makefile
index ed94cd7417aa..a8765a57b71e 100644
--- a/lang/gprolog/Makefile
+++ b/lang/gprolog/Makefile
@@ -27,7 +27,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}.orig/src/src
USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 253
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-c-flags="${CFLAGS}" \
--with-doc-dir=none \
--with-examples-dir="${EXAMPLESDIR}"
diff --git a/lang/hugs/Makefile b/lang/hugs/Makefile
index 52ae2c98a7c8..de41b79e149c 100644
--- a/lang/hugs/Makefile
+++ b/lang/hugs/Makefile
@@ -37,7 +37,7 @@ PLIST_SUB+= X11="@comment "
MAN1= hugs.1
-.if ${ARCH:L} == "amd64"
+.if ${MACHINE_ARCH:L} == "amd64"
CFLAGS+= "-fPIC"
.endif
diff --git a/lang/libutils/Makefile b/lang/libutils/Makefile
index 909040e7243d..17ec79a9845f 100644
--- a/lang/libutils/Makefile
+++ b/lang/libutils/Makefile
@@ -19,7 +19,7 @@ COMMENT= Support lib for Tensile/NSL
USE_GMAKE= yes
USE_INC_LIBTOOL_VER=13
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAKE_ARGS= CFLAGS="${CFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/lang/lua/Makefile b/lang/lua/Makefile
index 06effc4359cb..227d4889b2a3 100644
--- a/lang/lua/Makefile
+++ b/lang/lua/Makefile
@@ -44,7 +44,7 @@ post-install:
@cd ${WRKSRC}/doc && ${INSTALL_DATA} *.html *.gif ${DOCSDIR}
.endif
-.if ${ARCH:L} == "amd64"
+.if ${MACHINE_ARCH:L} == "amd64"
CFLAGS+= -fPIC
.endif
diff --git a/lang/lua4/Makefile b/lang/lua4/Makefile
index e0a2c91eeb12..c79d286f7b62 100644
--- a/lang/lua4/Makefile
+++ b/lang/lua4/Makefile
@@ -48,7 +48,7 @@ post-install:
@${STRIP_CMD} ${PREFIX}/bin/lua
@${STRIP_CMD} ${PREFIX}/bin/luac
-.if ${ARCH:L} == "amd64"
+.if ${MACHINE_ARCH:L} == "amd64"
CFLAGS+= -fPIC
.endif
diff --git a/lang/lua50/Makefile b/lang/lua50/Makefile
index 06effc4359cb..227d4889b2a3 100644
--- a/lang/lua50/Makefile
+++ b/lang/lua50/Makefile
@@ -44,7 +44,7 @@ post-install:
@cd ${WRKSRC}/doc && ${INSTALL_DATA} *.html *.gif ${DOCSDIR}
.endif
-.if ${ARCH:L} == "amd64"
+.if ${MACHINE_ARCH:L} == "amd64"
CFLAGS+= -fPIC
.endif
diff --git a/lang/nickle/Makefile b/lang/nickle/Makefile
index c225faf5df24..539b59c7ca37 100644
--- a/lang/nickle/Makefile
+++ b/lang/nickle/Makefile
@@ -15,7 +15,7 @@ COMMENT= A desk calculator language
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
# Nickle now has bindings which are likely to pull in libraries that need
# libpthread. Link to it now, since it wouldn't work at runtime.
diff --git a/lang/onyx/Makefile b/lang/onyx/Makefile
index c04be4c428e7..0fe6db541e02 100644
--- a/lang/onyx/Makefile
+++ b/lang/onyx/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= edit.5:${PORTSDIR}/devel/libedit \
USE_BZIP2= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-libedit-prefix=${LOCALBASE} \
--with-pcre-prefix=${LOCALBASE}
INSTALLS_SHLIB= yes
diff --git a/lang/open-cobol-devel/Makefile b/lang/open-cobol-devel/Makefile
index d1ddcad65199..75c492113156 100644
--- a/lang/open-cobol-devel/Makefile
+++ b/lang/open-cobol-devel/Makefile
@@ -21,7 +21,7 @@ USE_LIBLTDL= yes
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
index d1ddcad65199..75c492113156 100644
--- a/lang/open-cobol/Makefile
+++ b/lang/open-cobol/Makefile
@@ -21,7 +21,7 @@ USE_LIBLTDL= yes
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/lang/python-devel/Makefile b/lang/python-devel/Makefile
index 68e64c32a310..e97fbac0eb7d 100644
--- a/lang/python-devel/Makefile
+++ b/lang/python-devel/Makefile
@@ -21,7 +21,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python/Makefile b/lang/python/Makefile
index a1f0311e0171..906d0506b333 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= stackless_python-*
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 8ca303cca73f..ebcd80d5b431 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= stackless_python-*
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index a1f0311e0171..906d0506b333 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= stackless_python-*
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 68e64c32a310..e97fbac0eb7d 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -21,7 +21,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 68e64c32a310..e97fbac0eb7d 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -21,7 +21,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 68e64c32a310..e97fbac0eb7d 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -21,7 +21,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index 68e64c32a310..e97fbac0eb7d 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -21,7 +21,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 68e64c32a310..e97fbac0eb7d 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -21,7 +21,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 68e64c32a310..e97fbac0eb7d 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -21,7 +21,7 @@ COMMENT?= An interpreted object-oriented programming language
DIST_SUBDIR= python
WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
diff --git a/lang/rscheme/Makefile b/lang/rscheme/Makefile
index 88ae4ef6d79b..1646fb33c845 100644
--- a/lang/rscheme/Makefile
+++ b/lang/rscheme/Makefile
@@ -15,7 +15,7 @@ DISTNAME= rs-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An object-oriented, extended version of the Scheme dialect of Lisp
-.if ${ARCH} != "i386"
+.if ${MACHINE_ARCH} != "i386"
BROKEN= "fails to install on ${ARCH}"
.endif
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index 9deccc3e26f1..351f896b0eae 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -21,7 +21,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --disable-gtk --without-emacs --without-gmp
diff --git a/lang/swi-pl/Makefile b/lang/swi-pl/Makefile
index 26bbe214bb82..210c00118345 100644
--- a/lang/swi-pl/Makefile
+++ b/lang/swi-pl/Makefile
@@ -26,7 +26,7 @@ GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --host=${ARCH}-${OPSYS:L} --disable-mt
+CONFIGURE_ARGS= --host=${MACHINE_ARCH}-${OPSYS:L} --disable-mt
MAN1= pl.1 plrc.1 plld.1
PLIST_SUB= DISTNAME=${DISTNAME} ARCH=${ARCH} OS=${OPSYS:L}
diff --git a/lang/tensile/Makefile b/lang/tensile/Makefile
index f98aac456e04..01d70d37fb84 100644
--- a/lang/tensile/Makefile
+++ b/lang/tensile/Makefile
@@ -25,7 +25,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=13
LIBTOOLFLAGS= # none
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-module-postgres
diff --git a/lang/xsb/Makefile b/lang/xsb/Makefile
index 94781a3fe6f5..7204f8b8c13d 100644
--- a/lang/xsb/Makefile
+++ b/lang/xsb/Makefile
@@ -23,7 +23,7 @@ USE_GMAKE= yes
MAN1= xsb.1
-PLIST_SUB+= ARCH=${ARCH} \
+PLIST_SUB+= MACHINE_ARCH=${MACHINE_ARCH} \
OPSYS=${OPSYS:S/BSD/bsd/g:S/F/f/g:S/O/o/g:S/N/n/g}
.include <bsd.port.pre.mk>
diff --git a/lang/yabasic/Makefile b/lang/yabasic/Makefile
index f580fcaee4a9..4b4c40f2ab88 100644
--- a/lang/yabasic/Makefile
+++ b/lang/yabasic/Makefile
@@ -17,7 +17,7 @@ USE_XLIB= yes
USE_BISON= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= yabasic.1
PORTDOCS= yabasic.htm
diff --git a/lang/yap/Makefile b/lang/yap/Makefile
index 90e22143bc7d..26af5f75c894 100644
--- a/lang/yap/Makefile
+++ b/lang/yap/Makefile
@@ -19,7 +19,7 @@ COMMENT= A high-performance Prolog compiler
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"