aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/etoile-languagekit/Makefile6
-rw-r--r--lang/mozart/Makefile8
-rw-r--r--lang/ocamlduce/Makefile2
-rw-r--r--lang/pugs/Makefile2
-rw-r--r--lang/u++/Makefile2
5 files changed, 14 insertions, 6 deletions
diff --git a/lang/etoile-languagekit/Makefile b/lang/etoile-languagekit/Makefile
index 66f816e88fe7..f1f901965daf 100644
--- a/lang/etoile-languagekit/Makefile
+++ b/lang/etoile-languagekit/Makefile
@@ -18,6 +18,10 @@ COMMENT= Etoile Project LanguageKit framework
BUILD_DEPENDS= llc:${PORTSDIR}/${LANGUAGEKIT_LLVM_PORT}
+BROKEN= needs llvm <= 2.6.r71086
+DEPRECATED= has been broken for over a half year
+EXPIRATION_DATE=2011-04-17
+
LICENSE= BSD
USE_BZIP2= yes
@@ -29,8 +33,6 @@ USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
USE_GNUSTEP_LOCAL_LIBS+= EtoileFoundation:${FOUNDATION_PORT}
USE_PERL5_BUILD= yes
-BROKEN= needs llvm <= 2.6.r71086
-
DEFAULT_LIBVERSION= 0.6
WRKSRC= ${WRKDIR}/Etoile-${PORTVERSION}
USE_GNUSTEP_MAKE_DIRS+= Languages/LanguageKit
diff --git a/lang/mozart/Makefile b/lang/mozart/Makefile
index 9a9b66164718..ce4b6982d51d 100644
--- a/lang/mozart/Makefile
+++ b/lang/mozart/Makefile
@@ -23,6 +23,10 @@ LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
gmp.10:${PORTSDIR}/math/gmp \
tk84.1:${PORTSDIR}/x11-toolkits/tk84
+BROKEN= Does not compile with GCC 4.2
+DEPRECATED= does not compile on FreeBSD 7.x or newer
+EXPIRATION_DATE=2011-04-17
+
MOZART_DOCS= mozart-${PORTVERSION}-doc.tar.gz
SCRIPTS_ENV= LN=${LN} PERL=${PERL}
@@ -47,10 +51,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX}/lib/oz \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.if ${ARCH} != "i386"
BROKEN= Does not compile on !i386
.endif
diff --git a/lang/ocamlduce/Makefile b/lang/ocamlduce/Makefile
index 4f32519366be..e0fb08a7423e 100644
--- a/lang/ocamlduce/Makefile
+++ b/lang/ocamlduce/Makefile
@@ -16,6 +16,8 @@ COMMENT= Library to integrate XML features into OCaml
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/lang/ocaml:extract
BROKEN= does not build
+DEPRECATED= has been broken for over a year
+EXPIRATION_DATE=2011-04-17
ALL_TARGET= prepare config/Makefile world world.opt
INSTALL_TARGET= installbyte installopt
diff --git a/lang/pugs/Makefile b/lang/pugs/Makefile
index 3f2f2ee5966c..887508fa15f3 100644
--- a/lang/pugs/Makefile
+++ b/lang/pugs/Makefile
@@ -30,6 +30,8 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
BROKEN= does not build
+DEPRECATED= has been broken for over a year
+EXPIRATION_DATE=2011-04-17
PERL_CONFIGURE= yes
WRKSRC= ${WRKDIR}/Perl6-Pugs-${PORTVERSION}
diff --git a/lang/u++/Makefile b/lang/u++/Makefile
index e5ff1e414ff3..541276ba5f57 100644
--- a/lang/u++/Makefile
+++ b/lang/u++/Makefile
@@ -22,6 +22,8 @@ EXTRACT_AFTER_ARGS= -b -e && \
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= Has not yet been ported to FreeBSD/amd64
BROKEN= does not build
+DEPRECATED= has been broken for over a half year
+EXPIRATION_DATE= 2011-04-17
USE_GMAKE= yes
USE_GCC= 4.2+