aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc/Makefile3
-rw-r--r--lang/gcc42/Makefile4
-rw-r--r--lang/gcc43/Makefile3
-rw-r--r--lang/gcc44/Makefile3
-rw-r--r--lang/gcc45/Makefile3
-rw-r--r--lang/gcc46/Makefile3
-rw-r--r--lang/gcc47/Makefile3
-rw-r--r--lang/gcc48/Makefile3
-rw-r--r--lang/gnat-gcc43/Makefile4
-rw-r--r--lang/gnat-gcc44/Makefile4
-rw-r--r--lang/gnat/Makefile4
11 files changed, 22 insertions, 15 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 0685d127b09e..8b0d3b9cf182 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.6.0.20100605
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -19,7 +20,7 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.6
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr \
+ mpfr.4:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index 5cada080983f..90ae927a2b9e 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.2.5.20090325
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -20,7 +20,7 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.2
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
VERSIONSTRING= ${PORTVERSION:C/([0-9]+\.[0-9]+).*\.([0-9]+)/\1-\2/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index 83e1204e9456..84f3a6b6ebe9 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.3.6.20100523
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -18,7 +19,7 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.3
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
.if defined(MAINTAINER_MODE)
DISTFILES+= gcc-testsuite-${VERSIONSTRING}${EXTRACT_SUFX}
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index 1535f0b8ec1e..02d1b32f86bc 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.4.5.20100518
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -19,7 +20,7 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.4
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 30ebe157d844..b3ba7345683b 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.5.1.20100603
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -19,7 +20,7 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.5
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr \
+ mpfr.4:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 0685d127b09e..8b0d3b9cf182 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.6.0.20100605
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -19,7 +20,7 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.6
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr \
+ mpfr.4:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 0685d127b09e..8b0d3b9cf182 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.6.0.20100605
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -19,7 +20,7 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.6
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr \
+ mpfr.4:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 0685d127b09e..8b0d3b9cf182 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 4.6.0.20100605
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -19,7 +20,7 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.6
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr \
+ mpfr.4:${PORTSDIR}/math/mpfr \
mpc.2:${PORTSDIR}/math/mpc
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
diff --git a/lang/gnat-gcc43/Makefile b/lang/gnat-gcc43/Makefile
index 2830f3574b3d..8647ef3049b2 100644
--- a/lang/gnat-gcc43/Makefile
+++ b/lang/gnat-gcc43/Makefile
@@ -9,7 +9,7 @@
PORTNAME= gnat-gcc
PORTVERSION= 4.3.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MASTER_SITES= GCC/releases/gcc-${PORTVERSION} \
CENKES:boot \
@@ -23,7 +23,7 @@ MAINTAINER= karel@lovetemple.net
COMMENT= The GNU Ada Compiler system
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
ONLY_FOR_ARCHS= i386
diff --git a/lang/gnat-gcc44/Makefile b/lang/gnat-gcc44/Makefile
index 3ef8e755b53e..fc30e61ae47b 100644
--- a/lang/gnat-gcc44/Makefile
+++ b/lang/gnat-gcc44/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnat-gcc
PORTVERSION= 4.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= GCC/releases/gcc-${PORTVERSION} \
http://coreland.ath.cx/data/code/gnatport/src/:boot
@@ -21,7 +21,7 @@ MAINTAINER= freebsd-ports@coreland.ath.cx
COMMENT= The GNU Ada Compiler system
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
BROKEN= fails to configure
diff --git a/lang/gnat/Makefile b/lang/gnat/Makefile
index 1d132f113ec4..b793529a1c80 100644
--- a/lang/gnat/Makefile
+++ b/lang/gnat/Makefile
@@ -14,7 +14,7 @@
PORTNAME= gnat
PORTVERSION= 2009
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_LOCAL}:boot
MASTER_SITE_SUBDIR= deischen/gcc/:boot
@@ -24,7 +24,7 @@ MAINTAINER= eischen@vigrid.com
COMMENT= The GNU Ada Compiler system
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
ONLY_FOR_ARCHS= i386