aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/q/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/q/Makefile b/lang/q/Makefile
index b4457b32caab..23c6f9fc9897 100644
--- a/lang/q/Makefile
+++ b/lang/q/Makefile
@@ -76,5 +76,8 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${GREP} -l "^examplesdir" | ${XARGS} ${REINPLACE_CMD} -e \
"s;[(]pkgdatadir[)]/examples;(datadir)/examples/@PACKAGE@;"
+ @${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} \
+ ${GREP} -l "<malloc\.h>" | ${XARGS} ${REINPLACE_CMD} \
+ -e "s,<malloc\.h>,<stdlib.h>,"
.include <bsd.port.mk>