aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby-devel/Makefile7
-rw-r--r--lang/ruby/Makefile7
-rw-r--r--lang/ruby16/Makefile7
-rw-r--r--lang/ruby18/Makefile7
4 files changed, 16 insertions, 12 deletions
diff --git a/lang/ruby-devel/Makefile b/lang/ruby-devel/Makefile
index baa79ab69494..2681751fbffc 100644
--- a/lang/ruby-devel/Makefile
+++ b/lang/ruby-devel/Makefile
@@ -104,12 +104,12 @@ post-extract:
${MV} ${WRKSRC}/ext/dl/h2rb ${WRKSRC}/bin/
post-patch:
- ${FIND} ${WRKSRC} -name '*.orig' -delete
+ ${FIND} ${PATCH_WRKSRC} -name '*.orig' -delete
.for d in Win32API
- ${RM} -rf ${WRKSRC}/ext/${d}
+ ${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
.for d in gdbm iconv tcltklib tk
- ${MV} ${WRKSRC}/ext/${d} ${WRKDIR}/
+ ${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
pre-configure:
@@ -118,6 +118,7 @@ pre-configure:
./configure; \
${MAKE} -f Makefile ${RUBY_VER:S/.//} RUBYDIR=${WRKSRC}
.endif
+ ${TOUCH} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
.if defined(STRIP) && ${STRIP} == -s
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 9d4fca959bd8..8610d90e11cc 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -92,12 +92,12 @@ OBSOLETED_MODULES= sha1 \
uri
post-patch:
- ${FIND} ${WRKSRC} -name '*.orig' -delete
+ ${FIND} ${PATCH_WRKSRC} -name '*.orig' -delete
.for d in Win32API
- ${RM} -rf ${WRKSRC}/ext/${d}
+ ${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
.for d in gdbm tcltklib tk
- ${MV} ${WRKSRC}/ext/${d} ${WRKDIR}/
+ ${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
pre-configure:
@@ -106,6 +106,7 @@ pre-configure:
./configure; \
${MAKE} -f Makefile ${RUBY_VER:S/.//} RUBYDIR=${WRKSRC}
.endif
+ ${TOUCH} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
.if defined(STRIP) && ${STRIP} == -s
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index 9d4fca959bd8..8610d90e11cc 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -92,12 +92,12 @@ OBSOLETED_MODULES= sha1 \
uri
post-patch:
- ${FIND} ${WRKSRC} -name '*.orig' -delete
+ ${FIND} ${PATCH_WRKSRC} -name '*.orig' -delete
.for d in Win32API
- ${RM} -rf ${WRKSRC}/ext/${d}
+ ${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
.for d in gdbm tcltklib tk
- ${MV} ${WRKSRC}/ext/${d} ${WRKDIR}/
+ ${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
pre-configure:
@@ -106,6 +106,7 @@ pre-configure:
./configure; \
${MAKE} -f Makefile ${RUBY_VER:S/.//} RUBYDIR=${WRKSRC}
.endif
+ ${TOUCH} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
.if defined(STRIP) && ${STRIP} == -s
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index baa79ab69494..2681751fbffc 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -104,12 +104,12 @@ post-extract:
${MV} ${WRKSRC}/ext/dl/h2rb ${WRKSRC}/bin/
post-patch:
- ${FIND} ${WRKSRC} -name '*.orig' -delete
+ ${FIND} ${PATCH_WRKSRC} -name '*.orig' -delete
.for d in Win32API
- ${RM} -rf ${WRKSRC}/ext/${d}
+ ${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
.for d in gdbm iconv tcltklib tk
- ${MV} ${WRKSRC}/ext/${d} ${WRKDIR}/
+ ${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
pre-configure:
@@ -118,6 +118,7 @@ pre-configure:
./configure; \
${MAKE} -f Makefile ${RUBY_VER:S/.//} RUBYDIR=${WRKSRC}
.endif
+ ${TOUCH} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
.if defined(STRIP) && ${STRIP} == -s