aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/io/Makefile.addons4
-rw-r--r--lang/ofc/Makefile3
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php55/Makefile.ext4
-rw-r--r--lang/php56/Makefile.ext4
-rw-r--r--lang/pike78/Makefile5
-rw-r--r--lang/racket/Makefile3
-rw-r--r--lang/swi-pl/Makefile3
8 files changed, 13 insertions, 17 deletions
diff --git a/lang/io/Makefile.addons b/lang/io/Makefile.addons
index 112f8e6d5e04..73c6d62bcc3b 100644
--- a/lang/io/Makefile.addons
+++ b/lang/io/Makefile.addons
@@ -127,9 +127,9 @@ LIB_DEPENDS+= libglfw.so.0:${PORTSDIR}/graphics/glfw2
# Image
#
.if ${PORT_OPTIONS:MImage}
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
+USES+= jpeg
.endif
#
diff --git a/lang/ofc/Makefile b/lang/ofc/Makefile
index 9fa17a6732a1..c3889caa3560 100644
--- a/lang/ofc/Makefile
+++ b/lang/ofc/Makefile
@@ -12,12 +12,11 @@ COMMENT= The Objective-C Foundation Classes library
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libfreetype.so:${PORTSDIR}/print/freetype2
PROJECTHOST= ${PORTNAME}
USE_SDL= sdl
-USES= libtool objc pathfix
+USES= jpeg libtool objc pathfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 8335c5c05e79..660c47d1e0fd 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -87,8 +87,8 @@ USE_OPENSSL= yes
.if ${PHP_MODNAME} == "gd"
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+ libpng.so:${PORTSDIR}/graphics/png
+USES+= jpeg
CONFIGURE_ARGS+=--with-gd \
--with-freetype-dir=${LOCALBASE} \
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index 4535f2b7f32b..ebccd09874c5 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -87,8 +87,8 @@ USE_OPENSSL= yes
.if ${PHP_MODNAME} == "gd"
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+ libpng.so:${PORTSDIR}/graphics/png
+USES+= jpeg
CONFIGURE_ARGS+=--with-gd \
--with-freetype-dir=${LOCALBASE} \
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index edacc0e78e18..8991791cdb18 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -87,8 +87,8 @@ USE_OPENSSL= yes
.if ${PHP_MODNAME} == "gd"
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+ libpng.so:${PORTSDIR}/graphics/png
+USES+= jpeg
CONFIGURE_ARGS+=--with-gd \
--with-freetype-dir=${LOCALBASE} \
diff --git a/lang/pike78/Makefile b/lang/pike78/Makefile
index 08d227307cf0..75d92bc1be3e 100644
--- a/lang/pike78/Makefile
+++ b/lang/pike78/Makefile
@@ -13,8 +13,7 @@ DISTNAME= Pike-v${PORTVERSION}
MAINTAINER= johans@FreeBSD.org
COMMENT= Dynamic programming language with a syntax similar to C++
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libtiff.so:${PORTSDIR}/graphics/tiff \
+LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libgdbm.so:${PORTSDIR}/databases/gdbm \
libpcre.so:${PORTSDIR}/devel/pcre \
libgmp.so:${PORTSDIR}/math/gmp \
@@ -79,7 +78,7 @@ CONFIGURE_ARGS+= --without-debug \
--without-sybase \
--prefix=${PREFIX}
-USES= bison gettext gmake perl5
+USES= bison gettext gmake jpeg perl5
PLIST_FILES= bin/pike bin/pike78 bin/hilfe \
man/man1/pike.1.gz
diff --git a/lang/racket/Makefile b/lang/racket/Makefile
index 5406d0883fac..83982e64e833 100644
--- a/lang/racket/Makefile
+++ b/lang/racket/Makefile
@@ -18,7 +18,6 @@ COMMENT= Interactive, integrated, graphical Scheme programming environment
LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi \
libcairo.so:${PORTSDIR}/graphics/cairo \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png
MAKE_JOBS_UNSAFE=yes
@@ -36,7 +35,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/racket-${PORTVERSION}/src
-USES= iconv libtool tar:tgz
+USES= iconv jpeg libtool tar:tgz
USE_LDCONFIG= yes
USE_GNOME= pango
USE_SQLITE= 3
diff --git a/lang/swi-pl/Makefile b/lang/swi-pl/Makefile
index 8a83c5a6e2e8..c9396ee3981f 100644
--- a/lang/swi-pl/Makefile
+++ b/lang/swi-pl/Makefile
@@ -11,7 +11,6 @@ MAINTAINER= johans@FreeBSD.org
COMMENT= Edinburgh-style Prolog compiler
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libodbc.so:${PORTSDIR}/databases/unixODBC
CFLAGS+= -I${LOCALBASE}/include
@@ -21,7 +20,7 @@ SWIPLDIR= ${PORTNAME:C/-//}-${PORTVERSION}
NOPRECIOUSMAKEVARS= yes
USE_XORG= xft xpm xt
-USES= pkgconfig pathfix gmake shebangfix
+USES= gmake jpeg pathfix pkgconfig shebangfix
MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ARCH=${ARCH}-${OPSYS:tl}