aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/ocamlduce/Makefile36
-rw-r--r--lang/ocamlduce/distinfo3
-rw-r--r--lang/ocamlduce/pkg-descr3
-rw-r--r--lang/ocamlduce/pkg-plist22
5 files changed, 65 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 862d8e8912c9..02ef8b6cc91c 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -177,6 +177,7 @@
SUBDIR += ocaml-examples
SUBDIR += ocaml-mode.el
SUBDIR += ocaml-nox11
+ SUBDIR += ocamlduce
SUBDIR += ofc
SUBDIR += ohugs
SUBDIR += onyx
diff --git a/lang/ocamlduce/Makefile b/lang/ocamlduce/Makefile
new file mode 100644
index 000000000000..7123e5c067f8
--- /dev/null
+++ b/lang/ocamlduce/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ocamlduce
+# Date created: Feb 24, 2007
+# Whom: Jaap Boender <jaapb@kerguelen.rg>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ocamlduce
+PORTVERSION= 3.09.3
+CATEGORIES= lang
+MASTER_SITES= http://gallium.inria.fr/~frisch/ocamlcduce/download/
+PKGNAMESUFFIX= pl1
+DISTNAME= ${PORTNAME}-${PORTVERSION}${PKGNAMESUFFIX}
+
+MAINTAINER= jaapb@kerguelen.org
+COMMENT= Library to integrate XML features into OCaml
+
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+
+ALL_TARGET= all opt
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+.if !exists(${OCAMLFIND_LDCONF})
+ ${TOUCH} ${OCAMLFIND_LDCONF}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/ocamlduce/distinfo b/lang/ocamlduce/distinfo
new file mode 100644
index 000000000000..fb3ef75f052e
--- /dev/null
+++ b/lang/ocamlduce/distinfo
@@ -0,0 +1,3 @@
+MD5 (ocamlduce-3.09.3pl1.tar.gz) = 341e04b8fc7e9c211ae270ae2135e83a
+SHA256 (ocamlduce-3.09.3pl1.tar.gz) = 19f5151790f85d282de7f7f7c8282d2e0562670fc54a97d1acd98be0b8df651b
+SIZE (ocamlduce-3.09.3pl1.tar.gz) = 944146
diff --git a/lang/ocamlduce/pkg-descr b/lang/ocamlduce/pkg-descr
new file mode 100644
index 000000000000..9b6e6159d53f
--- /dev/null
+++ b/lang/ocamlduce/pkg-descr
@@ -0,0 +1,3 @@
+OCamlDuce is an enhancement to OCaml that allows you to use XML types.
+
+WWW: http://www.cduce.org/ocaml
diff --git a/lang/ocamlduce/pkg-plist b/lang/ocamlduce/pkg-plist
new file mode 100644
index 000000000000..677d22f694f5
--- /dev/null
+++ b/lang/ocamlduce/pkg-plist
@@ -0,0 +1,22 @@
+%%OCAML_SITELIBDIR%%/ocamlduce/META
+%%OCAML_SITELIBDIR%%/ocamlduce/cduce_types.cmi
+%%OCAML_SITELIBDIR%%/ocamlduce/cduce_types.o
+%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.a
+%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.cma
+%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.cmi
+%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.cmxa
+%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.mli
+%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.o
+%%OCAML_SITELIBDIR%%/ocamlduce/topdirs.cmi
+%%OCAML_SITELIBDIR%%/ocamlduce/toplevelducelib.cma
+%%OCAML_SITELIBDIR%%/ocamlduce/toploop.cmi
+%%OCAML_SITELIBDIR%%/ocamlduce/topmain.cmi
+%%OCAML_SITELIBDIR%%/ocamlduce/topstart.cmo
+bin/ocamlducec
+bin/ocamlduce
+bin/ocamlducedep
+bin/ocamlducedoc
+bin/ocamlduceopt
+bin/ocamlducemktop
+bin/expungeduce
+bin/ocamlducefind