aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/python-devel/Makefile6
-rw-r--r--lang/python/Makefile6
-rw-r--r--lang/python20/Makefile6
-rw-r--r--lang/python21/Makefile6
-rw-r--r--lang/python22/Makefile6
-rw-r--r--lang/python23/Makefile6
-rw-r--r--lang/python24/Makefile6
-rw-r--r--lang/python25/Makefile6
-rw-r--r--lang/python26/Makefile6
-rw-r--r--lang/python27/Makefile6
-rw-r--r--lang/python30/Makefile6
-rw-r--r--lang/python31/Makefile6
-rw-r--r--lang/python32/Makefile6
13 files changed, 78 insertions, 0 deletions
diff --git a/lang/python-devel/Makefile b/lang/python-devel/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python-devel/Makefile
+++ b/lang/python-devel/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python20/Makefile b/lang/python20/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python20/Makefile
+++ b/lang/python20/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python21/Makefile b/lang/python21/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python21/Makefile
+++ b/lang/python21/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python22/Makefile b/lang/python22/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python22/Makefile
+++ b/lang/python22/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 44a654b5a30b..6663762a106f 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -76,6 +76,12 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 400000
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif