aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/tcl82/Makefile7
-rw-r--r--lang/tcl83/Makefile6
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/tcl82/Makefile b/lang/tcl82/Makefile
index cbd0b4acb2d1..2bcd1021fd02 100644
--- a/lang/tcl82/Makefile
+++ b/lang/tcl82/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tcl
PORTVERSION= 8.2.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang tcl82
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= tcl8_2
@@ -26,6 +26,7 @@ MAKE_ENV= SHORT_TCL_VER=82
PKGINSTALL= ${PKGDIR}/pkg-install.tclsh
PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.tclsh
NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
+USE_REINPLACE= YES
PLIST_SUB= TCL_VER=8.2 SHORT_TCL_VER=82
@@ -369,6 +370,10 @@ MLINKS= Access.3 Tcl_Access.3 \
pkgMkIndex.n pkg_mkIndex.n \
safe.n Safe\Base.n
+post-configure:
+ ${REINPLACE_CMD} -e 's=${WRKDIRPREFIX}=$${WRKDIRPREFIX}=' \
+ ${WRKSRC}/tclConfig.sh
+
.include <bsd.port.pre.mk>
post-extract:
diff --git a/lang/tcl83/Makefile b/lang/tcl83/Makefile
index dfd18979fc4c..1c527f983d11 100644
--- a/lang/tcl83/Makefile
+++ b/lang/tcl83/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tcl
PORTVERSION= 8.3.5
+PORTREVISION= 1
CATEGORIES= lang tcl83
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcl
@@ -27,6 +28,7 @@ PKGINSTALL= ${PKGDIR}/pkg-install.tclsh
PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.tclsh
TCL_VER= 8.3
NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
+USE_REINPLACE= YES
PLIST_SUB= TCL_VER=${TCL_VER} SHORT_TCL_VER=83
@@ -420,6 +422,10 @@ MLINKS= Access.3 Tcl_Access.3 \
safe.n Safe\Base.n \
tcltest.n Tcltest.n
+post-configure:
+ ${REINPLACE_CMD} -e 's=${WRKDIRPREFIX}=$${WRKDIRPREFIX}=' \
+ ${WRKSRC}/tclConfig.sh
+
.include <bsd.port.pre.mk>
post-install: