aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby16_static/Makefile4
-rw-r--r--lang/ruby_static/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/lang/ruby16_static/Makefile b/lang/ruby16_static/Makefile
index 7e3c4105fc43..316229eb7c5e 100644
--- a/lang/ruby16_static/Makefile
+++ b/lang/ruby16_static/Makefile
@@ -30,7 +30,7 @@ _RUBY_PORTDIR= ${_PORTSDIR}/${RUBY_PORT}
LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
.if ${RUBY_VER} < 1.7
-EXT_PORTS+= lang/ruby16-shim-ruby18
+EXT_PORTS+= ${RUBY_SHIM18_PORT}
.else
EXT_PORTS+= converters/ruby-iconv
.endif
@@ -99,7 +99,7 @@ do-extract:
while read extdir; do \
extdir=$${extdir%/extconf.rb}; \
case "$p" in \
- lang/ruby16-shim-ruby18) \
+ ${RUBY_SHIM18_PORT) \
m=$$(basename $$extdir); \
case $$extdir in \
*/racc/*) \
diff --git a/lang/ruby_static/Makefile b/lang/ruby_static/Makefile
index 7e3c4105fc43..316229eb7c5e 100644
--- a/lang/ruby_static/Makefile
+++ b/lang/ruby_static/Makefile
@@ -30,7 +30,7 @@ _RUBY_PORTDIR= ${_PORTSDIR}/${RUBY_PORT}
LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
.if ${RUBY_VER} < 1.7
-EXT_PORTS+= lang/ruby16-shim-ruby18
+EXT_PORTS+= ${RUBY_SHIM18_PORT}
.else
EXT_PORTS+= converters/ruby-iconv
.endif
@@ -99,7 +99,7 @@ do-extract:
while read extdir; do \
extdir=$${extdir%/extconf.rb}; \
case "$p" in \
- lang/ruby16-shim-ruby18) \
+ ${RUBY_SHIM18_PORT) \
m=$$(basename $$extdir); \
case $$extdir in \
*/racc/*) \