aboutsummaryrefslogtreecommitdiff
path: root/mail/antivirus-milter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/antivirus-milter/Makefile')
-rw-r--r--mail/antivirus-milter/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/mail/antivirus-milter/Makefile b/mail/antivirus-milter/Makefile
index 229023aa4970..ee01e484a4a1 100644
--- a/mail/antivirus-milter/Makefile
+++ b/mail/antivirus-milter/Makefile
@@ -7,7 +7,7 @@
PORTNAME= antivirus
PORTVERSION= 3.30
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= dinoex
@@ -15,10 +15,13 @@ MASTER_SITE_SUBDIR= dinoex
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Sendmail milter wich uses Mcafee Virus Scan or clamav
+USE_RC_SUBR= antivirus-milter.sh
+
CFLAGS+= -Wall ${PTHREAD_CFLAGS:S=""==}
LIBS+= -lmilter ${PTHREAD_LIBS}
ANTIVIRUS_DIR?= /var/spool/antivirus
PLIST_SUB+= ANTIVIRUS=${ANTIVIRUS_DIR}
+SUB_LIST+= ANTIVIRUS=${ANTIVIRUS_DIR}
SED_SCRIPT= -e 's|%%ANTIVIRUS%%|${ANTIVIRUS_DIR}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g'
@@ -36,16 +39,12 @@ MAKE_ENV+= SENDMAILBASE="${MILTERBASE}" \
do-configure:
@${REINPLACE_CMD} -e 's|/etc/mail/antivirus.conf|${LOCALBASE}/etc/antivirus.conf|' \
${CONFIGURE_WRKSRC}/antivirus.c
- @${SED} ${SED_SCRIPT} ${FILESDIR}/antivirus-milter.sh \
- > ${WRKSRC}/antivirus-milter.sh
@${SED} ${SED_SCRIPT} ${FILESDIR}/antivirus.conf \
> ${WRKSRC}/antivirus.conf
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/antivirus \
${PREFIX}/libexec/antivirus
- ${INSTALL_SCRIPT} ${WRKSRC}/antivirus-milter.sh \
- ${PREFIX}/etc/rc.d/antivirus-milter.sh.sample
${INSTALL_DATA} ${WRKSRC}/antivirus.conf ${PREFIX}/etc/antivirus.conf-dist
${MKDIR} ${ANTIVIRUS_DIR}/spool ${ANTIVIRUS_DIR}/run ${ANTIVIRUS_DIR}/quarantine
${CHOWN} -R nobody:nobody ${ANTIVIRUS_DIR}/