aboutsummaryrefslogtreecommitdiff
path: root/mail/automx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/automx/Makefile')
-rw-r--r--mail/automx/Makefile41
1 files changed, 12 insertions, 29 deletions
diff --git a/mail/automx/Makefile b/mail/automx/Makefile
index 14fc5689a7ad..57800e4083d8 100644
--- a/mail/automx/Makefile
+++ b/mail/automx/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= automx
-PORTVERSION= 0.9
-PORTREVISION= 1
+PORTVERSION= 0.9.2
CATEGORIES= mail
MASTER_SITES= http://www.automx.org/download/
@@ -13,7 +12,6 @@ LICENSE= GPLv3
RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_wsgi.so:${PORTSDIR}/www/mod_wsgi2 \
${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml \
- bash:${PORTSDIR}/shells/bash \
wget:${PORTSDIR}/ftp/wget
USE_APACHE_RUN= 22+
@@ -22,42 +20,27 @@ NO_BUILD= yes
PORTDATA= *
PORTDOCS= *
-MAN1= ${PORTNAME}-test.1
-MAN5= ${PORTNAME}.conf.5 ${PORTNAME}_ldap.5 ${PORTNAME}_sql.5
-
PKGMESSAGE= ${WRKDIR}/pkg-message
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
- ${REINPLACE_CMD} -e '1s,/bin/bash,${LOCALBASE}/bin/bash,' \
- ${WRKSRC}/src/automx-test
# Generate pkg-message from INSTALL file; include lines from Section 5 onwards
- line=$$(${SED} -ne '/^5. Web Server/=' ${WRKSRC}/INSTALL) && \
+ line=$$(${SED} -ne '/^Web Server/=' ${WRKSRC}/INSTALL) && \
${SED} -ne "$$line,\$$p" ${WRKSRC}/INSTALL > ${PKGMESSAGE}
do-install:
- ${MKDIR} ${DATADIR}
- (cd ${WRKSRC}/src && ${COPYTREE_SHARE} ${PORTNAME} ${PYTHONPREFIX_SITELIBDIR})
- ${INSTALL_DATA} ${WRKSRC}/src/automx_wsgi.py ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/src/automx-test ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/src/automx.conf \
- ${PREFIX}/etc/automx.conf.sample
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC}/src && \
+ ${COPYTREE_SHARE} ${PORTNAME} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR})
+ ${INSTALL_DATA} ${WRKSRC}/src/automx_wsgi.py ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/automx-test ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/src/conf/automx.conf \
+ ${STAGEDIR}${PREFIX}/etc/automx.conf.sample
.for s in 1 5
-. for m in ${MAN$s}
- ${INSTALL_MAN} ${WRKSRC}/doc/man/man$s/$m ${MAN$sPREFIX}/man/man$s
-. endfor
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/man$s/* ${STAGEDIR}${PREFIX}/man/man$s/
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "[^m]*" ${DOCSDIR})
-.endif
-
-post-install:
- [ -f ${PREFIX}/etc/${PORTNAME}.conf ] || \
- ${CP} -p ${PREFIX}/etc/${PORTNAME}.conf.sample \
- ${PREFIX}/etc/${PORTNAME}.conf
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "[^m]*" ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>