aboutsummaryrefslogtreecommitdiff
path: root/mail/balsa/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/balsa/Makefile')
-rw-r--r--mail/balsa/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index 696fc20e37f1..7a6829655afc 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -8,7 +8,7 @@
PORTNAME= balsa
PORTVERSION= 2.3.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail gnome
MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/
DISTNAME= balsa-${PORTVERSION}
@@ -48,6 +48,7 @@ MAN1= balsa.1
OPTIONS= LDAP "Enable LDAP support" on \
GTKSPELL "Spell checking support" on \
GTKSV "Enable GtkSourceview support" on \
+ NOTIFY "Enable libnotify support" on \
GPG "Enable GnuPG support" off
.include <bsd.port.pre.mk>
@@ -72,6 +73,13 @@ USE_GNOME+= gtksourceview
CONFIGURE_ARGS+=--with-gtksourceview
.endif
+.if !defined(WITHOUT_NOTIFY)
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+CONFIGURE_ARGS+=--with-libnotify=yes
+.else
+CONFIGURE_ARGS+=--with-libnotify=no
+.endif
+
.if ${PREFIX}==${LOCALBASE}
PLIST_SUB+= GTKICON="@comment "
.else