aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail/claws-mail')
-rw-r--r--mail/claws-mail/Makefile56
1 files changed, 29 insertions, 27 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 7aadbe20d925..2a1574d06e9c 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -51,23 +51,25 @@ CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= BOGOFILTER "Enable bogofilter plugin" off \
- COMPFACE "Enable X-Face support" on \
- DEBUG "Enable debug support" off \
- DILLO "Enable Dillo HTML viewer plugin" off \
- ENCHANT "Enable spell checking support" on \
- GPGME "Enable PGP/GnuPG/SMIME plugins" off \
- IPV6 "Enable IPv6 support" on \
- JPILOT "Enable JPilot plugin" off \
- LDAP "Enable LDAP support" off \
- MANUAL "Build and install manual files" on \
- SPAMASSASSIN "Enable SpamAssassin plugin" off \
- STARTUP "Enable startup notification support" on \
- THEMES "Install additional themes" on
+OPTIONS_DEFINE= BOGOFILTER COMPFACE DEBUG DILLO ENCHANT GPGME IPV6 JPILOT LDAP \
+ MANUAL SPAMASSASSIN STARTUP THEMES
+
+BOGOFILTER_DESC= Enable bogofilter plugin
+COMPFACE_DESC= Enable X-Face support
+DILLO_DESC= Enable Dillo HTML viewer plugin
+ENCHANT_DESC= Enable spell checking support
+GPGME_DESC= Enable PGP/GnuPG/SMIME plugins
+JPILOT_DESC= Enable JPilot plugin
+MANUAL_DESC= Build and install manual files
+SPAMASSASSIN_DESC= Enable SpamAssassin plugin
+STARTUP_DESC= Enable startup notification support
+THEMES_DESC= Install additional themes
+
+OPTIONS_DEFAULT= COMPFACE ENCHANT IPV6 MANUAL STARTUP THEMES
.include <bsd.port.options.mk>
-.if defined(WITH_BOGOFILTER)
+.if ${PORT_OPTIONS:MBOGOFILTER}
RUN_DEPENDS+= bogofilter:${PORTSDIR}/mail/bogofilter
CONFIGURE_ARGS+= --enable-bogofilter-plugin
PLIST_SUB+= BOGO_PLUG=""
@@ -76,21 +78,21 @@ CONFIGURE_ARGS+= --disable-bogofilter-plugin
PLIST_SUB+= BOGO_PLUG="@comment "
.endif
-.if defined(WITH_COMPFACE)
+.if ${PORT_OPTIONS:MCOMPFACE}
LIB_DEPENDS+= compface.1:${PORTSDIR}/mail/faces
CONFIGURE_ARGS+= --enable-compface
.else
CONFIGURE_ARGS+= --disable-compface
.endif
-.if defined(WITH_ENCHANT)
+.if ${PORT_OPTIONS:MENCHANT}
LIB_DEPENDS+= enchant:${PORTSDIR}/textproc/enchant
CONFIGURE_ARGS+= --enable-enchant
.else
CONFIGURE_ARGS+= --disable-enchant
.endif
-.if defined(WITH_JPILOT)
+.if ${PORT_OPTIONS:MJPILOT}
LIB_DEPENDS+= pisock:${PORTSDIR}/palm/pilot-link
RUN_DEPENDS+= jpilot:${PORTSDIR}/palm/jpilot
CONFIGURE_ARGS+= --enable-jpilot
@@ -98,14 +100,14 @@ CONFIGURE_ARGS+= --enable-jpilot
CONFIGURE_ARGS+= --disable-jpilot
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --enable-ldap
.else
CONFIGURE_ARGS+= --disable-ldap
.endif
-.if defined(WITH_MANUAL)
+.if ${PORT_OPTIONS:MMANUAL}
BUILD_DEPENDS= ${LOCALBASE}/bin/docbook2html:${PORTSDIR}/textproc/docbook-utils
CONFIGURE_ARGS+= --enable-manual --with-manualdir=${DOCSDIR}/manual
PLIST_SUB+= MANUAL=""
@@ -114,7 +116,7 @@ CONFIGURE_ARGS+= --disable-manual
PLIST_SUB+= MANUAL="@comment "
.endif
-.if defined(WITH_SPAMASSASSIN)
+.if ${PORT_OPTIONS:MSPAMASSASSIN}
RUN_DEPENDS+= spamd:${PORTSDIR}/mail/p5-Mail-SpamAssassin
CONFIGURE_ARGS+= --enable-spamassassin-plugin
PLIST_SUB+= SA_PLUG=""
@@ -123,7 +125,7 @@ CONFIGURE_ARGS+= --disable-spamassassin-plugin
PLIST_SUB+= SA_PLUG="@comment "
.endif
-.if defined(WITH_GPGME)
+.if ${PORT_OPTIONS:MGPGME}
PLIST_SUB+= GPGME=""
CONFIGURE_ARGS+= --enable-pgpmime-plugin --enable-pgpcore-plugin \
--enable-pgpinline-plugin --enable-smime-plugin
@@ -136,11 +138,11 @@ CONFIGURE_ARGS+= --disable-pgpmime-plugin --disable-pgpcore-plugin \
--disable-pgpinline-plugin --disable-smime-plugin
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-maintainer-mode --enable-crash-dialog
.endif
-.if defined(WITH_DILLO)
+.if ${PORT_OPTIONS:MDILLO}
PLIST_SUB+= DILLO=""
RUN_DEPENDS+= dillo:${PORTSDIR}/www/dillo
.else
@@ -148,20 +150,20 @@ PLIST_SUB+= DILLO="@comment "
CONFIGURE_ARGS+= --disable-dillo-viewer-plugin
.endif
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if !defined(WITHOUT_STARTUP)
+.if ${PORT_OPTIONS:MSTARTUP}
LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
CONFIGURE_ARGS+= --enable-startup-notification
.else
CONFIGURE_ARGS+= --disable-startup-notification
.endif
-.if !defined(WITHOUT_THEMES)
+.if ${PORT_OPTIONS:MTHEMES}
RUN_DEPENDS+= ${LOCALBASE}/share/claws-mail/themes/ZX-0_1.1/down_arrow.xpm:${PORTSDIR}/x11-themes/claws-mail-themes
.endif
@@ -178,7 +180,7 @@ post-patch:
${REINPLACE_CMD} -e "s|/usr/bin/perl|${PERL}|" $$f; done
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in NEWS RELEASE_NOTES README TODO
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}