aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot2-pigeonhole/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/dovecot2-pigeonhole/Makefile')
-rw-r--r--mail/dovecot2-pigeonhole/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/mail/dovecot2-pigeonhole/Makefile b/mail/dovecot2-pigeonhole/Makefile
index 55fe6dfa619a..f2a5640c5fbe 100644
--- a/mail/dovecot2-pigeonhole/Makefile
+++ b/mail/dovecot2-pigeonhole/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dovecot-pigeonhole
PORTVERSION= 0.4.3
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://pigeonhole.dovecot.org/releases/${DOVECOTVERSION}/
DISTNAME= ${PORTNAME:C/-/-${DOVECOTVERSION}-/}-${PORTVERSION}
@@ -18,12 +19,13 @@ RUN_DEPENDS:= dovecot2>=${DOVECOTVERSION}:${PORTSDIR}/mail/dovecot2
DOVECOTVERSION= 2.2
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
--without-dovecot-install-dirs \
--docdir=${DOCSDIR} \
--with-dovecot="${LOCALBASE}/lib/dovecot"
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+USES= libtool
USE_LDCONFIG= ${PREFIX}/lib/dovecot
PORTDOCS= doc/extensions/* doc/plugins/* doc/rfc/*
@@ -34,7 +36,4 @@ post-patch:
s!^(uninstall-am:) uninstall-sieve_docDATA!\1!;' \
${WRKSRC}/doc/Makefile.in
-post-install:
- ${FIND} ${STAGEDIR}${PREFIX}/lib/ -name \*.so | ${XARGS} ${STRIP_CMD}
-
.include <bsd.port.mk>