aboutsummaryrefslogtreecommitdiff
path: root/mail/enigmail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/enigmail/Makefile')
-rw-r--r--mail/enigmail/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/mail/enigmail/Makefile b/mail/enigmail/Makefile
index 799fb3371e42..b8a4c1ce444f 100644
--- a/mail/enigmail/Makefile
+++ b/mail/enigmail/Makefile
@@ -6,11 +6,16 @@
#
PORTNAME= enigmail
-PORTVERSION= 0.83.6
+PORTVERSION= 0.84.0
PORTREVISION?= 0
CATEGORIES= mail security
-MASTER_SITES= http://mozdev.secsup.org/enigmail/src/ \
- http://downloads.us-east3.mozdev.org/enigmail/src/
+MASTER_SITES= http://www.brunschwig.net/enigmail/src/ \
+ http://mozdev.secsup.org/enigmail/src/ \
+ http://downloads.us-east3.mozdev.org/enigmail/src/ \
+ http://mozdev.oregonstate.edu/enigmail/src/ \
+ http://mozdev.sweetooth.org/enigmail/src/ \
+ http://ftp.heanet.ie/pub/mozdev/enigmail/src/ \
+ http://mirror.meisterwerk.net/rmozdev/enigmail/src/
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
ipc-1.0.5${EXTRACT_SUFX}
@@ -20,6 +25,8 @@ COMMENT?= A GnuPG extension for the Mozilla mail client
EXTRACT_DEPENDS?= ${WRKDIR}/../../../${LOCAL_SRCDIR}/work/mozilla/Makefile:${PORTSDIR}/${LOCAL_SRCDIR}:configure
RUN_DEPENDS?= mozilla:${PORTSDIR}/${LOCAL_SRCDIR}
+RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
+
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -71,5 +78,6 @@ do-install:
post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>