aboutsummaryrefslogtreecommitdiff
path: root/mail/ezmlm-idx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/ezmlm-idx/Makefile')
-rw-r--r--mail/ezmlm-idx/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/mail/ezmlm-idx/Makefile b/mail/ezmlm-idx/Makefile
index 2887b0821790..2232a42c8034 100644
--- a/mail/ezmlm-idx/Makefile
+++ b/mail/ezmlm-idx/Makefile
@@ -42,7 +42,8 @@ EXTRACT_INCLUDE+= -I${PREFIX}/include/mysql
EXTRACT_LIB+= -L${PREFIX}/lib/mysql -lmysqlclient -lm
.elif defined(WITH_POSTGRESQL)
ALL_TARGET= pgsql it ${LANGUAGE}
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
EXTRACT_INCLUDE+= -I${PREFIX}/include/pgsql
EXTRACT_LIB+= -L${PREFIX}/lib -lpq -lcrypt
.else