aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmail
diff options
context:
space:
mode:
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile70
-rw-r--r--mail/fetchmail/distinfo6
-rw-r--r--mail/fetchmail/files/patch-LibreSSL14
3 files changed, 42 insertions, 48 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 21a0b7561e00..66474be62251 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -1,8 +1,8 @@
# Created by: Ville Eerola <ve@sci.fi>
PORTNAME?= fetchmail
-DISTVERSION= 6.4.22
-PORTREVISION= 1
+DISTVERSION= 6.4.24
+PORTREVISION?= 0
CATEGORIES= mail
# The next line is inherited by the fetchmailconf dependent port,
# do NOT replace fetchmail by ${PORTNAME}
@@ -11,55 +11,65 @@ MASTER_SITES= SF/fetchmail/branch_6.4/
MAINTAINER= chalpin@cs.wisc.edu
COMMENT?= Batch mail retrieval utility for IMAP/POP3/ETRN/ODMR
-LICENSE= GPLv2 LGPL21
-LICENSE_COMB= dual
+LICENSE= GPLv2+
.if empty(MASTERDIR)
-CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-
-USES= cpe gmake tar:xz ssl
-
-USERS= ${PORTNAME}
-GROUPS= ${USERS}
+USES= cpe gmake ssl tar:xz
+IGNORE_SSL= libressl libressl-devel
+IGNORE_SSL_REASON=incompatible license/no GPLv2 clause 2b exception for LibreSSL
+# The Free Software Foundation asserts that a GPL v2 clause 2b exception is
+# required even for dynamically linked binaries. See
+# https://www.gnu.org/licenses/gpl-faq.en.html#GPLStaticVsDynamic
USE_RC_SUBR= fetchmail
-SUB_FILES= pkg-message
GNU_CONFIGURE= yes
# the added PYTHON=: suppresses python builds,
# see ../../mail/fetchmailconf/ for the configuration tool
-CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-SDPS \
- --without-hesiod --enable-fallback=no \
- --with-ssl=${OPENSSLBASE} PYTHON=:
+CONFIGURE_ARGS= --enable-fallback=no \
+ --enable-opie \
+ --enable-RPA \
+ --enable-SDPS \
+ --with-ssl=${OPENSSLBASE} \
+ --without-hesiod \
+ PYTHON=:
# -Wl,--as-needed suppresses unneeded library references,
# for instance, libcom_err.so on GSSAPI_NONE builds:
LDFLAGS+= -L${LOCALBASE}/lib -Wl,--as-needed
-OPTIONS_DEFINE= CA_BUNDLE NLS DOCS
-OPTIONS_SINGLE= GSSAPI
-OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
+PATCH_STRIP= -p1
+SUB_FILES= pkg-message
+USERS= ${PORTNAME}
+GROUPS= ${USERS}
+
+OPTIONS_DEFINE= CA_BUNDLE DOCS NLS
OPTIONS_DEFAULT= CA_BUNDLE GSSAPI_BASE
-OPTIONS_SUB= yes
+OPTIONS_SINGLE= GSSAPI
+OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
+OPTIONS_SUB= yes
CA_BUNDLE_DESC= Install CA bundle for OpenSSL
+CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-GSSAPI_BASE_USES= gssapi
-GSSAPI_BASE_CONFIGURE_ON= --with-gssapi=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
-GSSAPI_HEIMDAL_USES= gssapi:heimdal
-GSSAPI_HEIMDAL_CONFIGURE_ON= --with-gssapi=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
-GSSAPI_MIT_USES= gssapi:mit
-GSSAPI_MIT_CONFIGURE_ON= --with-kerberos5=${GSSAPIBASEDIR} ${GSSAPI_CONFIGURE_ARGS}
+GSSAPI_BASE_USES= gssapi
+GSSAPI_BASE_CONFIGURE_ON= ${GSSAPI_CONFIGURE_ARGS} \
+ --with-gssapi=${GSSAPIBASEDIR}
+GSSAPI_HEIMDAL_USES= gssapi:heimdal
+GSSAPI_HEIMDAL_CONFIGURE_ON= ${GSSAPI_CONFIGURE_ARGS} \
+ --with-gssapi=${GSSAPIBASEDIR}
+GSSAPI_MIT_USES= gssapi:mit
+GSSAPI_MIT_CONFIGURE_ON= ${GSSAPI_CONFIGURE_ARGS} \
+ --with-kerberos5=${GSSAPIBASEDIR}
GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
-NLS_USES= gettext
+NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-PORTDOCS= FAQ FEATURES NEWS NOTES OLDNEWS \
- README README.SSL README.SSL-SERVER \
- design-notes.html fetchmail-FAQ.html fetchmail-features.html \
- esrs-design-notes.html todo.html
+PORTDOCS= FAQ FEATURES NEWS NOTES OLDNEWS README README.SSL \
+ README.SSL-SERVER design-notes.html esrs-design-notes.html \
+ fetchmail-FAQ.html fetchmail-features.html todo.html
post-patch:
.if !exists(/usr/lib/libcom_err.so)
@@ -68,8 +78,6 @@ post-patch:
.endif
-PATCH_STRIP= -p1
-
.if empty(MASTERDIR)
post-build:
${MAKE_CMD} -C ${WRKSRC} check ; { r=$$? ; ( set -x ; ${CAT} "${WRKSRC}/test-suite.log" ) ; exit $$r ; }
diff --git a/mail/fetchmail/distinfo b/mail/fetchmail/distinfo
index fb8a0db605b6..c2d2a1175c8c 100644
--- a/mail/fetchmail/distinfo
+++ b/mail/fetchmail/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1631567945
-SHA256 (fetchmail-6.4.22.tar.xz) = cc6818bd59435602169fa292d6d163d56b21c7f53112829470a3aceabe612c84
-SIZE (fetchmail-6.4.22.tar.xz) = 1330176
+TIMESTAMP = 1637401885
+SHA256 (fetchmail-6.4.24.tar.xz) = 9c961df25cd922f539218b0b56a77e7a47778e49ed907edaa5b4941ad3b253cf
+SIZE (fetchmail-6.4.24.tar.xz) = 1331764
diff --git a/mail/fetchmail/files/patch-LibreSSL b/mail/fetchmail/files/patch-LibreSSL
deleted file mode 100644
index 15bb350256f2..000000000000
--- a/mail/fetchmail/files/patch-LibreSSL
+++ /dev/null
@@ -1,14 +0,0 @@
-$OpenBSD: patch-tls-aux_h,v 1.1 2021/07/29 10:44:07 sthen Exp $
-
-Index: tls-aux.h
---- tls-aux.h.orig
-+++ tls-aux.h
-@@ -8,7 +8,7 @@
- #ifdef SSL_ENABLE
- #include <openssl/opensslv.h>
-
--# if defined(LIBRESSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER < 0x1010000fL
-+# if OPENSSL_VERSION_NUMBER < 0x1010000fL
- # undef OSSL110_API
- # else
- # define OSSL110_API 1