aboutsummaryrefslogtreecommitdiff
path: root/mail/gotmail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/gotmail/Makefile')
-rw-r--r--mail/gotmail/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/mail/gotmail/Makefile b/mail/gotmail/Makefile
index a26cceaa0774..38e6de19e700 100644
--- a/mail/gotmail/Makefile
+++ b/mail/gotmail/Makefile
@@ -7,11 +7,12 @@
PORTNAME= gotmail
PORTVERSION= 0.6.6
+PORTREVISION= 1
CATEGORIES= mail perl5
MASTER_SITES= http://www.hawkins.emu.id.au/gotmail/
DISTNAME= ${PORTNAME}_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@geeksrus.net
RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI.pm:${PORTSDIR}/net/p5-URI
@@ -21,8 +22,11 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+pre-patch:
+ ${PERL} -pi -e 's|\r$$||' ${WRKSRC}/${PORTNAME}.pl
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
post-install:
.if !defined(NOPORTDOCS)