aboutsummaryrefslogtreecommitdiff
path: root/mail/horde-ingo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/horde-ingo/Makefile')
-rw-r--r--mail/horde-ingo/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/mail/horde-ingo/Makefile b/mail/horde-ingo/Makefile
index 6c8f42c0c967..eb94e51a0363 100644
--- a/mail/horde-ingo/Makefile
+++ b/mail/horde-ingo/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ingo
PORTVERSION= 1.1.3
DISTVERSIONPREFIX= h3-
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= HORDE
@@ -26,7 +27,6 @@ RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde-base
NO_BUILD= yes
USE_PHP= imap
USE_GETTEXT= yes
-USE_APACHE= 1.3+ # needed to test APACHE_VERSION
PLIST_SUB= INGODIR=${LINGODIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -52,30 +52,23 @@ CONFDIR= ${INGODIR}/config
RUN_DEPENDS+= ${PEARDIR}/Net/Sieve.php:${PORTSDIR}/net/pear-Net_Sieve
.endif
-.if ${APACHE_VERSION} >= 20
-HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes
-.else
-HORDE_INC= ${LOCALBASE}/etc/horde
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name "*.orig" -delete
post-extract:
@${MV} ${WRKSRC}/README ${WRKSRC}/docs/
-pre-configure:
- @${SED} -e "s:/home/httpd/html/horde/ingo:${INGODIR}:g" \
- ${FILESDIR}/httpd.conf.ingo >${WRKDIR}/httpd-ingo.conf
-
do-install:
@${INSTALL} -d ${INGODIR}/
@${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${INGODIR}/
@${CP} -p ${WRKSRC}/*.php ${INGODIR}/
@${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}/
- @${INSTALL_DATA} ${WRKDIR}/httpd-ingo.conf ${HORDE_INC}/
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${INGODIR}/
@${CHMOD} -R o-rwx ${CONFDIR}/
+ ${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP}\
+ %D/${INGODIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ ${ECHO_CMD} @exec ${CHMOD} -R o-rwx\
+ %D/${CONFDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
@${INSTALL} -d ${DOCSDIR}/
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/