aboutsummaryrefslogtreecommitdiff
path: root/mail/im/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/im/Makefile')
-rw-r--r--mail/im/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/mail/im/Makefile b/mail/im/Makefile
index 1e5d6884dcf1..b18828439fed 100644
--- a/mail/im/Makefile
+++ b/mail/im/Makefile
@@ -10,21 +10,27 @@ MASTER_SITES= http://tats.haun.org/im/
MAINTAINER= ports@FreeBSD.org
COMMENT= Set of user interfaces of Email and NetNews
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/00copyright
+
USES= perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-hostname=_domain_of_your_mail_address_
CONFIGURE_ENV= im_path_perl=${PERL}
MAKE_ARGS= prefix=${PREFIX} imlibdir=${ETCDIR}
+NO_ARCH= yes
OPTIONS_DEFINE= DOCS EXAMPLES RPOP
RPOP_DESC= Use RPOP instead of APOP
RPOP_CONFIGURE_ENABLE= rpop
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/man
${INSTALL_DATA} ${WRKSRC}/00* ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/man/* ${STAGEDIR}${DOCSDIR}/man
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/dot.im/* ${STAGEDIR}${EXAMPLESDIR}