aboutsummaryrefslogtreecommitdiff
path: root/mail/libpst/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/libpst/Makefile')
-rw-r--r--mail/libpst/Makefile31
1 files changed, 19 insertions, 12 deletions
diff --git a/mail/libpst/Makefile b/mail/libpst/Makefile
index c05582420b5e..44e1beaeb2fa 100644
--- a/mail/libpst/Makefile
+++ b/mail/libpst/Makefile
@@ -1,18 +1,17 @@
-# New ports collection makefile for: libpst
-# Date created: 28 June 2002
-# Whom: Nate Underwood <natey@natey.com>
-#
+# Created by: Nate Underwood <natey@natey.com>
# $FreeBSD$
-#
PORTNAME= libpst
-PORTVERSION= 0.6.53
+PORTVERSION= 0.6.55
CATEGORIES= mail converters
-MASTER_SITES= http://www.five-ten-sg.com/libpst/packages/
+MASTER_SITES= http://www.five-ten-sg.com/libpst/packages/ \
+ http://fossies.org/unix/privat/
MAINTAINER= chifeng@gmail.com
COMMENT= A tool for converting Outlook .pst files to mbox and other formats
+LICENSE= GPLv2
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_ICONV= yes
@@ -20,18 +19,23 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -liconv
CONFIGURE_ARGS+= --disable-python
-OPTIONS= PST2DII "allow Summation Document Image Information output" off
-
MAN1= lspst.1 pst2dii.1 pst2ldif.1 readpst.1
MAN5= outlook.pst.5
+OPTIONS_DEFINE= DOCS PST2DII
+PST2DII_DESC= "allow Summation Document Image Information output"
+
.include <bsd.port.options.mk>
-.if defined(WITH_PST2DII)
+.if ${PORT_OPTIONS:MDOCS}
+PORTDOCS= *
+.endif
+
+.if ${PORT_OPTIONS:MPST2DII}
CONFIGURE_ARGS+= --enable-dii=yes
BUILD_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
-LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
PLIST_SUB+= PST2DII=""
.else
CONFIGURE_ARGS+= --enable-dii=no
@@ -43,7 +47,10 @@ post-patch:
-e 's/malloc.h/stdlib.h/g'
${REINPLACE_CMD} -e 's;doc\/@PACKAGE@-@VERSION@;doc\/@PACKAGE@;g' \
${WRKSRC}/Makefile.in ${WRKSRC}/html/Makefile.in
-.ifdef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
+ ${REINPLACE_CMD} -e '/html_DATA =/s/COPYING //' \
+ ${WRKSRC}/Makefile.in
+.else
${REINPLACE_CMD} -e '/SUBDIRS =/s/=.*/= src man/' -e '/html_DATA =/d' \
${WRKSRC}/Makefile.in
.endif