aboutsummaryrefslogtreecommitdiff
path: root/mail/libsieve/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/libsieve/Makefile')
-rw-r--r--mail/libsieve/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/mail/libsieve/Makefile b/mail/libsieve/Makefile
new file mode 100644
index 000000000000..8e2afff928cc
--- /dev/null
+++ b/mail/libsieve/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libsieve
+# Date created: 4 August 2006
+# Whom: Mark Starovoytov <mark_sf@kikg.ifmo.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsieve
+PORTVERSION= 2.1.13
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= libsieve
+
+MAINTAINER= mark_sf@kikg.ifmo.ru
+COMMENT= A library for parsing, sorting and filtering mail
+
+GNU_CONFIGURE= yes
+CONFIGURE_WRKSRC=${WRKSRC}/src
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+=--prefix=${PREFIX}
+USE_GMAKE= yes
+BUILD_WRKSRC= ${WRKSRC}/src
+INSTALL_WRKSRC= ${WRKSRC}/src
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>