aboutsummaryrefslogtreecommitdiff
path: root/mail/mahogany/files
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mahogany/files')
-rw-r--r--mail/mahogany/files/patch-Makefile12
-rw-r--r--mail/mahogany/files/patch-aa91
-rw-r--r--mail/mahogany/files/patch-ab196
-rw-r--r--mail/mahogany/files/patch-ac118
-rw-r--r--mail/mahogany/files/patch-ad48
-rw-r--r--mail/mahogany/files/patch-ae44
-rw-r--r--mail/mahogany/files/patch-af62
-rw-r--r--mail/mahogany/files/patch-ag16
-rw-r--r--mail/mahogany/files/patch-ah19
-rw-r--r--mail/mahogany/files/patch-ai31
-rw-r--r--mail/mahogany/files/patch-include-MThread.h27
-rw-r--r--mail/mahogany/files/patch-makeopts.in17
-rw-r--r--mail/mahogany/files/patch-src-Makefile19
-rw-r--r--mail/mahogany/files/patch-src-classes-MModule.cpp14
-rw-r--r--mail/mahogany/files/patch-src-gui-wxMApp.cpp11
-rw-r--r--mail/mahogany/files/patch-src-gui-wxMDialogs.cpp25
16 files changed, 125 insertions, 625 deletions
diff --git a/mail/mahogany/files/patch-Makefile b/mail/mahogany/files/patch-Makefile
new file mode 100644
index 000000000000..53188f5aa1d0
--- /dev/null
+++ b/mail/mahogany/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig Mon Jul 28 23:10:47 2003
++++ Makefile Sat Oct 4 23:28:15 2003
+@@ -76,9 +76,6 @@
+ set -e; for i in \
+ $(BINDIR) \
+ $(DATADIR) \
+- $(DATADIR)/$(CANONICAL_HOST) \
+- $(DATADIR)/$(CANONICAL_HOST)/bin \
+- $(DATADIR)/$(CANONICAL_HOST)/lib \
+ $(DOCDIR) \
+ $(DOCDIR)/Tips \
+ ;do \
diff --git a/mail/mahogany/files/patch-aa b/mail/mahogany/files/patch-aa
deleted file mode 100644
index 08dae241fb95..000000000000
--- a/mail/mahogany/files/patch-aa
+++ /dev/null
@@ -1,91 +0,0 @@
---- configure.in.orig Wed Nov 8 10:21:36 2000
-+++ configure.in Sun Nov 12 03:40:33 2000
-@@ -309,9 +309,19 @@
- AC_SUBST(MAKE_USE_LEAKTRACER)
-
- case "$USE_THREADS" in 1)
-- AC_CHECK_LIB(pthread,main,,AC_CHECK_LIB(pthreads,main))
-+ AC_CHECK_LIB(pthread,main,threaded_lib=pthread,
-+ AC_CHECK_LIB(pthreads,main,threaded_lib=pthreads,
-+ AC_CHECK_LIB(c_r,pthread_self,threaded_lib=c_r,
-+ threaded_lib=none)
-+ )
-+ )
- AC_DEFINE(USE_THREADS)
-- LIBS="$LIBS -lpthread"
-+ case "$threaded_lib" in
-+ none) ;;
-+ pthread*) LIBS="$LIBS -lpthread" ;;
-+ c_r) CPPFLAGS="$CPPFLAGS -D_THREAD_SAFE"
-+ LIBS="-pthread $LIBS" ;;
-+ esac
- esac
-
- dnl set debug/optimisation flags
-@@ -456,15 +466,16 @@
-
- dnl libresolv or libbind (or simply libc under FreeBSD)
- USE_RBL=1
--AC_CHECK_LIB(resolv,res_query,,
-- AC_CHECK_LIB(bind,res_query,,
-- AC_CHECK_LIB(r,res_query,,
-- [
-- AC_MSG_WARN(cannot use RBL spam checker.)
-- USE_RBL=0
-- ]
-- )
-- )
-+AC_CHECK_FUNC(res_query,,
-+ [AC_CHECK_LIB(resolv,res_query,,
-+ [AC_CHECK_LIB(bind,res_query,,
-+ [AC_CHECK_LIB(r,res_query,,
-+ [AC_MSG_WARN(cannot use RBL spam checker.)
-+ USE_RBL=0
-+ ]
-+ ])
-+ ])
-+ ])
- )
-
- case "$USE_RBL" in 1) AC_DEFINE(USE_RBL) ;; esac
---- Makefile.orig Mon Nov 6 14:58:02 2000
-+++ Makefile Sun Nov 12 06:48:56 2000
-@@ -18,7 +18,7 @@
- M := mahogany-$(M_VERSION_MAJOR).$(M_VERSION_MINOR)
-
- doc:
-- set -e; for i in extra doc; do $(MAKE) -C $$i doc; done
-+ set -e; for i in extra; do $(MAKE) -C $$i doc; done
-
- classdoc:
- set -e; for i in doc; do $(MAKE) -C $$i doc; done
-@@ -63,12 +63,6 @@
- $(BINDIR) \
- $(DATADIR) \
- $(DOCDIR) \
-- $(DATADIR)/$(CANONICAL_HOST) \
-- $(DATADIR)/$(CANONICAL_HOST)/bin \
-- $(DATADIR)/$(CANONICAL_HOST)/lib \
-- $(DATADIR)/bin \
-- $(DATADIR)/lib \
-- $(DATADIR)/doc \
- $(DOCDIR)/Tips \
- ;do $(INSTALL) -d -m 755 $$i; \
- done
---- makeopts.in.orig Thu Oct 5 09:48:37 2000
-+++ makeopts.in Sun Nov 12 17:22:51 2000
-@@ -95,11 +95,11 @@
- # Directory in which to install library files.
- DATADIR = $(DESTDIR)/share/Mahogany
- # where to install docs
--DOCDIR = $(DATADIR)/doc
-+DOCDIR = $(DESTDIR)/share/doc/Mahogany
-
- # for the dynamic linker, better than using -rpath
--LD_RUN_PATH=$(DATADIR)/$(CANONICAL_HOST)/lib
--MODULEDIR=$(DATADIR)/$(CANONICAL_HOST)/modules
-+LD_RUN_PATH=$(DESTDIR)/lib
-+MODULEDIR=$(DESTDIR)/libdata/Mahogany/modules
-
- ifdef USE_LIBTOOL
- LINK = $(LIBTOOL) --mode=link $(CXX) -Wl-r$(LD_RUN_PATH)
diff --git a/mail/mahogany/files/patch-ab b/mail/mahogany/files/patch-ab
deleted file mode 100644
index c0c1abbe865d..000000000000
--- a/mail/mahogany/files/patch-ab
+++ /dev/null
@@ -1,196 +0,0 @@
---- extra/src/c-client/dummy.c.orig Sat Nov 11 02:55:17 2000
-+++ extra/src/c-client/dummy.c Sat Nov 11 02:55:27 2000
-@@ -252,7 +252,7 @@
- long level)
- {
- DIR *dp;
-- struct direct *d;
-+ struct dirent *d;
- struct stat sbuf;
- char tmp[MAILTMPLEN];
- /* punt if bogus name */
---- extra/src/c-client/mh.c.orig Sat Nov 11 02:57:05 2000
-+++ extra/src/c-client/mh.c Sat Nov 11 02:57:15 2000
-@@ -285,7 +285,7 @@
- void mh_list_work (MAILSTREAM *stream,char *dir,char *pat,long level)
- {
- DIR *dp;
-- struct direct *d;
-+ struct dirent *d;
- struct stat sbuf;
- char *cp,*np,curdir[MAILTMPLEN],name[MAILTMPLEN];
- /* build MH name to search */
-@@ -386,7 +386,7 @@
- long mh_delete (MAILSTREAM *stream,char *mailbox)
- {
- DIR *dirp;
-- struct direct *d;
-+ struct dirent *d;
- int i;
- char tmp[MAILTMPLEN];
- if (!(mailbox[0] == '#' && (mailbox[1] == 'm' || mailbox[1] == 'M') &&
-@@ -651,7 +651,7 @@
- }
- stream->silent = T; /* don't pass up mm_exists() events yet */
- if (sbuf.st_ctime != LOCAL->scantime) {
-- struct direct **names = NIL;
-+ struct dirent **names = NIL;
- long nfiles = scandir (LOCAL->dir,&names,mh_select,mh_numsort);
- if (nfiles < 0) nfiles = 0; /* in case error */
- old = stream->uid_last;
-@@ -871,7 +871,7 @@
- long mh_append (MAILSTREAM *stream,char *mailbox,char *flags,char *date,
- STRING *message)
- {
-- struct direct **names;
-+ struct dirent **names;
- int fd;
- char c,*s,tmp[MAILTMPLEN];
- MESSAGECACHE elt;
-@@ -961,7 +961,7 @@
- * Returns: T to use file name, NIL to skip it
- */
-
--int mh_select (struct direct *name)
-+int mh_select (struct dirent *name)
- {
- char c;
- char *s = name->d_name;
-@@ -978,8 +978,8 @@
-
- int mh_numsort (const void *d1,const void *d2)
- {
-- return atoi ((*(struct direct **) d1)->d_name) -
-- atoi ((*(struct direct **) d2)->d_name);
-+ return atoi ((*(struct dirent **) d1)->d_name) -
-+ atoi ((*(struct dirent **) d2)->d_name);
- }
-
-
---- extra/src/c-client/mh.h.orig Sat Nov 11 02:56:50 2000
-+++ extra/src/c-client/mh.h Sat Nov 11 02:57:01 2000
-@@ -83,7 +83,7 @@
- long mh_append (MAILSTREAM *stream,char *mailbox,char *flags,char *date,
- STRING *message);
-
--int mh_select (struct direct *name);
-+int mh_select (struct dirent *name);
- int mh_numsort (const void *d1,const void *d2);
- char *mh_file (char *dst,char *name);
- long mh_canonicalize (char *pattern,char *ref,char *pat);
---- extra/src/c-client/mx.c.orig Sat Nov 11 02:54:19 2000
-+++ extra/src/c-client/mx.c Sat Nov 11 02:54:43 2000
-@@ -197,7 +197,7 @@
- void mx_list_work (MAILSTREAM *stream,char *dir,char *pat,long level)
- {
- DIR *dp;
-- struct direct *d;
-+ struct dirent *d;
- struct stat sbuf;
- char *cp,*np,curdir[MAILTMPLEN],name[MAILTMPLEN];
- /* make mailbox and directory names */
-@@ -294,7 +294,7 @@
- long mx_delete (MAILSTREAM *stream,char *mailbox)
- {
- DIR *dirp;
-- struct direct *d;
-+ struct dirent *d;
- char *s;
- char tmp[MAILTMPLEN];
- if (!mx_isvalid (mailbox,tmp))
-@@ -585,7 +585,7 @@
- if (stat (LOCAL->dir,&sbuf)) return NIL;
- stream->silent = T; /* don't pass up mm_exists() events yet */
- if (sbuf.st_ctime != LOCAL->scantime) {
-- struct direct **names = NIL;
-+ struct dirent **names = NIL;
- long nfiles = scandir (LOCAL->dir,&names,mx_select,mx_numsort);
- if (nfiles < 0) nfiles = 0; /* in case error */
- old = stream->uid_last;
-@@ -902,7 +902,7 @@
- * Returns: T to use file name, NIL to skip it
- */
-
--int mx_select (struct direct *name)
-+int mx_select (struct dirent *name)
- {
- char c;
- char *s = name->d_name;
-@@ -919,8 +919,8 @@
-
- int mx_numsort (const void *d1,const void *d2)
- {
-- return atoi ((*(struct direct **) d1)->d_name) -
-- atoi ((*(struct direct **) d2)->d_name);
-+ return atoi ((*(struct dirent **) d1)->d_name) -
-+ atoi ((*(struct dirent **) d2)->d_name);
- }
-
-
---- extra/src/c-client/mx.h.orig Sat Nov 11 02:53:27 2000
-+++ extra/src/c-client/mx.h Sat Nov 11 02:53:34 2000
-@@ -86,7 +86,7 @@
- long mx_append (MAILSTREAM *stream,char *mailbox,char *flags,char *date,
- STRING *message);
-
--int mx_select (struct direct *name);
-+int mx_select (struct dirent *name);
- int mx_numsort (const void *d1,const void *d2);
- char *mx_file (char *dst,char *name);
- long mx_lockindex (MAILSTREAM *stream);
---- extra/src/c-client/news.c.orig Sat Nov 11 02:56:14 2000
-+++ extra/src/c-client/news.c Sat Nov 11 02:56:32 2000
-@@ -352,7 +352,7 @@
- {
- long i,nmsgs;
- char *s,tmp[MAILTMPLEN];
-- struct direct **names;
-+ struct dirent **names;
- /* return prototype for OP_PROTOTYPE call */
- if (!stream) return &newsproto;
- if (stream->local) fatal ("news recycle stream");
-@@ -401,7 +401,7 @@
- * Returns: T to use file name, NIL to skip it
- */
-
--int news_select (struct direct *name)
-+int news_select (struct dirent *name)
- {
- char c;
- char *s = name->d_name;
-@@ -418,8 +418,8 @@
-
- int news_numsort (const void *d1,const void *d2)
- {
-- return atoi ((*(struct direct **) d1)->d_name) -
-- atoi ((*(struct direct **) d2)->d_name);
-+ return atoi ((*(struct dirent **) d1)->d_name) -
-+ atoi ((*(struct dirent **) d2)->d_name);
- }
-
-
---- extra/src/c-client/news.h.orig Sat Nov 11 02:55:57 2000
-+++ extra/src/c-client/news.h Sat Nov 11 02:56:10 2000
-@@ -65,7 +65,7 @@
- long news_rename (MAILSTREAM *stream,char *old,char *newname);
- long news_status (MAILSTREAM *stream,char *mbx,long flags);
- MAILSTREAM *news_open (MAILSTREAM *stream);
--int news_select (struct direct *name);
-+int news_select (struct dirent *name);
- int news_numsort (const void *d1,const void *d2);
- void news_close (MAILSTREAM *stream,long options);
- void news_fast (MAILSTREAM *stream,char *sequence,long flags);
---- extra/src/c-client/os_bsi.h.orig Sat Nov 11 02:51:06 2000
-+++ extra/src/c-client/os_bsi.h Sat Nov 11 03:00:17 2000
-@@ -37,10 +37,9 @@
- #include <unistd.h>
- #include <string.h>
- #include <sys/types.h>
--#include <sys/dir.h>
-+#include <dirent.h>
- #include <fcntl.h>
- #include <syslog.h>
--#include <sys/file.h>
-
-
- #include "env_unix.h"
diff --git a/mail/mahogany/files/patch-ac b/mail/mahogany/files/patch-ac
deleted file mode 100644
index 8962e3f06213..000000000000
--- a/mail/mahogany/files/patch-ac
+++ /dev/null
@@ -1,118 +0,0 @@
---- src/wx/vcard/vcc.y.orig Thu Aug 24 16:27:50 2000
-+++ src/wx/vcard/vcc.y Sat Nov 11 03:23:44 2000
-@@ -107,7 +107,7 @@
- #endif
-
- #include <string.h>
--#ifndef __MWERKS__
-+#if !defined(__MWERKS__) && !defined(__FreeBSD__)
- #include <malloc.h>
- #endif
- #include <stdio.h>
-@@ -161,7 +161,6 @@
- /**** Private Forward Declarations ****/
- static int pushVObject(const char *prop);
- static VObject* popVObject();
--static char* lexDataFromBase64();
- static void lexPopMode(int top);
- static int lexWithinMode(enum LexMode mode);
- static void lexPushMode(enum LexMode mode);
-@@ -371,7 +370,7 @@
- ;
-
- %%
--/*/////////////////////////////////////////////////////////////////////////*/
-+/*-------------------------------------------------------------------------*/
- static int pushVObject(const char *prop)
- {
- VObject *newObj;
-@@ -391,7 +390,7 @@
- }
-
-
--/*/////////////////////////////////////////////////////////////////////////*/
-+/*-------------------------------------------------------------------------*/
- /* This pops the recently built vCard off the stack and returns it. */
- static VObject* popVObject()
- {
-@@ -432,7 +431,8 @@
-
- static void enterAttr(const char *s1, const char *s2)
- {
-- const char *p1, *p2;
-+ const char *p1;
-+ const char *p2 = NULL;
- p1 = lookupProp_(s1);
- if (s2) {
- VObject *a;
-@@ -726,7 +726,6 @@
- }
-
- static char* lexGet1Value() {
-- int size = 0;
- int c;
- lexSkipWhite();
- c = lexLookahead();
-@@ -758,7 +757,6 @@
- #endif
-
- static char* lexGetStrUntil(char *termset) {
-- int size = 0;
- int c = lexLookahead();
- lexClearToken();
- while (c != EOF && !strchr(termset,c)) {
-@@ -814,7 +812,7 @@
- }
-
-
--/*/////////////////////////////////////////////////////////////////////////*/
-+/*-------------------------------------------------------------------------*/
- /* This parses and converts the base64 format for binary encoding into
- * a decoded buffer (allocated with new). See RFC 1521.
- */
-@@ -943,7 +941,6 @@
- static char* lexGetQuotedPrintable()
- {
- char cur;
-- unsigned long len = 0;
-
- lexClearToken();
- do {
-@@ -999,8 +996,6 @@
- } /* LexQuotedPrintable */
-
- int yylex() {
-- int token = 0;
--
- int lexmode = LEXMODE();
- if (lexmode == L_VALUES) {
- int c = lexGetc();
-@@ -1130,7 +1125,7 @@
- return vObjList;
- }
-
--/*/////////////////////////////////////////////////////////////////////////*/
-+/*-------------------------------------------------------------------------*/
- DLLEXPORT(VObject*) Parse_MIME(const char *input, unsigned long len)
- {
- initLex(input, len, 0);
-@@ -1185,7 +1180,7 @@
-
- #endif
-
--/*/////////////////////////////////////////////////////////////////////////*/
-+/*-------------------------------------------------------------------------*/
- static void YYDebug(const char *s)
- {
- /* Parse_Debug(s); */
---- src/wx/vcard/vobject.c.orig Sat Nov 11 03:25:07 2000
-+++ src/wx/vcard/vobject.c Sat Nov 11 03:25:31 2000
-@@ -42,7 +42,7 @@
- * vobject, and convert a vobject into its textual representation.
- */
-
--#ifndef MWERKS
-+#if !defined(MWERKS) && !defined(__FreeBSD__)
- #include <malloc.h>
- #endif
-
diff --git a/mail/mahogany/files/patch-ad b/mail/mahogany/files/patch-ad
deleted file mode 100644
index 6dd44d3d6ddb..000000000000
--- a/mail/mahogany/files/patch-ad
+++ /dev/null
@@ -1,48 +0,0 @@
---- src/gui/wxMApp.cpp.orig Sat Sep 30 12:10:50 2000
-+++ src/gui/wxMApp.cpp Sun Nov 12 05:30:09 2000
-@@ -561,7 +561,11 @@
- {
- #ifdef OS_UNIX
- String localePath;
-+#ifdef __FreeBSD__
-+ localePath << M_PREFIX << "/share/locale";
-+#else
- localePath << M_BASEDIR << "/locale";
-+#endif
- #elif defined(OS_WIN)
- InitGlobalDir();
- String localePath;
-@@ -835,7 +839,12 @@
- READ_APPCONFIG(MP_HELPBROWSER),
- READ_APPCONFIG(MP_HELPBROWSER_ISNS));
- #endif
-+#ifdef __FreeBSD__
-+ helpfile = M_PREFIX;
-+ helpfile += "/share/doc/Mahogany";
-+#else
- helpfile = GetGlobalDir()+"/doc";
-+#endif // __FreeBSD__
- #else // Windows
- helpfile = GetGlobalDir()+"\\doc\\Mahogany.hlp";
- #endif // Unix/Windows
---- src/gui/wxMDialogs.cpp.orig Sun Nov 12 04:24:18 2000
-+++ src/gui/wxMDialogs.cpp Sun Nov 12 05:19:40 2000
-@@ -1006,15 +1006,9 @@
- {
- String dir, filename;
-
-- // Tips files are in @prefix@/share/Mahogany/doc/Tips/
-- dir = mApplication->GetGlobalDir();
-- if ( !dir )
-- {
-- // like this, it will work in an uninstalled copy of M too
-- dir = "..";
-- }
--
-- dir << DIR_SEPARATOR << "doc" << DIR_SEPARATOR << "Tips" << DIR_SEPARATOR;
-+ // Tips files are in @prefix@/share/doc/Mahogany/Tips/
-+ dir << M_PREFIX << DIR_SEPARATOR << "share" << DIR_SEPARATOR << "doc";
-+ dir << DIR_SEPARATOR << "Mahogany" << DIR_SEPARATOR << "Tips" << DIR_SEPARATOR;
-
- // Tips files are either Tips_LOCALENAME.txt, e.g. Tips_de.txt or
- // simply Tips.txt
diff --git a/mail/mahogany/files/patch-ae b/mail/mahogany/files/patch-ae
deleted file mode 100644
index 91b21cae19c1..000000000000
--- a/mail/mahogany/files/patch-ae
+++ /dev/null
@@ -1,44 +0,0 @@
---- src/classes/MModule.cpp.orig Mon Nov 6 14:58:02 2000
-+++ src/classes/MModule.cpp Thu Nov 16 00:07:29 2000
-@@ -683,22 +683,24 @@
-
- static wxArrayString BuildListOfModulesDirs()
- {
-- // look under extra M_CANONICAL_HOST directory under Unix, but not for other
-- // platforms (doesn't make much sense under Windows)
--
- wxString path1, path2;
- wxArrayString dirs;
-
-- path1 << mApplication->GetGlobalDir()
-+#if defined(OS_UNIX) && defined( __FreeBSD__)
-+ path1 << M_PREFIX << DIR_SEPARATOR << "libdata"
-+ << DIR_SEPARATOR << "Mahogany"
-+#else
-+ path1 << mApplication->GetLocalDir()
- #ifdef OS_UNIX
- << DIR_SEPARATOR << M_CANONICAL_HOST
--#endif // Unix
-+#endif
-+#endif
- << DIR_SEPARATOR << "modules" << DIR_SEPARATOR;
-
- path2 << mApplication->GetLocalDir()
- #ifdef OS_UNIX
- << DIR_SEPARATOR << M_CANONICAL_HOST
--#endif // Unix
-+#endif
- << DIR_SEPARATOR << "modules" << DIR_SEPARATOR;
-
- dirs.Add(path1);
---- src/classes/Profile.cpp.orig Sun Nov 12 09:12:38 2000
-+++ src/classes/Profile.cpp Sun Nov 12 09:12:12 2000
-@@ -765,7 +765,7 @@
- // 3. default installation dir
- String globalFileName, globalFile;
- globalFileName << '/' << M_APPLICATIONNAME << ".conf";
-- globalFile = String(M_PREFIX) + globalFileName;
-+ globalFile = String(M_PREFIX) + "/etc" + globalFileName;
- if ( !wxFileExists(globalFile) )
- {
- const char *dir = getenv("MAHOGANY_DIR");
diff --git a/mail/mahogany/files/patch-af b/mail/mahogany/files/patch-af
deleted file mode 100644
index 475fa258cd43..000000000000
--- a/mail/mahogany/files/patch-af
+++ /dev/null
@@ -1,62 +0,0 @@
---- doc/HackersGuide.htex.orig Sun Nov 12 06:24:51 2000
-+++ doc/HackersGuide.htex Sun Nov 12 06:24:47 2000
-@@ -1,8 +1,8 @@
- %% LyX 1.1 created this file. For more info, see http://www.lyx.org/.
- %% Do not edit unless you really know what you are doing.
- \documentclass[12pt,letterpaper,oneside]{book}
--\usepackage{palatino}
--\usepackage[T1]{fontenc}
-+%% \usepackage{palatino}
-+%% \usepackage[T1]{fontenc}
-
- \makeatletter
-
---- doc/Manual.htex.orig Sun Nov 12 06:24:00 2000
-+++ doc/Manual.htex Sun Nov 12 06:25:02 2000
-@@ -3,8 +3,8 @@
-
- %% Do not edit this file unless you know what you are doing.
- \documentclass[12pt,letterpaper,oneside]{book}
--\usepackage[T1]{fontenc}
--\usepackage{palatino}
-+%% \usepackage[T1]{fontenc}
-+%% \usepackage{palatino}
-
- \makeatletter
-
---- doc/Makefile.sub.orig Sat Sep 30 12:10:13 2000
-+++ doc/Makefile.sub Thu Feb 1 12:44:15 2001
-@@ -3,12 +3,14 @@
-
- include ../../makeopts
-
--all: wxhelp.map
-+all: $(DIR)/wxhelp.map
- @true
-
- #include ../../makerules
-
--wxhelp.map: ../.src/$(DIR).htex ../.src/html.sty
-+HTML2WXHELP= $(shell pwd)/../../.src/extra/scripts/html2wxhelp
-+
-+$(DIR)/wxhelp.map: ../.src/$(DIR).htex ../.src/html.sty
- @ln -sf ../.src/$(DIR).htex ../.src/html.sty ../.src/pics .
- ../../.src/extra/scripts/striphelpids $(DIR).htex >tmp.tex
- $(LATEX) tmp.tex </dev/null
-@@ -21,11 +23,12 @@
- mv tmp.dvi $(DIR).dvi
- mv tmp.aux $(DIR).aux
- rm -f tmp.*
-- @$(RM) -r $(DIR)
-- $(LATEX2HTML) -local_icons -debug $(DIR).htex
-- cd $(DIR) && ../../../.src/extra/scripts/html2wxhelp > ../wxhelp.map
-+ $(LATEX2HTML) -mkdir -dir /tmp/$(DIR) -local_icons -debug $(DIR).htex
-+ cd /tmp/$(DIR) && $(HTML2WXHELP) > wxhelp.map
-+ @(cd /tmp; tar -cpf - ${DIR}) | tar -xf -
-+ @${RM} -r /tmp/$(DIR)
-
--install: wxhelp.map
-+install: $(DIR)/wxhelp.map
- $(INSTALL_DATA) $(DIR).pdf $(DOCDIR)/Pdf
- @$(RM) -r $(DOCDIR)/$(DIR)
- $(INSTALL) -d $(DOCDIR)/$(DIR)
diff --git a/mail/mahogany/files/patch-ag b/mail/mahogany/files/patch-ag
deleted file mode 100644
index 9d4dd642468f..000000000000
--- a/mail/mahogany/files/patch-ag
+++ /dev/null
@@ -1,16 +0,0 @@
---- extra/install/Makefile.orig Sun Nov 12 06:55:27 2000
-+++ extra/install/Makefile Sun Nov 12 06:56:48 2000
-@@ -16,10 +16,8 @@
- done
- $(INSTALL_DATA) .src/newmail.wav $(DATADIR)
- $(INSTALL_DATA) .src/kylemail.wav $(DATADIR)
--# $(INSTALL_DATA) .src/mailcap $(DATADIR)
-- $(INSTALL_DATA) .src/M.conf $(DATADIR)
-- $(INSTALL) -d $(DESTDIR)/man/man1
-- $(INSTALL_DATA) .src/mahogany.1 $(DESTDIR)/man/man1
-- $(INSTALL_DATA) .src/mahogany.1 $(DESTDIR)/man/man1/M.1
-+ $(INSTALL_DATA) .src/M.conf $(PREFIX)/etc/mahogany.conf.sample
-+ $(INSTALL) -d $(PREFIX)/man/man1
-+ $(INSTALL_DATA) .src/mahogany.1 $(PREFIX)/man/man1
-
- .PHONY: install
diff --git a/mail/mahogany/files/patch-ah b/mail/mahogany/files/patch-ah
deleted file mode 100644
index ed5ef51ae6db..000000000000
--- a/mail/mahogany/files/patch-ah
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/Makefile.orig Sat Sep 30 12:10:50 2000
-+++ src/Makefile Sun Nov 12 09:09:41 2000
-@@ -65,14 +65,8 @@
- $(RM) core libM.so M M.static
-
- install:
-- $(INSTALL_PROGRAM) -s -m 755 M $(DATADIR)/$(CANONICAL_HOST)/bin
-- if test -f libM.so; \
-- then $(INSTALL_PROGRAM) libM.so $(DATADIR)/$(CANONICAL_HOST)/lib; \
-- fi
-- $(RM) -f $(BINDIR)/M $(DATADIR)/bin/M
-- ln -f -s ../share/Mahogany/$(CANONICAL_HOST)/bin/M $(BINDIR)/M
-- $(RM) $(BINDIR)/mahogany
-- ln -f -s ../share/Mahogany/$(CANONICAL_HOST)/bin/M $(BINDIR)/mahogany
-+ $(INSTALL_PROGRAM) -s -m 755 M $(BINDIR)/M
-+ ln -f -s M $(BINDIR)/mahogany
- ifeq ($(USE_MODULES),dynamic)
- set -e; for i in $(MOD_DIRS); do $(MAKE) -C $$i install-modules; done
- endif
diff --git a/mail/mahogany/files/patch-ai b/mail/mahogany/files/patch-ai
deleted file mode 100644
index 9a40cf2ac473..000000000000
--- a/mail/mahogany/files/patch-ai
+++ /dev/null
@@ -1,31 +0,0 @@
---- locale/Makefile.orig Sat Sep 30 12:10:48 2000
-+++ locale/Makefile Sun Nov 12 07:47:53 2000
-@@ -9,6 +9,8 @@
-
- include ../makeopts
-
-+LOCALE_DIR=$(DESTDIR)/share/locale
-+
- vpath %.po .src
-
- %.mo: %.po
-@@ -30,14 +32,14 @@
- @for i in $(FILES_PO); do echo $$i:; msgfmt -v $$i ; done
-
- install: all
-- $(INSTALL) -d $(DATADIR)/locale
-+ $(INSTALL) -d $(LOCALE_DIR)
- set -e; for i in $(FILES_MO); \
-- do $(INSTALL) -d $(DATADIR)/locale/`basename $$i .mo`/LC_MESSAGES; \
-- $(INSTALL_DATA) $$i $(DATADIR)/locale/`basename $$i .mo`/LC_MESSAGES/M.mo; \
-+ do $(INSTALL) -d $(LOCALE_DIR)/`basename $$i .mo`/LC_MESSAGES; \
-+ $(INSTALL_DATA) $$i $(LOCALE_DIR)/`basename $$i .mo`/LC_MESSAGES/M.mo; \
- done
- set -e; for i in wxstd/*.mo; \
-- do $(INSTALL) -d $(DATADIR)/locale/`basename $$i .mo`/LC_MESSAGES; \
-- $(INSTALL_DATA) $$i $(DATADIR)/locale/`basename $$i .mo`/LC_MESSAGES/wxstd.mo; \
-+ do $(INSTALL) -d $(LOCALE_DIR)/`basename $$i .mo`/LC_MESSAGES; \
-+ $(INSTALL_DATA) $$i $(LOCALE_DIR)/`basename $$i .mo`/LC_MESSAGES/wxstd.mo; \
- done
-
- msgcat:
diff --git a/mail/mahogany/files/patch-include-MThread.h b/mail/mahogany/files/patch-include-MThread.h
new file mode 100644
index 000000000000..66ef9db8aeb3
--- /dev/null
+++ b/mail/mahogany/files/patch-include-MThread.h
@@ -0,0 +1,27 @@
+--- include/MThread.h.orig Wed Jul 23 00:01:38 2003
++++ include/MThread.h Sun Oct 5 00:39:39 2003
+@@ -19,8 +19,23 @@
+
+ #if USE_THREADS
+
++#include "wx/thread.h"
++
+ // use inheritance and not typedef to allow forward declaring it
+-class MMutex : public wxMutex { };
++class MMutex : public wxMutex {
++public:
++ bool IsLocked() const {
++ if ( TryLock() == wxMUTEX_NO_ERROR )
++ {
++ Unlock();
++ return false;
++ }
++ else
++ {
++ return true;
++ }
++ }
++};
+
+ #else // !USE_THREADS
+
diff --git a/mail/mahogany/files/patch-makeopts.in b/mail/mahogany/files/patch-makeopts.in
new file mode 100644
index 000000000000..2e2cbc2b4bf3
--- /dev/null
+++ b/mail/mahogany/files/patch-makeopts.in
@@ -0,0 +1,17 @@
+--- makeopts.in.orig Sat Oct 4 23:36:51 2003
++++ makeopts.in Sat Oct 4 23:38:06 2003
+@@ -108,11 +108,11 @@
+ # Directory in which to install library files.
+ DATADIR = $(DESTDIR)/share/Mahogany
+ # where to install docs
+-DOCDIR = $(DATADIR)/doc
++DOCDIR = $(DESTDIR)/share/doc/Mahogany
+
+ # for the dynamic linker, better than using -rpath
+-LD_RUN_PATH=$(DATADIR)/$(CANONICAL_HOST)/lib
+-MODULEDIR=$(DATADIR)/$(CANONICAL_HOST)/modules
++LD_RUN_PATH=$(DESTDIR)/lib
++MODULEDIR=$(DESTDIR)/libexec/Mahogany/modules
+
+ LINK = $(CXX)
+
diff --git a/mail/mahogany/files/patch-src-Makefile b/mail/mahogany/files/patch-src-Makefile
new file mode 100644
index 000000000000..bc38fead4689
--- /dev/null
+++ b/mail/mahogany/files/patch-src-Makefile
@@ -0,0 +1,19 @@
+--- src/Makefile.orig Sat Oct 4 23:45:28 2003
++++ src/Makefile Sat Oct 4 23:47:49 2003
+@@ -139,14 +139,8 @@
+ $(RM) $(MOBJS:.o=.d) $(MSOS:.so=.d)
+
+ install:
+- $(INSTALL_PROGRAM) $(INSTALL_OPTIONS) M $(DATADIR)/$(CANONICAL_HOST)/bin
+- if test -f libM.so; \
+- then $(INSTALL_PROGRAM) libM.so $(DATADIR)/$(CANONICAL_HOST)/lib; \
+- fi
+- $(RM) -f $(BINDIR)/M $(DATADIR)/bin/M
+- ln -f -s ../share/Mahogany/$(CANONICAL_HOST)/bin/M $(BINDIR)/M
+- $(RM) $(BINDIR)/mahogany
+- ln -f -s ../share/Mahogany/$(CANONICAL_HOST)/bin/M $(BINDIR)/mahogany
++ ${INSTALL_PROGRAM} ${INSTALL_OPTIONS} M ${BINDIR}
++ ln -f -s ${BINDIR}/M ${BINDIR}/mahogany
+ ifeq ($(USE_MODULES),dynamic)
+ $(INSTALL) -d $(MODULEDIR)
+ set -e $(MSOS); while test $$# -ge 1; \
diff --git a/mail/mahogany/files/patch-src-classes-MModule.cpp b/mail/mahogany/files/patch-src-classes-MModule.cpp
new file mode 100644
index 000000000000..d55fc6c7b7a4
--- /dev/null
+++ b/mail/mahogany/files/patch-src-classes-MModule.cpp
@@ -0,0 +1,14 @@
+--- src/classes/MModule.cpp.orig Tue Jul 22 14:07:38 2003
++++ src/classes/MModule.cpp Sun Oct 5 03:02:24 2003
+@@ -870,10 +870,7 @@
+ // platforms (doesn't make much sense under Windows)
+
+ wxString path1;
+- path1 << mApplication->GetGlobalDir()
+-#ifdef OS_UNIX
+- << DIR_SEPARATOR << M_CANONICAL_HOST
+-#endif // Unix
++ path1 << M_PREFIX << DIR_SEPARATOR << "libexec" << DIR_SEPARATOR << "Mahogany"
+ << DIR_SEPARATOR << _T("modules") << DIR_SEPARATOR;
+
+ dirs.Add(path1);
diff --git a/mail/mahogany/files/patch-src-gui-wxMApp.cpp b/mail/mahogany/files/patch-src-gui-wxMApp.cpp
new file mode 100644
index 000000000000..369a961917f0
--- /dev/null
+++ b/mail/mahogany/files/patch-src-gui-wxMApp.cpp
@@ -0,0 +1,11 @@
+--- src/gui/wxMApp.cpp.orig Tue Aug 5 01:04:21 2003
++++ src/gui/wxMApp.cpp Sun Oct 5 03:06:51 2003
+@@ -911,7 +911,7 @@
+ // now load the message catalogs
+ #ifdef OS_UNIX
+ String localePath;
+- localePath << M_BASEDIR << "/locale";
++ localePath << M_PREFIX << "/share/locale";
+ #elif defined(OS_WIN)
+ // the program directory is not initialized yet so we can't do much
+ // more than looking in the current directory...
diff --git a/mail/mahogany/files/patch-src-gui-wxMDialogs.cpp b/mail/mahogany/files/patch-src-gui-wxMDialogs.cpp
new file mode 100644
index 000000000000..132b94dbbfdb
--- /dev/null
+++ b/mail/mahogany/files/patch-src-gui-wxMDialogs.cpp
@@ -0,0 +1,25 @@
+--- src/gui/wxMDialogs.cpp.orig Wed Jul 23 00:01:41 2003
++++ src/gui/wxMDialogs.cpp Sun Oct 5 03:10:29 2003
+@@ -1286,19 +1286,9 @@
+ {
+ String dir, filename;
+
+- // Tips files are in @prefix@/share/Mahogany/doc/Tips/
+- dir = mApplication->GetGlobalDir();
+- if ( !dir )
+- {
+- // like this, it will work in an uninstalled copy of M too
+- dir = _T("..");
+- }
+-
+- dir << DIR_SEPARATOR << _T("doc") << DIR_SEPARATOR
+-#ifndef OS_WIN
+- << _T("Tips") << DIR_SEPARATOR
+-#endif // !Windows
+- ;
++ // Tips files are in @prefix@/share/doc/Mahogany/Tips/
++ dir << M_PREFIX << DIR_SEPARATOR << "share" << DIR_SEPARATOR << "doc";
++ dir << DIR_SEPARATOR << "Mahogany" << DIR_SEPARATOR << "Tips" << DIR_SEPARATOR;
+
+ // Tips files are either Tips_LOCALENAME.txt, e.g. Tips_de.txt or
+ // simply Tips.txt