aboutsummaryrefslogtreecommitdiff
path: root/mail/mboxgrep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mboxgrep/Makefile')
-rw-r--r--mail/mboxgrep/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/mail/mboxgrep/Makefile b/mail/mboxgrep/Makefile
index e28657e4387f..01e5939a6a8e 100644
--- a/mail/mboxgrep/Makefile
+++ b/mail/mboxgrep/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= SF
MAINTAINER= anders@FreeBSD.org
COMMENT= Utility to scan mailboxes for messages matching a regular expression
-.if defined(WITH_PCRE)
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
-.endif
+PCRE_LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+
+OPTIONS_DEFINE= DOCS PCRE
USES= uidfix
GNU_CONFIGURE= yes
@@ -32,11 +32,9 @@ post-patch:
${WRKSRC}/src/Makefile.in ${WRKSRC}/doc/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
${INSTALL} -d -o root -g wheel -m 0755 ${STAGEDIR}${DOCSDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
-.endif
.include <bsd.port.mk>