aboutsummaryrefslogtreecommitdiff
path: root/mail/mboxgrep
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mboxgrep')
-rw-r--r--mail/mboxgrep/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/mail/mboxgrep/Makefile b/mail/mboxgrep/Makefile
index 6202b8bb0f0a..213f6930f656 100644
--- a/mail/mboxgrep/Makefile
+++ b/mail/mboxgrep/Makefile
@@ -19,14 +19,17 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+USE_REINPLACE= yes
MAN1= mboxgrep.1
INFO= mboxgrep
DOCS= ChangeLog NEWS README TODO
+post-patch:
+ @${REINPLACE_CMD} -e 's,void \*tmpp,FILE \*tmpp,g' ${WRKSRC}/src/main.c
+
post-install:
install-info ${PREFIX}/info/mboxgrep.info ${PREFIX}/info/dir
.if !defined(NOPORTDOCS)