aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mutt-devel/Makefile')
-rw-r--r--mail/mutt-devel/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 41c1ec86f058..b59d8f585517 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -373,6 +373,14 @@ CONFIGURE_ARGS+= --enable-gpgme
.else
CONFIGURE_ARGS+= --disable-gpgme
.endif
+.if !defined(WITHOUT_GSSAPI)
+.if exists(${LOCALBASE}/bin/krb5-config)
+LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
+CONFIGURE_ARGS+= --with-gss=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --with-gss
+.endif
+.endif
PATCH_DIST_STRIP= -p1
@@ -441,6 +449,11 @@ post-patch::
pre-configure::
@(cd ${WRKSRC}; ${SETENV} ${AUTOMAKE_ENV} ${ACLOCAL} -I m4)
+.if !exists(${LOCALBASE}/bin/krb5-config)
+ @${ECHO_CMD} "#define HAVE_HEIMDAL" >> ${WRKSRC}/config.h.in
+ @${REINPLACE_CMD} -e 's|<gssapi/gssapi\.h>|<gssapi.h>|' \
+ ${WRKSRC}/imap/auth_gss.c
+.endif
.if defined(MUTT_SLAVE_HTML_PAGES)
SCRIPTS_ENV+= MUTT_SLAVE_HTML_PAGES="${MUTT_SLAVE_HTML_PAGES}"