aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mutt/Makefile')
-rw-r--r--mail/mutt/Makefile58
1 files changed, 22 insertions, 36 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 9e11ccee9734..df2593c4870c 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mutt
-PORTVERSION= 1.6.1
+PORTVERSION= 1.7.0
PORTREVISION?= 0
CATEGORIES+= mail ipv6
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
@@ -18,8 +18,10 @@ PATCH_SITES+= http://www.mutt.org.ua/download/mutt-${VVV_PATCH_VERSION}/:vvv \
http://www2.mutt.org.ua/download/mutt-${VVV_PATCH_VERSION}/:vvv \
http://home.woolridge.ca/mutt/patches/:dw
-MAINTAINER?= udo.schweigert@siemens.com
-COMMENT?= The Mongrel of Mail User Agents (development version)
+MAINTAINER?= dereks@lifeofadishwasher.com
+COMMENT?= The Mongrel of Mail User Agents
+
+LICENSE= GPLv2+
CONFLICTS?= ja-mutt-[0-9]* ja-mutt-devel-[0-9]* mutt-1.4* mutt-devel-lite-[0-9]* mutt-lite-[0-9]* zh-mutt-devel-[0-9]*
@@ -33,7 +35,7 @@ CONFIGURE_ARGS= --disable-fcntl --with-ssl=${OPENSSLBASE} \
--enable-external-dotlock --enable-pop --enable-imap \
--disable-warnings
-USES+= cpe shebangfix
+USES+= cpe shebangfix ssl
SHEBANG_FILES= doc/gen-map-doc smime_keys.pl contrib/smime_keys_test.pl
.if defined(MUTT_CONFIGURE_ARGS)
@@ -43,7 +45,6 @@ CONFIGURE_ARGS+= ${MUTT_CONFIGURE_ARGS}
USES+= autoreconf
GNU_CONFIGURE= yes
AUTOMAKE_ARGS= --add-missing --foreign
-USE_OPENSSL= yes
OPTIONS_SUB= yes
@@ -60,9 +61,9 @@ OPTIONS_DEFINE= COMPRESSED_FOLDERS SASL DEBUG DOCS EXAMPLES FLOCK \
IMAP_HEADER_CACHE LOCALES_FIX MAILBOX_MANPAGES \
MAILDIR_HEADER_CACHE MAILDIR_MTIME_PATCH \
MIXMASTER NLS NNTP PARENT_CHILD_MATCH_PATCH \
- QUOTE_PATCH REVERSE_REPLY_PATCH SIDEBAR_PATCH \
+ QUOTE_PATCH REVERSE_REPLY_PATCH SIDEBAR \
SMART_DATE SMIME_OUTLOOK_COMPAT SMTP TOKYOCABINET \
- TRASH_PATCH URLVIEW XML
+ URLVIEW XML
OPTIONS_SINGLE= GSSAPI SCREEN
OPTIONS_RADIO= SPELL
@@ -91,13 +92,12 @@ NLS_DESC= Native language support (implies ICONV)
PARENT_CHILD_MATCH_PATCH_DESC= Parent/child match
QUOTE_PATCH_DESC= Extended quoting
REVERSE_REPLY_PATCH_DESC= Reverse_reply
-SIDEBAR_PATCH_DESC= Sidebar support
+SIDEBAR_DESC= Sidebar support
SLANG_DESC= SLANG support
SMART_DATE_DESC= Dynamic date formatting with "%@"
SMIME_OUTLOOK_COMPAT_DESC= SMIME outlook compatibility
SMTP_DESC= SMTP relay support
TOKYOCABINET_DESC= Use tokyocabinet instead of Berkley DB
-TRASH_PATCH_DESC= Trash folder support
URLVIEW_DESC= Use urlview for the URL selector menu
XML_DESC= Use XML tools for rebuilding documentation
@@ -106,16 +106,16 @@ OPTIONS_DEFAULT= COMPRESSED_FOLDERS HTML ICONV IDN IFDEF_PATCH \
MAILDIR_HEADER_CACHE MAILDIR_MTIME_PATCH NLS \
NCURSES PARENT_CHILD_MATCH_PATCH QUOTE_PATCH \
REVERSE_REPLY_PATCH SMART_DATE SMIME_OUTLOOK_COMPAT \
- SASL SMTP TRASH_PATCH URLVIEW XML GSSAPI_NONE
+ SASL SMTP URLVIEW XML GSSAPI_NONE
.endif
RUN_DEPENDS+= ${LOCALBASE}/etc/mime.types:misc/mime-support
.if !defined (LITE)
ASPELL_BUILD_DEPENDS= aspell:textproc/aspell
-ASPELL_RUN_DEPENDS= aspell:textproc/aspell
+ASPELL_RUN_DEPENDS= aspell:textproc/aspell
ISPELL_BUILD_DEPENDS= ispell:textproc/aspell-ispell
-ISPELL_RUN_DEPENDS= ispell:textproc/aspell-ispell
+ISPELL_RUN_DEPENDS= ispell:textproc/aspell-ispell
URLVIEW_RUN_DEPENDS= urlview:textproc/urlview
.endif
@@ -141,7 +141,8 @@ SLANG_VARS= PKGMESSAGE=${FILESDIR}/pkg-message.slang
NCURSES_USES= ncurses
NLS_USES= gettext
-NLS_CONFIGURE_OFF= --disable-nls
+NLS_CONFIGURE_ENABLE= nls
+#NLS_CONFIGURE_OFF= --disable-nls
NLS_IMPLIES= ICONV
# Handle GSSAPI from various places
@@ -171,22 +172,18 @@ MIXMASTER_CONFIGURE_ON= --with-mixmaster=${LOCALBASE}
SMIME_OUTLOOK_COMPAT_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-smime-outlook
SMART_DATE_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-smartdate
-FLOCK_CONFIGURE_ON= --enable-flock
-FLOCK_CONFIGURE_OFF= --disable-flock
+FLOCK_CONFIGURE_ENABLE= flock
LOCALES_FIX_CONFIGURE_ON= --enable-locales-fix
IDN_LIB_DEPENDS= libidn.so:dns/libidn
-IDN_CONFIGURE_ON= --with-idn
-IDN_CONFIGURE_OFF= --without-idn
+IDN_CONFIGURE_WITH= idn
IDN_IMPLIES= ICONV
GPGME_LIB_DEPENDS= libgpgme.so:security/gpgme
-GPGME_CONFIGURE_ON= --enable-gpgme
-GPGME_CONFIGURE_OFF= --disable-gpgme
+GPGME_CONFIGURE_ENABLE= gpgme
-SMTP_CONFIGURE_ON= --enable-smtp
-SMTP_CONFIGURE_OFF= --disable-smtp
+SMTP_CONFIGURE_ENABLE= smtp
MAILDIR_HEADER_CACHE_CONFIGURE_OFF= --without-qdbm
@@ -195,7 +192,7 @@ COMPRESSED_FOLDERS_CONFIGURE_ON= --enable-compressed
COMPRESSED_FOLDERS_VARS= XML_NEEDED=yes
QUOTE_PATCH_PATCHFILES= patch-${VVV_PATCH_VERSION}.vvv.initials.gz:vvv \
- patch-${VVV_PATCH_VERSION}.vvv.quote.gz:vvv
+ patch-${VVV_PATCH_VERSION}.vvv.quote.gz:vvv
QUOTE_PATCH_VARS= XML_NEEDED=yes
NNTP_DISTFILES= patch-${VVV_PATCH_VERSION}.vvv.nntp.gz:vvv \
@@ -204,15 +201,15 @@ NNTP_CONFIGURE_ON= --enable-nntp
NNTP_VARS= XML_NEEDED=yes
NNTP_CATEGORIES= news
-SIDEBAR_PATCH_VARS= XML_NEEDED=yes
+SIDEBAR_CONFIGURE_ENABLE= sidebar
+SIDEBAR_CONFIGURE_ON= --enable-sidebar
+SIDEBAR_VARS= XML_NEEDED=yes
DOCS_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-doc-ref
.include <bsd.port.options.mk>
DW_PATCH_VERSION= 1.5.6
-VVV_PATCH_VERSION:= 1.6.0
-RR_PATCH_VERSION:= 1.6.0
.if !defined(VVV_PATCH_VERSION)
VVV_PATCH_VERSION= ${PORTVERSION}
.endif
@@ -255,10 +252,6 @@ pre-patch-NNTP-on:
@${PATCH} ${PATCH_ARGS} -p1 < ${WRKDIR}/patch-nntp
post-patch-NNTP-on:
-.if ${PORT_OPTIONS:MSIDEBAR_PATCH}
- @${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-sidebar-nntp
- @${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-sidebar-refresh
-.endif
.if ${PORT_OPTIONS:MMAILDIR_MTIME_PATCH}
@${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-maildir-mtime-nntp
.endif
@@ -267,10 +260,6 @@ post-patch-NNTP-on:
.endif
post-patch-NNTP-off:
-.if ${PORT_OPTIONS:MSIDEBAR_PATCH}
- @${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-sidebar
- @${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-sidebar-refresh
-.endif
.if ${PORT_OPTIONS:MMAILDIR_MTIME_PATCH}
@${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-maildir-mtime
.endif
@@ -290,9 +279,6 @@ post-patch-GREETING_PATCH-on:
post-patch-IFDEF_PATCH-on:
@${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-ifdef
-post-patch-TRASH_PATCH-on:
- @${PATCH} ${PATCH_ARGS} -p1 < ${PATCHDIR}/extra-patch-trash-purge
-
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
post-patch::