aboutsummaryrefslogtreecommitdiff
path: root/mail/noattach
diff options
context:
space:
mode:
Diffstat (limited to 'mail/noattach')
-rw-r--r--mail/noattach/Makefile1
-rw-r--r--mail/noattach/files/noattach.sh4
2 files changed, 3 insertions, 2 deletions
diff --git a/mail/noattach/Makefile b/mail/noattach/Makefile
index b16762d09295..a0248231c283 100644
--- a/mail/noattach/Makefile
+++ b/mail/noattach/Makefile
@@ -7,6 +7,7 @@
PORTNAME= noattach
PORTVERSION= 1.1.1
+PORTVREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.rhnet.is/pub/noattach/
DISTNAME= ${PORTNAME}-1.1p1
diff --git a/mail/noattach/files/noattach.sh b/mail/noattach/files/noattach.sh
index 95589b4b3021..3a63cb9be69e 100644
--- a/mail/noattach/files/noattach.sh
+++ b/mail/noattach/files/noattach.sh
@@ -24,13 +24,13 @@ stop)
reload)
if test -r /var/run/noattach.pid
then
- kill `head -SIGUSR1 /var/run/noattach.pid`
+ kill -USR1 `head -1 /var/run/noattach.pid`
else
echo " noattach: not running" 2>&1
fi
;;
*)
- echo "Usage: ${0##*/}: { start | stop }" 2>&1
+ echo "Usage: ${0##*/}: { start | stop | reload }" 2>&1
exit 65
;;
esac