aboutsummaryrefslogtreecommitdiff
path: root/mail/opendkim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/opendkim/Makefile')
-rw-r--r--mail/opendkim/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index 5824fe6372f4..ee415ecfea30 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= opendkim
-PORTVERSION= 2.7.4
-PORTREVISION= 1
+PORTVERSION= 2.8.0
CATEGORIES= mail security
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME} \
@@ -109,7 +108,7 @@ CONFIGURE_ARGS+= --with-db-lib=c
CONFIGURE_ARGS+= --with-db-incdir=${BDB_INCLUDE_DIR} \
--with-db-libdir=${BDB_LIB_DIR} \
--with-db-lib=${BDB_LIB_NAME}
-USE_BDB= 41+
+USE_BDB= 40+
. endif
.endif
.if ${PORT_OPTIONS:MUNBOUND}
@@ -155,6 +154,17 @@ USE_LUA= 5.1
PLIST_SUB+= LUA="@comment "
.endif
+pre-configure:
+ ${REINPLACE_CMD} -e '/PKG_CONFIG/s/lua5/lua-5/' \
+ ${WRKSRC}/configure
+
+post-patch:
+.if ${PORT_OPTIONS:MLCOV}
+ ${CP} ${FILESDIR}/lcov-helper.sh ${WRKSRC}/libopendkim/tests/
+ ${CP} ${FILESDIR}/lcov-helper.sh ${WRKSRC}/opendkim/tests/
+ ${FIND} ${WRKSRC} -type f -name \*-helper.sh -exec ${CHMOD} 755 {} +
+.endif
+
post-install:
.if ! ${PORT_OPTIONS:MDEBUG} && ${PORT_OPTIONS:MFILTER}
@${STRIP_CMD} ${PREFIX}/sbin/opendkim