aboutsummaryrefslogtreecommitdiff
path: root/mail/opendkim/files/patch-libopendkim__tests__Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'mail/opendkim/files/patch-libopendkim__tests__Makefile.in')
-rw-r--r--mail/opendkim/files/patch-libopendkim__tests__Makefile.in41
1 files changed, 41 insertions, 0 deletions
diff --git a/mail/opendkim/files/patch-libopendkim__tests__Makefile.in b/mail/opendkim/files/patch-libopendkim__tests__Makefile.in
new file mode 100644
index 000000000000..213f3538cd34
--- /dev/null
+++ b/mail/opendkim/files/patch-libopendkim__tests__Makefile.in
@@ -0,0 +1,41 @@
+--- ./libopendkim/tests/Makefile.in.orig 2013-02-26 06:06:04.000000000 +0900
++++ ./libopendkim/tests/Makefile.in 2013-02-26 19:58:50.000000000 +0900
+@@ -1049,8 +1049,10 @@
+ { print $$2, files[$$2]; n[$$2] = 0; files[$$2] = "" } } \
+ END { for (dir in files) print dir, files[dir] }'
+ am__base_list = \
+- sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
+- sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
++ sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\
++/ /g' | \
++ sed '$$!N;$$!N;$$!N;$$!N;s/\
++/ /g'
+ am__uninstall_files_from_dir = { \
+ test -z "$$files" \
+ || { test ! -d "$$dir" && test ! -f "$$dir" && test ! -r "$$dir"; } \
+@@ -2782,16 +2784,19 @@
+ @LCOV_TRUE@description.txt: $(check_PROGRAMS) $(check_SCRIPTS)
+ @LCOV_TRUE@ rm -f $@
+ @LCOV_TRUE@ for i in $(check_PROGRAMS); do \
+-@LCOV_TRUE@ testname=$${i/t-}; \
+-@LCOV_TRUE@ testname=$${testname//-/_}; \
++@LCOV_TRUE@ testname=$${i#t-}; \
++@LCOV_TRUE@ testname=$$(echo $${testname} | sed -e 's/-/_/g'); \
+ @LCOV_TRUE@ fgrep '***' $$i.c | tail -n 1 | \
+-@LCOV_TRUE@ (echo $${testname} ; sed -e 's/[^*]*\*\*\*\(.*\)\\n.*/\t\1\n/g' ) >> $@; \
++@LCOV_TRUE@ (echo $${testname} ; sed -e 's/[^*]*\*\*\*\(.*\)\\
++@LCOV_TRUE@.*/ \1\
++@LCOV_TRUE@/g' ) >> $@; \
+ @LCOV_TRUE@ done
+ @LCOV_TRUE@ for i in $(check_SCRIPTS); do \
+-@LCOV_TRUE@ testname=$${i/t-}; \
+-@LCOV_TRUE@ testname=$${testname//-/_}; \
++@LCOV_TRUE@ testname=$${i#t-}; \
++@LCOV_TRUE@ testname=$$(echo $${testname} | sed -e 's/-/_/g'); \
+ @LCOV_TRUE@ grep '^#' $$i | tail -n 1 | \
+-@LCOV_TRUE@ (echo $${testname} ; sed -e 's/^# \(.*\)/\t\1\n/g' ) >> $@; \
++@LCOV_TRUE@ (echo $${testname} ; sed -e 's/^# \(.*\)/ \1\
++@LCOV_TRUE@/g' ) >> $@; \
+ @LCOV_TRUE@ done
+
+ @LCOV_TRUE@description.html: description.txt