aboutsummaryrefslogtreecommitdiff
path: root/mail/opendmarc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/opendmarc/Makefile')
-rw-r--r--mail/opendmarc/Makefile39
1 files changed, 19 insertions, 20 deletions
diff --git a/mail/opendmarc/Makefile b/mail/opendmarc/Makefile
index 8e255081cfe5..032b1d075f5c 100644
--- a/mail/opendmarc/Makefile
+++ b/mail/opendmarc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= opendmarc
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= mail security
MASTER_SITES= SF/${PORTNAME} \
SF/${PORTNAME}/Previous%20Releases
@@ -18,34 +19,32 @@ LICENSE_GROUPS_SENDMAIL= FSF OSI
LICENSE_NAME_SENDMAIL= Sendmail Open Source License
LICENSE_PERMS_SENDMAIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-.if !exists( /usr/include/libmilter/mfapi.h )
-BUILD_DEPENDS+= ${LOCALBASE}/include/libmilter/mfapi.h:${PORTSDIR}/mail/sendmail
-CFLAGS+= -I${LOCALBASE}/include
-.endif
-
USES= libtool shebangfix
-SHEBANG_FILES= reports/opendmarc-expire.in \
- reports/opendmarc-import.in \
- reports/opendmarc-params.in \
- reports/opendmarc-reports.in
-
-USE_RC_SUBR= opendmarc
USE_LDCONFIG= yes
+USE_RC_SUBR= opendmarc
-GNU_CONFIGURE= yes
-
-PORTDOCS= *
+GNU_CONFIGURE= yes
-OPTIONS_DEFINE= SPF
+OPTIONS_DEFINE= SPF
OPTIONS_DEFAULT= SPF
-SPF_DESC= Include direct SPF checking support
-SPF_BUILD_DEPENDS+= libspf2>=1.2.5:${PORTSDIR}/mail/libspf2
+SPF_DESC= Enable support for SPF record checking
+
+SPF_LIB_DEPENDS= libspf2.so:${PORTSDIR}/mail/libspf2
+SPF_CONFIGURE_ON= --with-spf \
+ --with-spf2-include=${LOCALBASE}/include/spf2 \
+ --with-spf2-lib=${LOCALBASE}/lib
+
+SHEBANG_FILES= reports/opendmarc-expire.in \
+ reports/opendmarc-import.in \
+ reports/opendmarc-params.in \
+ reports/opendmarc-reports.in
-.include <bsd.port.options.mk>
+PORTDOCS= *
-.if ${PORT_OPTIONS:MSPF}
-CONFIGURE_ARGS+= --with-spf --with-spf2-include=${LOCALBASE}/include/spf2 --with-spf2-lib=${LOCALBASE}/lib
+.if !exists( /usr/include/libmilter/mfapi.h )
+BUILD_DEPENDS+= ${LOCALBASE}/include/libmilter/mfapi.h:${PORTSDIR}/mail/sendmail
+CFLAGS+= -I${LOCALBASE}/include
.endif
post-install: