aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-Tools
diff options
context:
space:
mode:
Diffstat (limited to 'mail/p5-Mail-Tools')
-rw-r--r--mail/p5-Mail-Tools/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/mail/p5-Mail-Tools/Makefile b/mail/p5-Mail-Tools/Makefile
index b0408c1e6fc9..fa0a95506ff4 100644
--- a/mail/p5-Mail-Tools/Makefile
+++ b/mail/p5-Mail-Tools/Makefile
@@ -15,9 +15,6 @@ DISTNAME= MailTools-${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
-BUILD_DEPENDS= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
@@ -32,4 +29,11 @@ MAN3= Mail::Address.3 \
Mail::Send.3 \
Mail::Util.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>