aboutsummaryrefslogtreecommitdiff
path: root/mail/pear-Mail_Mime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/pear-Mail_Mime/Makefile')
-rw-r--r--mail/pear-Mail_Mime/Makefile27
1 files changed, 4 insertions, 23 deletions
diff --git a/mail/pear-Mail_Mime/Makefile b/mail/pear-Mail_Mime/Makefile
index 676e1b46b488..713fa196c8cf 100644
--- a/mail/pear-Mail_Mime/Makefile
+++ b/mail/pear-Mail_Mime/Makefile
@@ -7,32 +7,17 @@
PORTNAME= Mail_Mime
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR classes to create and decode MIME messages
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR
-RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
-
-NO_BUILD= yes
+BUILD_DEPENDS= ${PEARDIR}/Mail/mail.php:${PORTSDIR}/mail/pear-Mail
+RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.else
-PHP_BASE= ${LOCALBASE}
-.endif
-PEAR= ${LOCALBASE}/bin/pear
-LPHP_LIB= lib/php
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
do-install:
@${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Mail
@@ -41,8 +26,4 @@ do-install:
@${CHMOD} a-x ${PEARDIR}/Mail/${BUGMODE}
.endfor
-post-install:
-# Register a new package
- @${PEAR} install -r -f ${WRKDIR}/package.xml
-
.include <bsd.port.post.mk>