aboutsummaryrefslogtreecommitdiff
path: root/mail/pfqueue
diff options
context:
space:
mode:
Diffstat (limited to 'mail/pfqueue')
-rw-r--r--mail/pfqueue/Makefile25
-rw-r--r--mail/pfqueue/distinfo6
-rw-r--r--mail/pfqueue/pkg-descr3
-rw-r--r--mail/pfqueue/pkg-plist3
4 files changed, 22 insertions, 15 deletions
diff --git a/mail/pfqueue/Makefile b/mail/pfqueue/Makefile
index c10df276e1e1..08fc3e1c9f79 100644
--- a/mail/pfqueue/Makefile
+++ b/mail/pfqueue/Makefile
@@ -5,21 +5,26 @@
# $FreeBSD$
#
-PORTNAME= pfqueue
-PORTVERSION= 0.5.0
-CATEGORIES= mail
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+PORTNAME= pfqueue
+PORTVERSION= 0.5.1
+DISTVERSIONSUFFIX= -src
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= mnag@FreeBSD.org
-COMMENT= A console-based tool for handling Postfix 1, Postfix 2 and Exim queues
+MAINTAINER= mnag@FreeBSD.org
+COMMENT= A console-based tool for handling Postfix 1, Postfix 2 and Exim queues
-USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME:S/${DISTVERSIONSUFFIX}//}
+
+USE_REINPLACE= yes
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-MAN1= pfqueue.1
+MAN1= pfqueue.1
post-patch:
@${REINPLACE_CMD} -e "s|-lc_r|${PTHREAD_LIBS}|g; s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
diff --git a/mail/pfqueue/distinfo b/mail/pfqueue/distinfo
index 338b7f5d8843..229f86e7074a 100644
--- a/mail/pfqueue/distinfo
+++ b/mail/pfqueue/distinfo
@@ -1,3 +1,3 @@
-MD5 (pfqueue-0.5.0.tar.gz) = eb68b3a29267d1ad61e858cf2283cbcf
-SHA256 (pfqueue-0.5.0.tar.gz) = 28719ab05f905b2437ccd0432c2180e8c71096b7e713b2ee9a8383ef46a7f09b
-SIZE (pfqueue-0.5.0.tar.gz) = 320155
+MD5 (pfqueue-0.5.1-src.tar.gz) = 3e69b58e950845d12172718abaa369fc
+SHA256 (pfqueue-0.5.1-src.tar.gz) = a65d8f09d94c690c205398634c0e97f475b53838df9988e34f0cff83ae7c6d30
+SIZE (pfqueue-0.5.1-src.tar.gz) = 327753
diff --git a/mail/pfqueue/pkg-descr b/mail/pfqueue/pkg-descr
index b09a6bf7ce76..176c8f4aca1c 100644
--- a/mail/pfqueue/pkg-descr
+++ b/mail/pfqueue/pkg-descr
@@ -9,5 +9,4 @@ what is falling into and unexpectedly crowding your deferred queue.
WWW: http://pfqueue.sourceforge.net/
-- Marcus Alves Grando
-mnag@FreeBSD.org
+Marcus Alves Grando <mnag@FreeBSD.org>
diff --git a/mail/pfqueue/pkg-plist b/mail/pfqueue/pkg-plist
index b12612955a0e..e6df62354ab3 100644
--- a/mail/pfqueue/pkg-plist
+++ b/mail/pfqueue/pkg-plist
@@ -1,9 +1,12 @@
bin/pfqueue
+bin/spfqueue
lib/libpfq_exim.so
lib/libpfq_exim.so.0
lib/libpfq_postfix1.so
lib/libpfq_postfix1.so.0
lib/libpfq_postfix2.so
lib/libpfq_postfix2.so.0
+lib/libpfq_socket.so
+lib/libpfq_socket.so.0
lib/libpfqueue.so
lib/libpfqueue.so.0