aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-current/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postfix-current/Makefile')
-rw-r--r--mail/postfix-current/Makefile43
1 files changed, 20 insertions, 23 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index fcb337cfc627..5a75f95471fc 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -7,7 +7,7 @@
# To pre-select options in batch mode, run make like this:
#
-# make -DBATCH POSTFIX_OPTIONS="DB3 IPv6TLS"
+# make -DBATCH POSTFIX_OPTIONS="DB3 TLS"
#
# the options are the same names as in the scripts/configure.postfix file.
# POSTFIX_OPTIONS can be set in /etc/make.conf also.
@@ -15,7 +15,7 @@
# NOTE: PCRE is enabled by default unless you specifically disable it.
PORTNAME= postfix
-PORTVERSIONRAW= 2.2-20041030
+PORTVERSIONRAW= 2.2-20050212
PORTVERSION= ${PORTVERSIONRAW:S/-/./}
PORTEPOCH= 2
CATEGORIES= mail ipv6
@@ -30,7 +30,7 @@ MASTER_SITE_SUBDIR= . old related/postfix
DISTNAME= postfix-${PORTVERSIONRAW}
DIST_SUBDIR= ${PORTNAME}
-MAINTAINER= vivek@khera.org
+MAINTAINER= marcus@corp.grupos.com.br
COMMENT= A secure alternative to widely-used Sendmail
CONFLICTS= courier-0.* postfix-1.* postfix-2.0.* postfix-2.1.* sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
@@ -45,19 +45,16 @@ MAN1= mailq.1 newaliases.1 postalias.1 postcat.1 postconf.1 postdrop.1 \
MAN5= access.5 aliases.5 canonical.5 cidr_table.5 ldap_table.5 \
mysql_table.5 pgsql_table.5 postconf.5 pcre_table.5 \
regexp_table.5 relocated.5 tcp_table.5 transport.5 virtual.5 \
- header_checks.5 body_checks.5 master.5 nisplus_table.5
+ header_checks.5 body_checks.5 master.5 nisplus_table.5 \
+ generic.5
MAN8= anvil.8 bounce.8 cleanup.8 defer.8 error.8 flush.8 lmtp.8 local.8 \
master.8 oqmgr.8 pickup.8 pipe.8 proxymap.8 qmgr.8 qmqpd.8 showq.8 \
smtp.8 smtpd.8 spawn.8 trace.8 trivial-rewrite.8 verify.8 virtual.8 \
- scache.8 discard.8
-
-# TLS patch adds to MAN8 but doesn't have .html file, so avoid trying to
-# patch it.
-MAN8base=$(MAN8:S/tlsmgr.8//)
+ scache.8 discard.8 tlsmgr.8
CONF1= main.cf master.cf access aliases canonical header_checks relocated \
- transport virtual
+ transport virtual generic
README= ADDRESS_CLASS_README ADDRESS_REWRITING_README \
ADDRESS_VERIFICATION_README BACKSCATTER_README \
@@ -70,7 +67,7 @@ README= ADDRESS_CLASS_README ADDRESS_REWRITING_README \
SASL_README SCHEDULER_README SMTPD_ACCESS_README SMTPD_POLICY_README \
SMTPD_PROXY_README STANDARD_CONFIGURATION_README TUNING_README \
ULTRIX_README UUCP_README VERP_README VIRTUAL_README \
- XCLIENT_README XFORWARD_README
+ XCLIENT_README XFORWARD_README IPV6_README TLS_README
.if !defined(DEBUG)
MAKEFILEFLAGS+= DEBUG=
@@ -138,18 +135,18 @@ READMEDIR=${PREFIX}/share/doc/postfix
do-install:
cd ${WRKSRC}; ${SH} postfix-install -non-interactive install_root=/ tempdir=/tmp \
- config_directory=${PREFIX}/etc/postfix \
- daemon_directory=${PREFIX}/libexec/postfix \
- command_directory=${PREFIX}/sbin \
- queue_directory=/var/spool/postfix \
- sendmail_path=${PREFIX}/sbin/sendmail \
- newaliases_path=${PREFIX}/bin/newaliases \
- mailq_path=${PREFIX}/bin/mailq \
- mail_owner=postfix \
- setgid_group=maildrop \
- manpage_directory=${PREFIX}/man \
- sample_directory=${PREFIX}/etc/postfix \
- readme_directory=${READMEDIR}
+ config_directory=${PREFIX}/etc/postfix \
+ daemon_directory=${PREFIX}/libexec/postfix \
+ command_directory=${PREFIX}/sbin \
+ queue_directory=/var/spool/postfix \
+ sendmail_path=${PREFIX}/sbin/sendmail \
+ newaliases_path=${PREFIX}/bin/newaliases \
+ mailq_path=${PREFIX}/bin/mailq \
+ mail_owner=postfix \
+ setgid_group=maildrop \
+ manpage_directory=${PREFIX}/man \
+ sample_directory=${PREFIX}/etc/postfix \
+ readme_directory=${READMEDIR}
.for f in ${CONF1}
${INSTALL_DATA} ${WRKSRC}/conf/${f} \