aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-current/scripts/configure.postfix
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postfix-current/scripts/configure.postfix')
-rw-r--r--mail/postfix-current/scripts/configure.postfix56
1 files changed, 32 insertions, 24 deletions
diff --git a/mail/postfix-current/scripts/configure.postfix b/mail/postfix-current/scripts/configure.postfix
index a55fe39f2da1..b4481e939102 100644
--- a/mail/postfix-current/scripts/configure.postfix
+++ b/mail/postfix-current/scripts/configure.postfix
@@ -7,28 +7,36 @@ fi
tempfile=`mktemp -t checklist`
-if [ "${BATCH}" = "yes" ]; then
- set \"PCRE\"
+if [ "${POSTFIX_OPTIONS}" ]; then
+ set ${POSTFIX_OPTIONS}
else
+ set PCRE
+fi
+
+for i; do
+ eval status_$i=ON
+done
+
+if [ -z "${BATCH}" ]; then
/usr/bin/dialog --title "Postfix configuration options" --clear \
--checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
-SASL "Cyrus SASLv1 (Simple Authentication and Security Layer)" OFF \
-SASL2 "Cyrus SASLv2 (Simple Authentication and Security Layer)" OFF \
-DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
-MySQL "MySQL map lookups" OFF \
-PgSQL "PostgreSQL map lookups" OFF \
-OpenLDAP "OpenLDAP map lookups" OFF \
-Test "SMTP/LMTP test server and generator" OFF \
-TLS "SSL and TLS" OFF \
-IPv6 "IPv6 support (currently broken)" OFF \
+PCRE "Perl Compatible Regular Expressions" "$status_PCRE" \
+SASL "Cyrus SASLv1 (Simple Authentication and Security Layer)" "$status_SASL" \
+SASL2 "Cyrus SASLv2 (Simple Authentication and Security Layer)" "$status_SASL2" \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" "$status_DB3" \
+MySQL "MySQL map lookups" "$status_MySQL" \
+PgSQL "PostgreSQL map lookups" "$status_PgSQL" \
+OpenLDAP "OpenLDAP map lookups" "$status_OpenLDAP" \
+Test "SMTP/LMTP test server and generator" "$status_Test" \
+TLS "SSL and TLS (currently broken)" "$status_TLS" \
+IPv6 "IPv6 support (currently broken)" "$status_IPv6" \
2> $tempfile
retval=$?
if [ -s $tempfile ]; then
- set `cat $tempfile`
+ set `sed 's/"//g' $tempfile`
fi
rm -f $tempfile
@@ -53,14 +61,14 @@ SUB_TEST="@comment "
while [ "$1" ]; do
case $1 in
- \"PCRE\")
+ PCRE)
echo "LIB_DEPENDS+= pcre.0:\${PORTSDIR}/devel/pcre"
echo "POSTFIX_CCARGS+= -DHAS_PCRE -I\${LOCALBASE}/include"
echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lpcre"
echo "PCRE_SUFFIX= +pcre"
SUB_PCRE=""
;;
- \"SASL\")
+ SASL)
echo "LIB_DEPENDS+= sasl.8:\${PORTSDIR}/security/cyrus-sasl"
echo "POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I\${LOCALBASE}/include -I\${LOCALBASE}/include/sasl1"
echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lsasl -lpam -lcrypt"
@@ -79,7 +87,7 @@ while [ "$1" ]; do
echo ".endif"
SUB_SASL=""
;;
- \"SASL2\")
+ SASL2)
echo "LIB_DEPENDS+= sasl2.2:\${PORTSDIR}/security/cyrus-sasl2"
echo "POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I\${LOCALBASE}/include -I\${LOCALBASE}/include/sasl"
echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lsasl2 -lpam -lcrypt"
@@ -98,7 +106,7 @@ while [ "$1" ]; do
echo ".endif"
SUB_SASL=""
;;
- \"TLS\")
+ TLS)
echo "MAN8+= tlsmgr.8"
echo "POSTFIX_CCARGS+= -DHAS_SSL -I/usr/include/openssl"
echo "POSTFIX_AUXLIBS+= -lssl -lcrypto"
@@ -108,19 +116,19 @@ while [ "$1" ]; do
echo "TLS_SUFFIX= +tls"
SUB_TLS=""
;;
- \"DB3\")
- echo "LIB_DEPENDS+= db3.2:\${PORTSDIR}/databases/db3"
+ DB3)
+ echo "LIB_DEPENDS+= db3.3:\${PORTSDIR}/databases/db3"
echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db3"
echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -ldb3"
echo "DB3_SUFFIX= +db3"
;;
- \"MySQL\")
+ MySQL)
echo "BUILD_DEPENDS+= \${LOCALBASE}/lib/mysql/libmysqlclient.a:\${PORTSDIR}/databases/mysql323-client"
echo "POSTFIX_CCARGS+= -DHAS_MYSQL -I\${LOCALBASE}/include/mysql"
echo "POSTFIX_AUXLIBS+= \${LOCALBASE}/lib/mysql/libmysqlclient.a -lm -lz"
echo "MYSQL_SUFFIX= +mysql"
;;
- \"PgSQL\")
+ PgSQL)
echo "LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7"
echo "POSTFIX_CCARGS+= -DHAS_PGSQL -I\${LOCALBASE}/include -I\${LOCALBASE}/pgsql/include"
echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -L\${LOCALBASE}/pgsql/lib -lpq -lcrypt"
@@ -129,17 +137,17 @@ while [ "$1" ]; do
echo "PATCHFILES+= postfix-pg.postfix-1.1.8.patch"
echo "PATCH_DIST_STRIP= -p1"
;;
- \"OpenLDAP\")
+ OpenLDAP)
echo "BUILD_DEPENDS+= \${LOCALBASE}/lib/libldap.a:\${PORTSDIR}/net/openldap"
echo "POSTFIX_CCARGS+= -DHAS_LDAP -I\${LOCALBASE}/include"
echo "POSTFIX_AUXLIBS+= \${LOCALBASE}/lib/libldap.a \${PREFIX}/lib/liblber.a"
echo "OPENLDAP_SUFFIX= +openldap"
;;
- \"Test\")
+ Test)
echo "BIN1= smtp-sink smtp-source"
SUB_TEST=""
;;
- \"IPv6\")
+ IPv6)
if [ `uname -m` != "i386" ]; then
/usr/bin/dialog --msgbox "IPv6 patch currently only supported on i386!" 5 60 > /dev/stderr
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc