aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix22/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postfix22/Makefile')
-rw-r--r--mail/postfix22/Makefile117
1 files changed, 44 insertions, 73 deletions
diff --git a/mail/postfix22/Makefile b/mail/postfix22/Makefile
index 8bcb312b0e37..8d54f9120ef0 100644
--- a/mail/postfix22/Makefile
+++ b/mail/postfix22/Makefile
@@ -15,8 +15,7 @@
# NOTE: PCRE is enabled by default unless you specifically disable it.
PORTNAME= postfix
-PORTVERSION= 2.1.5
-PORTREVISION= 1
+PORTVERSION= 2.2.1
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -32,42 +31,26 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= vivek@khera.org
COMMENT= A secure alternative to widely-used Sendmail
-CONFLICTS= courier-0.* postfix-1.* postfix-2.0.* sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
+CONFLICTS= courier-0.* postfix-1.* postfix-2.0.* postfix-2.1.* postfix-2.3.* \
+ sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
USE_SUBMAKE= yes
USE_REINPLACE= yes
-MAN1= mailq.1 newaliases.1 postalias.1 postcat.1 postconf.1 postdrop.1 \
- postfix.1 postkick.1 postlock.1 postlog.1 postmap.1 postqueue.1 \
- postsuper.1 sendmail.1
-
-MAN5= access.5 aliases.5 canonical.5 cidr_table.5 ldap_table.5 \
- mysql_table.5 pgsql_table.5 postconf.5 pcre_table.5 \
- regexp_table.5 relocated.5 transport.5 virtual.5 \
- header_checks.5 body_checks.5
-
-MAN8= bounce.8 cleanup.8 defer.8 error.8 flush.8 lmtp.8 local.8 \
- master.8 oqmgr.8 pickup.8 pipe.8 proxymap.8 qmgr.8 qmqpd.8 showq.8 \
- smtp.8 smtpd.8 spawn.8 trace.8 trivial-rewrite.8 verify.8 virtual.8
-
-# TLS patch adds to MAN8 but doesn't have .html file, so avoid trying to
-# patch it.
-MAN8base=$(MAN8:S/tlsmgr.8//)
-
-CONF1= main.cf master.cf access aliases canonical header_checks relocated \
- transport virtual
-
-README= ADDRESS_CLASS_README ADDRESS_REWRITING_README \
- ADDRESS_VERIFICATION_README BACKSCATTER_README \
- BASIC_CONFIGURATION_README BUILTIN_FILTER_README \
- CONTENT_INSPECTION_README CYRUS_README DATABASE_README DB_README \
- DEBUG_README ETRN_README FILTER_README INSTALL LDAP_README \
- LINUX_README LMTP_README LOCAL_RECIPIENT_README MAILDROP_README \
- MYSQL_README NFS_README OVERVIEW PACKAGE_README PCRE_README \
- PGSQL_README QMQP_README QSHAPE_README RESTRICTION_CLASS_README \
- SASL_README SCHEDULER_README SMTPD_ACCESS_README SMTPD_POLICY_README \
- SMTPD_PROXY_README STANDARD_CONFIGURATION_README TUNING_README \
- ULTRIX_README UUCP_README VERP_README VIRTUAL_README \
- XCLIENT_README XFORWARD_README
+MAN1= mailq.1 newaliases.1 postalias.1 postcat.1 postconf.1 postdrop.1 postfix.1 \
+ postkick.1 postlock.1 postlog.1 postmap.1 postqueue.1 postsuper.1 sendmail.1
+
+MAN5= access.5 aliases.5 body_checks.5 canonical.5 cidr_table.5 generic.5 \
+ header_checks.5 ldap_table.5 master.5 mysql_table.5 nisplus_table.5 \
+ pcre_table.5 pgsql_table.5 postconf.5 regexp_table.5 relocated.5 \
+ transport.5 virtual.5
+
+MAN8= anvil.8 bounce.8 cleanup.8 defer.8 discard.8 error.8 flush.8 lmtp.8 \
+ local.8 master.8 oqmgr.8 pickup.8 pipe.8 proxymap.8 qmgr.8 qmqpd.8 \
+ scache.8 showq.8 smtp.8 smtpd.8 spawn.8 tlsmgr.8 trace.8 trivial-rewrite.8 \
+ verify.8 virtual.8
+
+CONF1= access aliases canonical generic header_checks main.cf master.cf \
+ relocated transport virtual
.if !defined(DEBUG)
MAKEFILEFLAGS+= DEBUG=
@@ -101,28 +84,16 @@ post-patch:
${ECHO} "all: default" >> Makefile)
pre-patch:
- ${ECHO} "<body>See <A HREF="header_checks.5.html">header_checks.5.html</A></BODY>" > ${WRKSRC}/html/body_checks.5.html
-.for file in ${MAN1}
- @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
- ${WRKSRC}/man/man1/${file} ${WRKSRC}/html/${file}.html
-.endfor
-.for file in ${MAN5}
- @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
- ${WRKSRC}/man/man5/${file} ${WRKSRC}/html/${file}.html
-.endfor
-.for file in ${MAN8base}
- @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
- ${WRKSRC}/man/man8/${file} ${WRKSRC}/html/${file}.html
-.endfor
-.for file in ${README}
- @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
- ${WRKSRC}/html/${file}.html
- @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
- ${WRKSRC}/README_FILES/${file}
-.endfor
-.for file in ${CONF1}
- @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" ${WRKSRC}/conf/${file}
-.endfor
+ @${ECHO} "<body>See <A HREF="header_checks.5.html">header_checks.5.html</A></BODY>" > ${WRKSRC}/html/body_checks.5.html
+ @for f in `${FIND} -P ${WRKSRC}/man -type f`; do \
+ ${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" $${f}; \
+ done
+ @for f in `${FIND} -P ${WRKSRC}/README_FILES -type f`; do \
+ ${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" $${f}; \
+ done
+ @for f in `${FIND} -P ${WRKSRC}/conf -type f`; do \
+ ${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" $${f}; \
+ done
pre-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -135,22 +106,22 @@ READMEDIR=${PREFIX}/share/doc/postfix
do-install:
cd ${WRKSRC}; ${SH} postfix-install -non-interactive install_root=/ tempdir=/tmp \
- config_directory=${PREFIX}/etc/postfix \
- daemon_directory=${PREFIX}/libexec/postfix \
- command_directory=${PREFIX}/sbin \
- queue_directory=/var/spool/postfix \
- sendmail_path=${PREFIX}/sbin/sendmail \
- newaliases_path=${PREFIX}/bin/newaliases \
- mailq_path=${PREFIX}/bin/mailq \
- mail_owner=postfix \
- setgid_group=maildrop \
- manpage_directory=${PREFIX}/man \
- sample_directory=${PREFIX}/etc/postfix \
- readme_directory=${READMEDIR}
-
-.for file in ${CONF1}
- ${INSTALL_DATA} ${WRKSRC}/conf/${file} \
- ${PREFIX}/etc/postfix/dist-${file}
+ config_directory=${PREFIX}/etc/postfix \
+ daemon_directory=${PREFIX}/libexec/postfix \
+ command_directory=${PREFIX}/sbin \
+ queue_directory=/var/spool/postfix \
+ sendmail_path=${PREFIX}/sbin/sendmail \
+ newaliases_path=${PREFIX}/bin/newaliases \
+ mailq_path=${PREFIX}/bin/mailq \
+ mail_owner=postfix \
+ setgid_group=maildrop \
+ manpage_directory=${PREFIX}/man \
+ sample_directory=${PREFIX}/etc/postfix \
+ readme_directory=${READMEDIR}
+
+ @${MKDIR} ${PREFIX}/etc/postfix/dist
+.for f in ${CONF1}
+ ${INSTALL_DATA} ${WRKSRC}/conf/${f} ${PREFIX}/etc/postfix/dist
.endfor
@${INSTALL_SCRIPT} \