aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix24
diff options
context:
space:
mode:
Diffstat (limited to 'mail/postfix24')
-rw-r--r--mail/postfix24/scripts/configure.postfix25
1 files changed, 20 insertions, 5 deletions
diff --git a/mail/postfix24/scripts/configure.postfix b/mail/postfix24/scripts/configure.postfix
index a7895ca1d6d2..d6a986215559 100644
--- a/mail/postfix24/scripts/configure.postfix
+++ b/mail/postfix24/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix24/scripts/Attic/configure.postfix,v 1.2 2001-03-05 22:15:24 knu Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix24/scripts/Attic/configure.postfix,v 1.3 2001-03-11 19:53:59 alex Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -10,18 +10,33 @@ tempfile=`mktemp -t checklist`
if [ "${BATCH}" = "yes" ]; then
set \"PCRE\"
else
- /usr/bin/dialog --title "Postfix configuration options" --clear \
- --checklist "\n\
+ # IPv6 patches are broken on alpha
+ if [ `uname -m` = "alpha" ]; then
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
Please select desired options:" -1 -1 16 \
-PCRE "Perl Compatible Regular Expressions" OFF \
+PCRE "Perl Compatible Regular Expressions" ON \
SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
MySQL "MySQL map lookups" OFF \
OpenLDAP "OpenLDAP map lookups" OFF \
Test "SMTP/LMTP test server and generator" OFF \
TLS "Secure Sockets Layer and Transport Layer Security" OFF \
-IPv6 "IPv6 support" OFF \
2> $tempfile
+ else
+ /usr/bin/dialog --title "Postfix configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+PCRE "Perl Compatible Regular Expressions" ON \
+SASL "Cyrus SASL (Simple Authentication and Security Layer)" OFF \
+DB3 "Berkeley DB3 (required if SASL also built with DB3)" OFF \
+MySQL "MySQL map lookups" OFF \
+OpenLDAP "OpenLDAP map lookups" OFF \
+Test "SMTP/LMTP test server and generator" OFF \
+TLS "Secure Sockets Layer and Transport Layer Security" OFF \
+IPv6 "IPv6 support" OFF
+2> $tempfile
+ fi
retval=$?