aboutsummaryrefslogtreecommitdiff
path: root/mail/qsf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/qsf/Makefile')
-rw-r--r--mail/qsf/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/mail/qsf/Makefile b/mail/qsf/Makefile
index ae4f9d097f6b..a0a3a9117e5d 100644
--- a/mail/qsf/Makefile
+++ b/mail/qsf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qsf
PORTVERSION= 1.0.18
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= qsf
@@ -18,6 +19,8 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_REINPLACE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
MAN1= qsf.1
MANCOMPRESSED= yes
PLIST_FILES= bin/qsf
@@ -30,17 +33,17 @@ OPTIONS= GDBM "GDBM support" off \
.if defined(WITH_GDBM)
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
-CONFIGURE_ARGS+= --with-gdbm=${LOCALBASE}
+CONFIGURE_ARGS+= --with-gdbm
.endif
.if defined(WITH_MYSQL)
USE_MYSQL= yes
-CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
+CONFIGURE_ARGS+= --with-mysql
.endif
.if defined(WITH_SQLITE2)
LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite2
-CONFIGURE_ARGS+= --with-sqlite=${LOCALBASE}
+CONFIGURE_ARGS+= --with-sqlite
.endif
# not supported yet.