aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube-contextmenu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/roundcube-contextmenu/Makefile')
-rw-r--r--mail/roundcube-contextmenu/Makefile34
1 files changed, 19 insertions, 15 deletions
diff --git a/mail/roundcube-contextmenu/Makefile b/mail/roundcube-contextmenu/Makefile
index 5553880a0f6e..2283c507eb05 100644
--- a/mail/roundcube-contextmenu/Makefile
+++ b/mail/roundcube-contextmenu/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= contextmenu
-PORTVERSION= 1.10 # PLEASE MIRROR DISTFILE WITH VERSIONED DIR
+PORTVERSION= 1.13
CATEGORIES= mail
-MASTER_SITES= http://www.tehinterweb.co.uk/roundcube/plugins/ \
- LOCAL/bdrewery/${PORTNAME}/${PORTVERSION}/
+MASTER_SITES= GH
PKGNAMEPREFIX= roundcube-
DISTNAME= ${PORTNAME}
@@ -14,24 +13,29 @@ COMMENT= RoundCube webmail contextmenu plugin
LICENSE= GPLv2
-RUN_DEPENDS= roundcube>=0.9:${PORTSDIR}/mail/roundcube
+RUN_DEPENDS= roundcube>=1.0:${PORTSDIR}/mail/roundcube
NO_BUILD= yes
-WWWDIR?= ${PREFIX}/www/roundcube/plugins/contextmenu
+USE_GITHUB= YES
+GH_ACCOUNT= JohnDoh
+GH_PROJECT= Roundcube-Plugin-Context-Menu
+GH_TAGNAME= 1.13
+GH_COMMIT= 53e7f7c
+
+PLUGINDIR= ${WWWDIR:S,/${PORTNAME}$$,,}/roundcube/plugins/${PORTNAME}
+RCDIR_REL= ${WWWDIR_REL:S,/${PORTNAME}$$,,}/roundcube
+PLIST_SUB= RCDIR_REL="${RCDIR_REL}"
# This target is only meant to be used by the port maintainer.
x-generate-plist: build
- cd ${WRKSRC}; \
- ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
- ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
- ${FIND} . -type d | ${SORT} -r | ${SED} \
- -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
- -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
-
-NO_STAGE= yes
+ make makeplist | \
+ ${SED} \
+ -e "s,^\(@dirrm\)try\( %%RCDIR_REL%%/plugins/contextmenu\),\1\2," \
+ >${.CURDIR}/pkg-plist.tmp
+
do-install:
- ${MKDIR} ${WWWDIR}
- cd ${WRKSRC} && ${PAX} -r -w . ${WWWDIR}
+ ${MKDIR} ${STAGEDIR}${PLUGINDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${PLUGINDIR}
.include <bsd.port.mk>