aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube-contextmenu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/roundcube-contextmenu/Makefile')
-rw-r--r--mail/roundcube-contextmenu/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/mail/roundcube-contextmenu/Makefile b/mail/roundcube-contextmenu/Makefile
new file mode 100644
index 000000000000..1c5b9b802aca
--- /dev/null
+++ b/mail/roundcube-contextmenu/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: roundcube-contextmenu
+# Date created: 27 Oct 2011
+# Whom: Alexander Moisseev <moiseev@mezonplus.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= contextmenu
+PORTVERSION= 1.8
+CATEGORIES= mail
+MASTER_SITES= http://www.tehinterweb.co.uk/roundcube/plugins/
+PKGNAMEPREFIX= roundcube-
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= moiseev@mezonplus.ru
+COMMENT= RoundCube webmail contextmenu plugin
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= roundcube>=0.6:${PORTSDIR}/mail/roundcube
+
+NO_BUILD= yes
+
+WWWDIR?= ${PREFIX}/www/roundcube/plugins/contextmenu
+
+# This target is only meant to be used by the port maintainer.
+x-generate-plist: build
+ cd ${WRKSRC}; \
+ ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
+ ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
+ ${FIND} . -type d | ${SORT} -r | ${SED} \
+ -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
+ -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+ cd ${WRKSRC} && ${PAX} -r -w . ${WWWDIR}
+
+.include <bsd.port.mk>