aboutsummaryrefslogtreecommitdiff
path: root/mail/roundcube/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/roundcube/Makefile')
-rw-r--r--mail/roundcube/Makefile33
1 files changed, 32 insertions, 1 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index 1e97ddece946..80fcf8e3e761 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -16,7 +16,7 @@ DISTFILES= ${PORTNAME}-${PORTVERSION:S/.${SNAPSHOT}//}-${SNAPSHOT}${EXTRACT_SUFX
MAINTAINER= farrokhi@FreeBSD.org
COMMENT= Fully skinnable XHTML/CSS webmail written in PHP
-SNAPSHOT= 20061202
+SNAPSHOT= 20061207
WRKSRC= ${WRKDIR}/${PORTNAME}mail
NO_BUILD= yes
@@ -42,6 +42,13 @@ SUB_FILES= pkg-install
SUB_LIST= RCUBEROOT=${RCUBEROOT}
PKGDEINSTALL= ${PKGINSTALL}
+.if defined(WITH_REPLACE_MAIL_URL) && !empty(WITH_REPLACE_MAIL_URL)
+MAIL= ${WITH_REPLACE_MAIL_URL}
+REINPLACE_ARGS= -i ""
+.else
+MAIL= mail
+.endif
+PLIST_SUB+= MAIL=${MAIL}
LOCALBASE?= /usr/local
.if exists(${LOCALBASE}/etc/php.conf)
@@ -78,6 +85,30 @@ USE_PHP?= yes
.include "${PORTSDIR}/Mk/bsd.php.mk"
+.if defined(WITH_REPLACE_MAIL_URL)
+post-patch:
+ @${REINPLACE_CMD} "s/'mail'/'${MAIL}'/g" ${WRKSRC}/index.php \
+ ${WRKSRC}/program/include/main.inc \
+ ${WRKSRC}/program/js/app.js
+ @${REINPLACE_CMD} "s/_task=mail/_task=${MAIL}/g" \
+ ${WRKSRC}/program/steps/mail/rss.inc
+ @${REINPLACE_CMD} "s/command=\"mail\"/command=\"${MAIL}\"/g" \
+ ${WRKSRC}/skins/default/includes/header.html \
+ ${WRKSRC}/skins/default/includes/taskbar.html
+ @${REINPLACE_CMD} "s/mail.gif/${MAIL}.gif/g" \
+ ${WRKSRC}/skins/default/common.css
+ @${REINPLACE_CMD} "s/mail.css/${MAIL}.css/g" \
+ ${WRKSRC}/skins/default/templates/*.html
+ @${MV} ${WRKSRC}/skins/default/images/buttons/mail.gif \
+ ${WRKSRC}/skins/default/images/buttons/${MAIL}.gif
+ @${MV} ${WRKSRC}/skins/default/images/buttons/mail.png \
+ ${WRKSRC}/skins/default/images/buttons/${MAIL}.png
+ @${MV} ${WRKSRC}/skins/default/mail.css \
+ ${WRKSRC}/skins/default/${MAIL}.css
+ @${MV} ${WRKSRC}/skins/default/templates/mail.html \
+ ${WRKSRC}/skins/default/templates/${MAIL}.html
+.endif
+
do-install:
${MKDIR} ${RCUBEROOT}
.for i in ${RCUBECOMP}