aboutsummaryrefslogtreecommitdiff
path: root/mail/sendmail-old/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/sendmail-old/Makefile')
-rw-r--r--mail/sendmail-old/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/mail/sendmail-old/Makefile b/mail/sendmail-old/Makefile
index 3770d87f19d7..4596b661f3c1 100644
--- a/mail/sendmail-old/Makefile
+++ b/mail/sendmail-old/Makefile
@@ -22,6 +22,9 @@ PLIST= ${WRKDIR}/.PLIST.more
.if defined(SENDMAIL_WITH_TSL)
USE_OPENSSL= yes
.endif
+.if defined(SENDMAIL_WITH_SASL)
+BUILD_DEPENDS= ${LOCALBASE}/sbin/pwcheck:${PORTSDIR}/security/cyrus-sasl
+.endif
.if exists(${DESTDIR}/etc/mail/mailer.conf)
pre-configure:
@@ -30,6 +33,10 @@ pre-configure:
.if defined(SENDMAIL_WITH_TSL)
${CAT} ${FILESDIR}/site.config.m4.tls >> ${WCONF}/site.config.m4
.endif
+.if defined(SENDMAIL_WITH_SASL)
+ ${SED} -e "s=%%LOCALBASE%%=${LOCALBASE}=" \
+ ${FILESDIR}/site.config.m4.sasl >>${WCONF}/site.config.m4
+.endif
.else
pre-configure:
${SED} -e "s=%%PREFIX%%=${PREFIX}=" \